summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-fps/ut2004-demo/ChangeLog12
-rw-r--r--games-fps/ut2004-demo/Manifest6
-rw-r--r--games-fps/ut2004-demo/files/digest-ut2004-demo-3120-r13
-rw-r--r--games-fps/ut2004-demo/ut2004-demo-3120-r1.ebuild54
-rw-r--r--games-fps/ut2004-demo/ut2004-demo-3120.ebuild11
5 files changed, 75 insertions, 11 deletions
diff --git a/games-fps/ut2004-demo/ChangeLog b/games-fps/ut2004-demo/ChangeLog
index ddfb934f2976..9be23b1713f9 100644
--- a/games-fps/ut2004-demo/ChangeLog
+++ b/games-fps/ut2004-demo/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for games-fps/ut2004-demo
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-demo/ChangeLog,v 1.3 2004/02/19 15:43:48 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-demo/ChangeLog,v 1.4 2004/02/20 18:51:28 augustus Exp $
+
+*ut2004-demo-3120-r1 (20 Feb 2004)
+
+ 20 Feb 2004; <augustus@gentoo.org> ut2004-demo-3120-r1.ebuild,
+ ut2004-demo-3120.ebuild:
+ Reverted ut2004-demo-3120.ebuild. The patch should have been in a new
+ release so that existing users would get it. I moved the changes to
+ ut2004-demo-3120-r1.ebuild and fixed it for AMD64. Please don't break other
+ ARCH with changes. -r1 is masked for now on AMD64 until icculus releases
+ an AMD64 patch.
19 Feb 2004; Chris Gianelloni <wolf31o2@gentoo.org> ut2004-demo-3120.ebuild:
Updated ebuild to include text-to-speech and server browser ping patches from
diff --git a/games-fps/ut2004-demo/Manifest b/games-fps/ut2004-demo/Manifest
index 87cd8ffcb615..1d668b709e98 100644
--- a/games-fps/ut2004-demo/Manifest
+++ b/games-fps/ut2004-demo/Manifest
@@ -1,4 +1,6 @@
-MD5 3bf8227d21dc480b2761b7f31efd6067 ChangeLog 661
-MD5 22fdddf01c1ad66fa76b3eb9ee3c2e75 ut2004-demo-3120.ebuild 1358
+MD5 7d5d0c981e1f00e0cbf6adc3ef84de11 ChangeLog 1103
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 73c56c6ff0ab0cf427b20969b5695ae6 ut2004-demo-3120-r1.ebuild 1399
+MD5 ee31b07c11059123bde9227164efbfd8 ut2004-demo-3120.ebuild 1244
MD5 60847139e60f6e8684262e26aa33d19c files/digest-ut2004-demo-3120 237
+MD5 60847139e60f6e8684262e26aa33d19c files/digest-ut2004-demo-3120-r1 237
diff --git a/games-fps/ut2004-demo/files/digest-ut2004-demo-3120-r1 b/games-fps/ut2004-demo/files/digest-ut2004-demo-3120-r1
new file mode 100644
index 000000000000..2ac87366e7da
--- /dev/null
+++ b/games-fps/ut2004-demo/files/digest-ut2004-demo-3120-r1
@@ -0,0 +1,3 @@
+MD5 da200b043add9d083f6aa7581e6829f0 ut2004-lnx-demo-3120.run.bz2 208802492
+MD5 aa44626fddafe4643e03cd777452d853 ut2004-demo-lnx-tts-pingpatch.tar.bz2 3294460
+MD5 3636e4c7ecadfccc152c7a7b456dc8ab ut2004-lnx64-demo-3120.run.bz2 211220807
diff --git a/games-fps/ut2004-demo/ut2004-demo-3120-r1.ebuild b/games-fps/ut2004-demo/ut2004-demo-3120-r1.ebuild
new file mode 100644
index 000000000000..f909c298f4f2
--- /dev/null
+++ b/games-fps/ut2004-demo/ut2004-demo-3120-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-demo/ut2004-demo-3120-r1.ebuild,v 1.1 2004/02/20 18:51:28 augustus Exp $
+
+inherit games eutils
+
+DESCRIPTION="Unreal Tournament 2004 Demo"
+HOMEPAGE="http://www.unrealtournament.com/"
+
+SRC_URI="x86? ( ftp://ftp.linuxhardware.org/ut2004/ut2004-lnx-demo-${PV}.run.bz2
+ http://www.lokigames.com/sekrit/ut2004-lnx-demo-${PV}.run.bz2
+ http://pomac.netswarm.net/mirror/games/ut2004/ut2004-lnx-demo-${PV}.run.bz2
+ http://icculus.org/~icculus/tmp/${PN}-lnx-tts-pingpatch.tar.bz2 )
+ amd64? ( mirror://gentoo/ut2004-lnx64-demo-${PV}.run.bz2 )"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* x86"
+
+DEPEND="!dedicated? ( virtual/opengl )"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ [ "${ARCH}" = "amd64" ] && RNAME="ut2004-lnx64-demo-${PV}.run"
+ [ "${ARCH}" = "x86" ] && RNAME="ut2004-lnx-demo-${PV}.run"
+ unpack_makeself ${RNAME}
+ rm ${RNAME}
+}
+
+src_install() {
+ local dir=/opt/${PN}
+ dodir ${dir}
+
+ tar -xf ut2004demo.tar -C ${D}/${dir}/ || die "unpacking ut2004 failed"
+
+ insinto ${dir}
+ doins README.linux ut2004demo.xpm
+
+ exeinto ${dir}
+ doexe bin/ut2004demo
+
+ dodir ${GAMES_BINDIR}
+ dosym ${dir}/ut2004demo ${GAMES_BINDIR}/ut2004demo
+
+ if [ "${ARCH}" = "amd64" ]; then
+ # Ping patch
+ exeinto ${dir}/System
+ doexe ut2004-bin
+ fi
+
+ prepgamesdirs
+}
diff --git a/games-fps/ut2004-demo/ut2004-demo-3120.ebuild b/games-fps/ut2004-demo/ut2004-demo-3120.ebuild
index 1f5de404c4fa..7c2b352eff7d 100644
--- a/games-fps/ut2004-demo/ut2004-demo-3120.ebuild
+++ b/games-fps/ut2004-demo/ut2004-demo-3120.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-demo/ut2004-demo-3120.ebuild,v 1.5 2004/02/19 15:43:48 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-demo/ut2004-demo-3120.ebuild,v 1.6 2004/02/20 18:51:28 augustus Exp $
inherit games eutils
@@ -9,13 +9,12 @@ HOMEPAGE="http://www.unrealtournament.com/"
SRC_URI="x86? ( ftp://ftp.linuxhardware.org/ut2004/ut2004-lnx-demo-${PV}.run.bz2
http://www.lokigames.com/sekrit/ut2004-lnx-demo-${PV}.run.bz2
- http://pomac.netswarm.net/mirror/games/ut2004/ut2004-lnx-demo-${PV}.run.bz2
- http://icculus.org/~icculus/tmp/${PN}-lnx-tts-pingpatch.tar.bz2 )
+ http://pomac.netswarm.net/mirror/games/ut2004/ut2004-lnx-demo-${PV}.run.bz2 )
amd64? ( mirror://gentoo/ut2004-lnx64-demo-${PV}.run.bz2 )"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="-* x86"
+KEYWORDS="-* x86 amd64"
DEPEND="!dedicated? ( virtual/opengl )"
@@ -44,9 +43,5 @@ src_install() {
dodir ${GAMES_BINDIR}
dosym ${dir}/ut2004demo ${GAMES_BINDIR}/ut2004demo
- # Ping patch
- exeinto ${dir}/System
- doexe ut2004-bin
-
prepgamesdirs
}