summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-strategy/ja2-stracciatella-data/ChangeLog10
-rw-r--r--games-strategy/ja2-stracciatella-data/Manifest3
-rw-r--r--games-strategy/ja2-stracciatella-data/ja2-stracciatella-data-1.ebuild64
-rw-r--r--games-strategy/ja2-stracciatella-data/metadata.xml10
4 files changed, 87 insertions, 0 deletions
diff --git a/games-strategy/ja2-stracciatella-data/ChangeLog b/games-strategy/ja2-stracciatella-data/ChangeLog
new file mode 100644
index 000000000000..67c7880e3145
--- /dev/null
+++ b/games-strategy/ja2-stracciatella-data/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-strategy/ja2-stracciatella-data
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/ja2-stracciatella-data/ChangeLog,v 1.1 2012/05/10 20:10:06 hasufell Exp $
+
+*ja2-stracciatella-data-1 (10 May 2012)
+
+ 10 May 2012; Julian Ospald <hasufell@gentoo.org>
+ +ja2-stracciatella-data-1.ebuild, +metadata.xml:
+ initial import wrt #171475
+
diff --git a/games-strategy/ja2-stracciatella-data/Manifest b/games-strategy/ja2-stracciatella-data/Manifest
new file mode 100644
index 000000000000..c8afa6780ff0
--- /dev/null
+++ b/games-strategy/ja2-stracciatella-data/Manifest
@@ -0,0 +1,3 @@
+EBUILD ja2-stracciatella-data-1.ebuild 1434 RMD160 b6a0ab2e11dfb130dd6d2860945f0d90e19dc116 SHA1 be9f915663332e284e1df6efe076a5709985b08d SHA256 4f6e845192a4892be433b22a924932a190b1b843b989651f141cc2741e1abc92
+MISC ChangeLog 311 RMD160 c42cd1f10c603645588a652192df771f0bdeb0b2 SHA1 cd97e28ab1568c2b10fd2261c958f01ec3017747 SHA256 e1672be581338aeacdd274599b857f2ca6a1c6f993fe61182d87ac40fa346a63
+MISC metadata.xml 255 RMD160 cc3f4166829c2668729ae9297e2f612390f51041 SHA1 e6e8defa0e59d10623400331ea0819a8822d0656 SHA256 8ce125b1cb2a8da5fe808223ae6ed60fe03598c692e5020f0a8aaee09b5d6ca3
diff --git a/games-strategy/ja2-stracciatella-data/ja2-stracciatella-data-1.ebuild b/games-strategy/ja2-stracciatella-data/ja2-stracciatella-data-1.ebuild
new file mode 100644
index 000000000000..deea7d0b8c7c
--- /dev/null
+++ b/games-strategy/ja2-stracciatella-data/ja2-stracciatella-data-1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/ja2-stracciatella-data/ja2-stracciatella-data-1.ebuild,v 1.1 2012/05/10 20:10:06 hasufell Exp $
+
+EAPI=3
+
+inherit cdrom check-reqs games
+
+DESCRIPTION="A port of Jagged Alliance 2 to SDL (data files)"
+HOMEPAGE="http://tron.homeunix.org/ja2/"
+SRC_URI=""
+
+LICENSE="SIR-TECH"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="games-strategy/ja2-stracciatella"
+DEPEND="app-arch/unshield"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ CHECKREQS_DISK_BUILD="3G"
+ CHECKREQS_DISK_USR="1G"
+ check-reqs_pkg_setup
+ games_pkg_setup
+}
+
+src_unpack() {
+ export CDROM_NAME="INSTALL_CD"
+
+ cdrom_get_cds INSTALL/data1.cab
+
+ # this makes some serious overhead
+ unshield x "${CDROM_ROOT}"/INSTALL/data1.cab || die "unpacking failed"
+}
+
+src_prepare() {
+ cd "${S}"/Ja2_Files/Data || die
+ local lower i
+
+ # convert to lowercase
+ find . \( -iname "*.jsd" -o -iname "*.wav" -o -iname "*.sti" -o -iname "*.slf" \) \
+ -exec sh -c 'echo "${1}"
+ lower="`echo "${1}" | tr [:upper:] [:lower:]`"
+ [ -d `dirname "${lower}"` ] || mkdir `dirname ${lower}`
+ [ "${1}" = "${lower}" ] || mv "${1}" "${lower}"' - {} \;
+
+ # remove possible leftover
+ rm -r ./TILECACHE ./STSOUNDS
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/ja2/data
+ doins -r "${S}"/Ja2_Files/Data/* || die
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "This is just the data portion of the game. You will need to install"
+ elog "games-strategy/ja2-stracciatella to play the game."
+}
diff --git a/games-strategy/ja2-stracciatella-data/metadata.xml b/games-strategy/ja2-stracciatella-data/metadata.xml
new file mode 100644
index 000000000000..e52db06ebd8c
--- /dev/null
+++ b/games-strategy/ja2-stracciatella-data/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ </maintainer>
+</pkgmetadata>
+