summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-puzzle/arrows/ChangeLog7
-rw-r--r--games-puzzle/arrows/arrows-0.6.ebuild19
2 files changed, 16 insertions, 10 deletions
diff --git a/games-puzzle/arrows/ChangeLog b/games-puzzle/arrows/ChangeLog
index 856a8b72c3b9..1e9238558a59 100644
--- a/games-puzzle/arrows/ChangeLog
+++ b/games-puzzle/arrows/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/arrows
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/arrows/ChangeLog,v 1.8 2008/03/07 16:44:46 wolf31o2 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/arrows/ChangeLog,v 1.9 2010/08/20 15:14:56 mr_bones_ Exp $
+
+ 20 Aug 2010; Michael Sterrett <mr_bones_@gentoo.org> arrows-0.6.ebuild:
+ EAPI=2; honor CC and LDFLAGS (bug #333607)
07 Mar 2008; Chris Gianelloni <wolf31o2@gentoo.org> arrows-0.6.ebuild:
QA cleanup: Shorten DESCRIPTION.
diff --git a/games-puzzle/arrows/arrows-0.6.ebuild b/games-puzzle/arrows/arrows-0.6.ebuild
index 65f2e330a6ff..c2685b0a359f 100644
--- a/games-puzzle/arrows/arrows-0.6.ebuild
+++ b/games-puzzle/arrows/arrows-0.6.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/arrows/arrows-0.6.ebuild,v 1.8 2008/03/07 16:44:46 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/arrows/arrows-0.6.ebuild,v 1.9 2010/08/20 15:14:56 mr_bones_ Exp $
+EAPI=2
inherit games
DESCRIPTION="simple maze-like game where you navigate around and destroy arrows"
@@ -13,14 +14,11 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE=""
-RDEPEND=">=x11-libs/gtk+-2.4.0"
+RDEPEND=">=x11-libs/gtk+-2.4:2"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# Modify path to data
sed -i \
-e "s:arrfl:${GAMES_DATADIR}/${PN}/arrfl:" \
@@ -28,7 +26,12 @@ src_unpack() {
-e 's:nm\[6:nm[30:' \
-e 's:nm\[7:nm[31:' \
game.c \
- || die "sed game.c failed"
+ || die 'sed failed'
+ sed -i \
+ -e '/^CC /d' \
+ -e '/CCLIBS/s:$: $(LDFLAGS):' \
+ Makefile \
+ || die 'sed failed'
}
src_compile() {