summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-strategy/wormux/ChangeLog9
-rw-r--r--games-strategy/wormux/files/digest-wormux-0.7.13
-rw-r--r--games-strategy/wormux/files/wormux-0.7.1-fix-gettext-Makefile.patch14
-rw-r--r--games-strategy/wormux/files/wormux-0.7.1-user-CFLAGS.patch13
-rw-r--r--games-strategy/wormux/wormux-0.7.1.ebuild49
5 files changed, 87 insertions, 1 deletions
diff --git a/games-strategy/wormux/ChangeLog b/games-strategy/wormux/ChangeLog
index 09b4243ef414..7caf65394eea 100644
--- a/games-strategy/wormux/ChangeLog
+++ b/games-strategy/wormux/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-strategy/wormux
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wormux/ChangeLog,v 1.8 2006/04/24 18:14:46 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wormux/ChangeLog,v 1.9 2006/04/27 07:09:32 mr_bones_ Exp $
+
+*wormux-0.7.1 (27 Apr 2006)
+
+ 27 Apr 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/wormux-0.7.1-fix-gettext-Makefile.patch,
+ +files/wormux-0.7.1-user-CFLAGS.patch, +wormux-0.7.1.ebuild:
+ version bump
24 Apr 2006; <squinky86@gentoo.org> wormux-0.7.ebuild:
Add ~amd64 keyword; bug #130942.
diff --git a/games-strategy/wormux/files/digest-wormux-0.7.1 b/games-strategy/wormux/files/digest-wormux-0.7.1
new file mode 100644
index 000000000000..2dbc9f430afd
--- /dev/null
+++ b/games-strategy/wormux/files/digest-wormux-0.7.1
@@ -0,0 +1,3 @@
+MD5 0e50fbdb63424e71ce19c0c48106793e wormux-0.7.1.tar.gz 21022945
+RMD160 fa4b9e42e8d5173fa7b01a488201ec5578008d12 wormux-0.7.1.tar.gz 21022945
+SHA256 143c0bf8cf741d52118f634ee30eb717b69b9689dce9ed8f47b9044e7affc476 wormux-0.7.1.tar.gz 21022945
diff --git a/games-strategy/wormux/files/wormux-0.7.1-fix-gettext-Makefile.patch b/games-strategy/wormux/files/wormux-0.7.1-fix-gettext-Makefile.patch
new file mode 100644
index 000000000000..9d28d6005b08
--- /dev/null
+++ b/games-strategy/wormux/files/wormux-0.7.1-fix-gettext-Makefile.patch
@@ -0,0 +1,14 @@
+--- wormux-0.7beta3/po/Makefile.in.orig 2006-01-24 16:07:54.000000000 +0100
++++ wormux-0.7beta3/po/Makefile.in 2006-01-24 16:08:09.000000000 +0100
+@@ -443,9 +443,9 @@
+ @sed -e '/^#/d' $< > t-$@
+ @mv t-$@ $@
+
+-all-local: all-local-@USE_NLS@ $(GMOFILES)
++all-local: all-local-@USE_NLS@
+
+-all-local-yes: stamp-po
++all-local-yes: $(GMOFILES)
+ all-local-no:
+
+ # stamp-po is a timestamp denoting the last time at which the CATALOGS have
diff --git a/games-strategy/wormux/files/wormux-0.7.1-user-CFLAGS.patch b/games-strategy/wormux/files/wormux-0.7.1-user-CFLAGS.patch
new file mode 100644
index 000000000000..0f6c0973fdc5
--- /dev/null
+++ b/games-strategy/wormux/files/wormux-0.7.1-user-CFLAGS.patch
@@ -0,0 +1,13 @@
+--- wormux-0.7/configure.orig 2006-04-04 23:41:28.000000000 +0200
++++ wormux-0.7/configure 2006-04-04 23:43:34.000000000 +0200
+@@ -6752,9 +6752,7 @@
+ GCC_FLAGS="$GCC_FLAGS -Wno-unused-parameter"
+
+ if test "${debug}" = "yes"; then
+- GCC_FLAGS="$GCC_FLAGS -O0 -g -DDEBUG"
+- else
+- GCC_FLAGS="$GCC_FLAGS -O2"
++ GCC_FLAGS="$GCC_FLAGS -DDEBUG"
+ fi
+
+ CFLAGS="$CFLAGS $GCC_FLAGS"
diff --git a/games-strategy/wormux/wormux-0.7.1.ebuild b/games-strategy/wormux/wormux-0.7.1.ebuild
new file mode 100644
index 000000000000..89336d3a9241
--- /dev/null
+++ b/games-strategy/wormux/wormux-0.7.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wormux/wormux-0.7.1.ebuild,v 1.1 2006/04/27 07:09:32 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="A free Worms clone"
+HOMEPAGE="http://www.wormux.org/"
+SRC_URI="http://download.gna.org/wormux/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug nls"
+
+RDEPEND=">=media-libs/libsdl-1.2.6
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-ttf-2.0
+ >=media-libs/sdl-gfx-2.0.13
+ >=dev-cpp/libxmlpp-2.6"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}/${P}-fix-gettext-Makefile.patch" \
+ "${FILESDIR}/${P}-user-CFLAGS.patch"
+}
+
+src_compile() {
+ egamesconf \
+ --with-datadir-name="${GAMES_DATADIR}/${PN}" \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README
+ newicon data/wormux-32.xpm wormux.xpm
+ make_desktop_entry wormux Wormux wormux.xpm
+ prepgamesdirs
+}