summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-servers/nginx/ChangeLog10
-rw-r--r--www-servers/nginx/files/nginx-0.8.32-ey-balancer.patch51
-rw-r--r--www-servers/nginx/metadata.xml2
-rw-r--r--www-servers/nginx/nginx-1.0.8.ebuild (renamed from www-servers/nginx/nginx-1.1.2.ebuild)6
-rw-r--r--www-servers/nginx/nginx-1.1.6.ebuild (renamed from www-servers/nginx/nginx-1.0.4.ebuild)125
5 files changed, 76 insertions, 118 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index ab249b221812..8fc75557eb3c 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.292 2011/10/04 21:32:48 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.293 2011/10/28 06:52:53 hollow Exp $
+
+*nginx-1.1.6 (28 Oct 2011)
+*nginx-1.0.8 (28 Oct 2011)
+
+ 28 Oct 2011; Benedikt Böhm <hollow@gentoo.org>
+ -files/nginx-0.8.32-ey-balancer.patch, -nginx-1.0.4.ebuild,
+ +nginx-1.0.8.ebuild, -nginx-1.1.2.ebuild, +nginx-1.1.6.ebuild, metadata.xml:
+ version bump wrt #385965
04 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> nginx-1.0.6.ebuild:
x86 stable wrt bug #385035
diff --git a/www-servers/nginx/files/nginx-0.8.32-ey-balancer.patch b/www-servers/nginx/files/nginx-0.8.32-ey-balancer.patch
deleted file mode 100644
index 2a58e877d012..000000000000
--- a/www-servers/nginx/files/nginx-0.8.32-ey-balancer.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-diff -Naur a/src/http/ngx_http_upstream.c b/src/http/ngx_http_upstream.c
---- a/src/http/ngx_http_upstream.c 2009-12-23 10:31:16.000000000 -0500
-+++ b/src/http/ngx_http_upstream.c 2010-01-20 15:26:24.000000000 -0500
-@@ -24,8 +24,6 @@
- static void ngx_http_upstream_wr_check_broken_connection(ngx_http_request_t *r);
- static void ngx_http_upstream_check_broken_connection(ngx_http_request_t *r,
- ngx_event_t *ev);
--static void ngx_http_upstream_connect(ngx_http_request_t *r,
-- ngx_http_upstream_t *u);
- static ngx_int_t ngx_http_upstream_reinit(ngx_http_request_t *r,
- ngx_http_upstream_t *u);
- static void ngx_http_upstream_send_request(ngx_http_request_t *r,
-@@ -600,13 +598,12 @@
-
- found:
-
-- if (uscf->peer.init(r, uscf) != NGX_OK) {
-- ngx_http_upstream_finalize_request(r, u,
-- NGX_HTTP_INTERNAL_SERVER_ERROR);
-- return;
-+ switch(uscf->peer.init(r, uscf)) {
-+ case NGX_OK: ngx_http_upstream_connect(r, u);
-+ case NGX_BUSY: return;
- }
-
-- ngx_http_upstream_connect(r, u);
-+ ngx_http_upstream_finalize_request(r, u, NGX_HTTP_INTERNAL_SERVER_ERROR);
- }
-
-
-@@ -1030,7 +1027,7 @@
- }
-
-
--static void
-+void
- ngx_http_upstream_connect(ngx_http_request_t *r, ngx_http_upstream_t *u)
- {
- ngx_int_t rc;
-diff -Naur a/src/http/ngx_http_upstream.h b/src/http/ngx_http_upstream.h
---- a/src/http/ngx_http_upstream.h 2009-12-23 09:22:17.000000000 -0500
-+++ b/src/http/ngx_http_upstream.h 2010-01-20 15:24:36.000000000 -0500
-@@ -321,6 +321,8 @@
-
- ngx_int_t ngx_http_upstream_create(ngx_http_request_t *r);
- void ngx_http_upstream_init(ngx_http_request_t *r);
-+#define NGX_HTTP_UPSTREAM_INIT_BUSY_PATCH_VERSION 1
-+void ngx_http_upstream_connect(ngx_http_request_t *r, ngx_http_upstream_t *u);
- ngx_http_upstream_srv_conf_t *ngx_http_upstream_add(ngx_conf_t *cf,
- ngx_url_t *u, ngx_uint_t flags);
- char *ngx_http_upstream_bind_set_slot(ngx_conf_t *cf, ngx_command_t *cmd,
diff --git a/www-servers/nginx/metadata.xml b/www-servers/nginx/metadata.xml
index a8693e07c4b7..dd7abd7b5984 100644
--- a/www-servers/nginx/metadata.xml
+++ b/www-servers/nginx/metadata.xml
@@ -34,8 +34,6 @@
replace text in the nginx response</flag>
<flag name='nginx_modules_http_upload'>Enable support for handling file
uploads using multipart/form-data encoding</flag>
- <flag name='nginx_modules_http_ey_balancer'>This module adds an upstream
- connection queue to nginx</flag>
<flag name='nginx_modules_http_slowfs_cache'>This module adds the
ability to cache static files</flag>
<flag name='nginx_modules_http_upload_progress'>This module adds the
diff --git a/www-servers/nginx/nginx-1.1.2.ebuild b/www-servers/nginx/nginx-1.0.8.ebuild
index 447ff14c1d54..8339ab82c6ad 100644
--- a/www-servers/nginx/nginx-1.1.2.ebuild
+++ b/www-servers/nginx/nginx-1.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-1.1.2.ebuild,v 1.2 2011/09/09 16:44:14 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-1.0.8.ebuild,v 1.1 2011/10/28 06:52:53 hollow Exp $
EAPI="4"
@@ -18,7 +18,7 @@ EAPI="4"
GENTOO_DEPEND_ON_PERL="no"
# http_uploadprogress (https://github.com/masterzen/nginx-upload-progress-module, BSD-2 license)
-HTTP_UPLOAD_PROGRESS_MODULE_PV="0.8.2"
+HTTP_UPLOAD_PROGRESS_MODULE_PV="0.8.3"
HTTP_UPLOAD_PROGRESS_MODULE_P="ngx_upload_progress-${HTTP_UPLOAD_PROGRESS_MODULE_PV}"
HTTP_UPLOAD_PROGRESS_MODULE_SHA1="8b55a34"
HTTP_UPLOAD_PROGRESS_MODULE_URI="http://github.com/masterzen/nginx-upload-progress-module/tarball/v${HTTP_UPLOAD_PROGRESS_MODULE_PV}"
@@ -35,7 +35,7 @@ HTTP_PUSH_MODULE_P="nginx_http_push_module-${HTTP_PUSH_MODULE_PV}"
HTTP_PUSH_MODULE_URI="http://pushmodule.slact.net/downloads/${HTTP_PUSH_MODULE_P}.tar.gz"
# http_cache_purge (http://labs.frickle.com/nginx_ngx_cache_purge/, BSD-2 license)
-HTTP_CACHE_PURGE_MODULE_PV="1.3"
+HTTP_CACHE_PURGE_MODULE_PV="1.4"
HTTP_CACHE_PURGE_MODULE_P="ngx_cache_purge-${HTTP_CACHE_PURGE_MODULE_PV}"
HTTP_CACHE_PURGE_MODULE_URI="http://labs.frickle.com/files/${HTTP_CACHE_PURGE_MODULE_P}.tar.gz"
diff --git a/www-servers/nginx/nginx-1.0.4.ebuild b/www-servers/nginx/nginx-1.1.6.ebuild
index 3c67ae1b3c4a..46462af12935 100644
--- a/www-servers/nginx/nginx-1.0.4.ebuild
+++ b/www-servers/nginx/nginx-1.1.6.ebuild
@@ -1,74 +1,85 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-1.0.4.ebuild,v 1.4 2011/09/09 16:44:14 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-1.1.6.ebuild,v 1.1 2011/10/28 06:52:53 hollow Exp $
-EAPI="2"
+EAPI="4"
# Maintainer notes:
# - http_rewrite-independent pcre-support makes sense for matching locations without an actual rewrite
# - any http-module activates the main http-functionality and overrides USE=-http
-# - keep the following 3 requirements in mind before adding external modules:
+# - keep the following requirements in mind before adding external modules:
# * alive upstream
# * sane packaging
# * builds cleanly
+# * does not need a patch for nginx core
# - TODO: test the google-perftools module (included in vanilla tarball)
# prevent perl-module from adding automagic perl DEPENDs
GENTOO_DEPEND_ON_PERL="no"
+# http_uploadprogress (https://github.com/masterzen/nginx-upload-progress-module, BSD-2 license)
+HTTP_UPLOAD_PROGRESS_MODULE_PV="0.8.3"
+HTTP_UPLOAD_PROGRESS_MODULE_P="ngx_upload_progress-${HTTP_UPLOAD_PROGRESS_MODULE_PV}"
+HTTP_UPLOAD_PROGRESS_MODULE_SHA1="8b55a34"
+HTTP_UPLOAD_PROGRESS_MODULE_URI="http://github.com/masterzen/nginx-upload-progress-module/tarball/v${HTTP_UPLOAD_PROGRESS_MODULE_PV}"
+
# http_headers_more (http://github.com/agentzh/headers-more-nginx-module, BSD license)
-HTTP_HEADERS_MORE_MODULE_PV="0.13"
-HTTP_HEADERS_MORE_MODULE_P="ngx-http-headers-more-${HTTP_HEADERS_MORE_MODULE_PV}"
-HTTP_HEADERS_MORE_MODULE_SHA1="9508330"
+HTTP_HEADERS_MORE_MODULE_PV="0.15"
+HTTP_HEADERS_MORE_MODULE_P="ngx_http_headers_more-${HTTP_HEADERS_MORE_MODULE_PV}"
+HTTP_HEADERS_MORE_MODULE_SHA1="137855d"
+HTTP_HEADERS_MORE_MODULE_URI="http://github.com/agentzh/headers-more-nginx-module/tarball/v${HTTP_HEADERS_MORE_MODULE_PV}"
# http_push (http://pushmodule.slact.net/, MIT license)
HTTP_PUSH_MODULE_PV="0.692"
HTTP_PUSH_MODULE_P="nginx_http_push_module-${HTTP_PUSH_MODULE_PV}"
+HTTP_PUSH_MODULE_URI="http://pushmodule.slact.net/downloads/${HTTP_PUSH_MODULE_P}.tar.gz"
# http_cache_purge (http://labs.frickle.com/nginx_ngx_cache_purge/, BSD-2 license)
-HTTP_CACHE_PURGE_MODULE_PV="1.3"
+HTTP_CACHE_PURGE_MODULE_PV="1.4"
HTTP_CACHE_PURGE_MODULE_P="ngx_cache_purge-${HTTP_CACHE_PURGE_MODULE_PV}"
+HTTP_CACHE_PURGE_MODULE_URI="http://labs.frickle.com/files/${HTTP_CACHE_PURGE_MODULE_P}.tar.gz"
# HTTP Upload module from Valery Kholodkov
# (http://www.grid.net.ru/nginx/upload.en.html, BSD license)
HTTP_UPLOAD_MODULE_PV="2.2.0"
HTTP_UPLOAD_MODULE_P="nginx_upload_module-${HTTP_UPLOAD_MODULE_PV}"
-
-# ey-balancer/maxconn module (https://github.com/ry/nginx-ey-balancer, as-is)
-HTTP_EY_BALANCER_MODULE_PV="0.0.6"
-HTTP_EY_BALANCER_MODULE_P="nginx-ey-balancer-${HTTP_EY_BALANCER_MODULE_PV}"
-HTTP_EY_BALANCER_MODULE_SHA1="d373670"
+HTTP_UPLOAD_MODULE_URI="http://www.grid.net.ru/nginx/download/${HTTP_UPLOAD_MODULE_P}.tar.gz"
# http_slowfs_cache (http://labs.frickle.com/nginx_ngx_slowfs_cache/, BSD-2 license)
HTTP_SLOWFS_CACHE_MODULE_PV="1.6"
HTTP_SLOWFS_CACHE_MODULE_P="ngx_slowfs_cache-${HTTP_SLOWFS_CACHE_MODULE_PV}"
+HTTP_SLOWFS_CACHE_MODULE_URI="http://labs.frickle.com/files/${HTTP_SLOWFS_CACHE_MODULE_P}.tar.gz"
inherit eutils ssl-cert toolchain-funcs perl-module flag-o-matic
DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-HOMEPAGE="http://nginx.net/
- http://pushmodule.slact.net/
- http://labs.frickle.com/nginx_ngx_cache_purge/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz
- nginx_modules_http_headers_more? ( http://github.com/agentzh/headers-more-nginx-module/tarball/v${HTTP_HEADERS_MORE_MODULE_PV} -> ${HTTP_HEADERS_MORE_MODULE_P}.tar.gz )
- nginx_modules_http_push? ( http://pushmodule.slact.net/downloads/${HTTP_PUSH_MODULE_P}.tar.gz )
- nginx_modules_http_cache_purge? ( http://labs.frickle.com/files/${HTTP_CACHE_PURGE_MODULE_P}.tar.gz )
- nginx_modules_http_upload? ( http://www.grid.net.ru/nginx/download/${HTTP_UPLOAD_MODULE_P}.tar.gz )
- nginx_modules_http_ey_balancer? ( https://github.com/ry/nginx-ey-balancer/tarball/v${HTTP_EY_BALANCER_MODULE_PV} -> ${HTTP_EY_BALANCER_MODULE_P}.tar.gz )
- nginx_modules_http_slowfs_cache? ( http://labs.frickle.com/files/${HTTP_SLOWFS_CACHE_MODULE_P}.tar.gz )"
+HOMEPAGE="http://nginx.org"
+SRC_URI="http://nginx.org/download/${P}.tar.gz
+ nginx_modules_http_upload_progress? ( ${HTTP_UPLOAD_PROGRESS_MODULE_URI} -> ${HTTP_UPLOAD_PROGRESS_MODULE_P}.tar.gz )
+ nginx_modules_http_headers_more? ( ${HTTP_HEADERS_MORE_MODULE_URI} -> ${HTTP_HEADERS_MORE_MODULE_P}.tar.gz )
+ nginx_modules_http_push? ( ${HTTP_PUSH_MODULE_URI} )
+ nginx_modules_http_cache_purge? ( ${HTTP_CACHE_PURGE_MODULE_URI} )
+ nginx_modules_http_upload? ( ${HTTP_UPLOAD_MODULE_URI} )
+ nginx_modules_http_slowfs_cache? ( ${HTTP_SLOWFS_CACHE_MODULE_URI} )"
LICENSE="as-is BSD BSD-2 GPL-2 MIT"
SLOT="0"
-KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
NGINX_MODULES_STD="access auth_basic autoindex browser charset empty_gif fastcgi
geo gzip limit_req limit_zone map memcached proxy referer rewrite scgi ssi
split_clients upstream_ip_hash userid uwsgi"
NGINX_MODULES_OPT="addition dav degradation flv geoip gzip_static image_filter
-perl random_index realip secure_link stub_status sub xslt"
+mp4 perl random_index realip secure_link stub_status sub xslt"
NGINX_MODULES_MAIL="imap pop3 smtp"
-NGINX_MODULES_3RD="http_cache_purge http_headers_more http_passenger http_push
-http_upload http_ey_balancer http_slowfs_cache"
+NGINX_MODULES_3RD="
+ http_upload_progress
+ http_headers_more
+ http_passenger
+ http_push
+ http_cache_purge
+ http_upload
+ http_slowfs_cache"
IUSE="aio debug +http +http-cache ipv6 libatomic +pcre ssl vim-syntax"
@@ -128,7 +139,7 @@ pkg_setup() {
ebegin "Creating nginx user and group"
enewgroup ${PN}
enewuser ${PN} -1 -1 -1 ${PN}
- eend ${?}
+ eend $?
if use libatomic; then
ewarn "GCC 4.1+ features built-in atomic operations."
@@ -151,70 +162,66 @@ pkg_setup() {
src_prepare() {
sed -i 's/ make/ \\$(MAKE)/' "${S}"/auto/lib/perl/make
-
- if use nginx_modules_http_ey_balancer; then
- epatch "${FILESDIR}"/nginx-0.8.32-ey-balancer.patch
- fi
}
src_configure() {
local myconf= http_enabled= mail_enabled=
- use aio && myconf="${myconf} --with-file-aio --with-aio_module"
- use debug && myconf="${myconf} --with-debug"
- use ipv6 && myconf="${myconf} --with-ipv6"
- use libatomic && myconf="${myconf} --with-libatomic"
- use pcre && myconf="${myconf} --with-pcre"
+ use aio && myconf+=" --with-file-aio --with-aio_module"
+ use debug && myconf+=" --with-debug"
+ use ipv6 && myconf+=" --with-ipv6"
+ use libatomic && myconf+=" --with-libatomic"
+ use pcre && myconf+=" --with-pcre"
# HTTP modules
for mod in $NGINX_MODULES_STD; do
if use nginx_modules_http_${mod}; then
http_enabled=1
else
- myconf="${myconf} --without-http_${mod}_module"
+ myconf+=" --without-http_${mod}_module"
fi
done
for mod in $NGINX_MODULES_OPT; do
if use nginx_modules_http_${mod}; then
http_enabled=1
- myconf="${myconf} --with-http_${mod}_module"
+ myconf+=" --with-http_${mod}_module"
fi
done
if use nginx_modules_http_fastcgi; then
- myconf="${myconf} --with-http_realip_module"
+ myconf+=" --with-http_realip_module"
fi
# third-party modules
+ if use nginx_modules_http_upload_progress; then
+ http_enabled=1
+ myconf+=" --add-module=${WORKDIR}/masterzen-nginx-upload-progress-module-${HTTP_UPLOAD_PROGRESS_MODULE_SHA1}"
+ fi
+
if use nginx_modules_http_headers_more; then
http_enabled=1
- myconf="${myconf} --add-module=${WORKDIR}/agentzh-headers-more-nginx-module-${HTTP_HEADERS_MORE_MODULE_SHA1}"
+ myconf+=" --add-module=${WORKDIR}/agentzh-headers-more-nginx-module-${HTTP_HEADERS_MORE_MODULE_SHA1}"
fi
if use nginx_modules_http_push; then
http_enabled=1
- myconf="${myconf} --add-module=${WORKDIR}/${HTTP_PUSH_MODULE_P}"
+ myconf+=" --add-module=${WORKDIR}/${HTTP_PUSH_MODULE_P}"
fi
if use nginx_modules_http_cache_purge; then
http_enabled=1
- myconf="${myconf} --add-module=${WORKDIR}/${HTTP_CACHE_PURGE_MODULE_P}"
+ myconf+=" --add-module=${WORKDIR}/${HTTP_CACHE_PURGE_MODULE_P}"
fi
if use nginx_modules_http_upload; then
http_enabled=1
- myconf="${myconf} --add-module=${WORKDIR}/${HTTP_UPLOAD_MODULE_P}"
- fi
-
- if use nginx_modules_http_ey_balancer; then
- http_enabled=1
- myconf="${myconf} --add-module=${WORKDIR}/ry-nginx-ey-balancer-${HTTP_EY_BALANCER_MODULE_SHA1}"
+ myconf+=" --add-module=${WORKDIR}/${HTTP_UPLOAD_MODULE_P}"
fi
if use nginx_modules_http_slowfs_cache; then
http_enabled=1
- myconf="${myconf} --add-module=${WORKDIR}/${HTTP_SLOWFS_CACHE_MODULE_P}"
+ myconf+=" --add-module=${WORKDIR}/${HTTP_SLOWFS_CACHE_MODULE_P}"
fi
if use http || use http-cache; then
@@ -222,10 +229,10 @@ src_configure() {
fi
if [ $http_enabled ]; then
- use http-cache || myconf="${myconf} --without-http-cache"
- use ssl && myconf="${myconf} --with-http_ssl_module"
+ use http-cache || myconf+=" --without-http-cache"
+ use ssl && myconf+=" --with-http_ssl_module"
else
- myconf="${myconf} --without-http --without-http-cache"
+ myconf+=" --without-http --without-http-cache"
fi
# MAIL modules
@@ -233,18 +240,18 @@ src_configure() {
if use nginx_modules_mail_${mod}; then
mail_enabled=1
else
- myconf="${myconf} --without-mail_${mod}_module"
+ myconf+=" --without-mail_${mod}_module"
fi
done
if [ $mail_enabled ]; then
- myconf="${myconf} --with-mail"
- use ssl && myconf="${myconf} --with-mail_ssl_module"
+ myconf+=" --with-mail"
+ use ssl && myconf+=" --with-mail_ssl_module"
fi
# custom modules
for mod in $NGINX_ADD_MODULES; do
- myconf="${myconf} --add-module=${mod}"
+ myconf+=" --add-module=${mod}"
done
# https://bugs.gentoo.org/286772
@@ -278,6 +285,7 @@ src_compile() {
src_install() {
keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi,scgi,uwsgi}
+ keepdir /var/www/localhost/htdocs
dosbin objs/nginx
newinitd "${FILESDIR}"/nginx.init-r2 nginx
@@ -317,11 +325,6 @@ src_install() {
dodoc "${WORKDIR}"/${HTTP_UPLOAD_MODULE_P}/{Changelog,README}
fi
- if use nginx_modules_http_ey_balancer; then
- docinto ${HTTP_EY_BALANCER_MODULE_P}
- dodoc "${WORKDIR}"/ry-nginx-ey-balancer-${HTTP_EY_BALANCER_MODULE_SHA1}/README
- fi
-
if use nginx_modules_http_slowfs_cache; then
docinto ${HTTP_SLOWFS_CACHE_MODULE_P}
dodoc "${WORKDIR}"/${HTTP_SLOWFS_CACHE_MODULE_P}/{CHANGES,README}