summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/pmacct/ChangeLog8
-rw-r--r--net-analyzer/pmacct/Manifest2
-rw-r--r--net-analyzer/pmacct/files/digest-pmacct-0.10.0_rc11
-rw-r--r--net-analyzer/pmacct/pmacct-0.10.0_rc1.ebuild56
4 files changed, 66 insertions, 1 deletions
diff --git a/net-analyzer/pmacct/ChangeLog b/net-analyzer/pmacct/ChangeLog
index f0c4434053c2..c00a2b32208c 100644
--- a/net-analyzer/pmacct/ChangeLog
+++ b/net-analyzer/pmacct/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/pmacct
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.34 2006/01/15 18:32:03 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.35 2006/01/24 14:05:46 vanquirius Exp $
+
+*pmacct-0.10.0_rc1 (24 Jan 2006)
+
+ 24 Jan 2006; Marcelo Goes <vanquirius@gentoo.org>
+ +pmacct-0.10.0_rc1.ebuild:
+ 0.10.0_rc1 version bump.
15 Jan 2006; Marcelo Goes <vanquirius@gentoo.org> -pmacct-0.8.7.ebuild:
Remove old ebuild.
diff --git a/net-analyzer/pmacct/Manifest b/net-analyzer/pmacct/Manifest
index 436c85548332..7433b497d381 100644
--- a/net-analyzer/pmacct/Manifest
+++ b/net-analyzer/pmacct/Manifest
@@ -1,8 +1,10 @@
MD5 8b794a0ff8c1d2ad04678b6408e7828a ChangeLog 5463
+MD5 582af06423157d7dd6763d56a58509cb files/digest-pmacct-0.10.0_rc1 68
MD5 51edce191b704cca9a48ef7745397aa1 files/digest-pmacct-0.9.5 64
MD5 d8cd455e2f42da88b681bce258019c3e files/digest-pmacct-0.9.6 64
MD5 50333f1c79a80df31266ce7235cbf36c files/pmacctd-conf.d 313
MD5 2afa8e97312b03f3e119c0befed9e7d3 files/pmacctd-init.d 869
MD5 808a9a788ae7955af0a3c442cafee866 metadata.xml 243
+MD5 fa7f222902205fc06ddf7602bbe90b35 pmacct-0.10.0_rc1.ebuild 1574
MD5 e143af869089ae996a96f3525c7a97b3 pmacct-0.9.5.ebuild 1560
MD5 89522186825cf87b8976320c538e7653 pmacct-0.9.6.ebuild 1566
diff --git a/net-analyzer/pmacct/files/digest-pmacct-0.10.0_rc1 b/net-analyzer/pmacct/files/digest-pmacct-0.10.0_rc1
new file mode 100644
index 000000000000..cbd8a8f820d4
--- /dev/null
+++ b/net-analyzer/pmacct/files/digest-pmacct-0.10.0_rc1
@@ -0,0 +1 @@
+MD5 6e72a1587b195bd1880782dafa359306 pmacct-0.10.0rc1.tar.gz 331103
diff --git a/net-analyzer/pmacct/pmacct-0.10.0_rc1.ebuild b/net-analyzer/pmacct/pmacct-0.10.0_rc1.ebuild
new file mode 100644
index 000000000000..5eba3d214152
--- /dev/null
+++ b/net-analyzer/pmacct/pmacct-0.10.0_rc1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.10.0_rc1.ebuild,v 1.1 2006/01/24 14:05:46 vanquirius Exp $
+
+MY_P="${P%_*}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="A network tool to gather ip traffic informations"
+HOMEPAGE="http://www.ba.cnr.it/~paolo/pmacct/"
+SRC_URI="http://www.ba.cnr.it/~paolo/pmacct/${P/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="64bit debug ipv6 mmap mysql postgres"
+
+RDEPEND="virtual/libpcap
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i "s|\(CFLAGS=\).*$|\1\"${CFLAGS}\"|g" configure || die "sed failed"
+}
+
+src_compile() {
+ econf \
+ $(use_enable mysql) \
+ $(use_enable postgres pgsql) \
+ $(use_enable mmap) \
+ $(use_enable ipv6) \
+ $(use_enable debug) \
+ $(use_enable 64bit) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README EXAMPLES KNOWN-BUGS CONFIG-KEYS FAQS ChangeLog docs/SIGNALS \
+ docs/PLUGINS docs/INTERNALS TODO TOOLS || die "dodoc failed"
+
+ for dirname in examples sql; do
+ docinto ${dirname}
+ dodoc ${dirname}/* || die "dodoc ${dirname} failed"
+ done
+
+ newinitd "${FILESDIR}"/pmacctd-init.d pmacctd || die "newinitd failed"
+ newconfd "${FILESDIR}"/pmacctd-conf.d pmacctd || die "newconfd failed"
+
+ insinto /etc
+ newins "${S}"/examples/pmacctd-imt.conf.example pmacctd.conf.example || \
+ die "newins failed"
+}