summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/gimmix/ChangeLog6
-rw-r--r--media-sound/gimmix/files/gimmix-0.5.3-missing-prototypes.patch24
-rw-r--r--media-sound/gimmix/gimmix-0.5.3.ebuild50
3 files changed, 79 insertions, 1 deletions
diff --git a/media-sound/gimmix/ChangeLog b/media-sound/gimmix/ChangeLog
index fd32957ff6be..22fde0184c59 100644
--- a/media-sound/gimmix/ChangeLog
+++ b/media-sound/gimmix/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/gimmix
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gimmix/ChangeLog,v 1.17 2008/10/14 23:39:55 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gimmix/ChangeLog,v 1.18 2008/12/12 19:31:49 angelos Exp $
+
+ 12 Dec 2008; Christoph Mende <angelos@gentoo.org>
+ +files/gimmix-0.5.3-missing-prototypes.patch, +gimmix-0.5.3.ebuild:
+ Version bump
*gimmix-0.5.2 (14 Oct 2008)
diff --git a/media-sound/gimmix/files/gimmix-0.5.3-missing-prototypes.patch b/media-sound/gimmix/files/gimmix-0.5.3-missing-prototypes.patch
new file mode 100644
index 000000000000..78d6f12a0e76
--- /dev/null
+++ b/media-sound/gimmix/files/gimmix-0.5.3-missing-prototypes.patch
@@ -0,0 +1,24 @@
+diff -u -Nru a/src/gimmix-firstrun.h b/src/gimmix-firstrun.h
+--- a/src/gimmix-firstrun.h 2008-12-12 17:59:03.000000000 +0100
++++ b/src/gimmix-firstrun.h 2008-12-12 20:14:52.000000000 +0100
+@@ -2,6 +2,6 @@
+ #define GIMMIX_FIRSTRUN_H
+
+ /* Displays the first run dialog */
+-void gimmix_show_first_run_dialog (void);
++void gimmix_show_firstrun_dialog (void);
+
+ #endif
+diff -u -Nru a/src/gimmix.h b/src/gimmix.h
+--- a/src/gimmix.h 2008-12-12 17:59:03.000000000 +0100
++++ b/src/gimmix.h 2008-12-12 20:20:40.000000000 +0100
+@@ -27,6 +27,9 @@
+ /* display connection error */
+ void gimmix_connect_error (void);
+
++/* display general error */
++void gimmix_error (const char *error_str);
++
+ /* displays the about dialog */
+ void gimmix_about_show (void);
+
diff --git a/media-sound/gimmix/gimmix-0.5.3.ebuild b/media-sound/gimmix/gimmix-0.5.3.ebuild
new file mode 100644
index 000000000000..2448a19d3e2d
--- /dev/null
+++ b/media-sound/gimmix/gimmix-0.5.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gimmix/gimmix-0.5.3.ebuild,v 1.3 2008/12/12 19:31:49 angelos Exp $
+
+inherit eutils
+
+DESCRIPTION="a graphical music player daemon (MPD) client using GTK+2"
+HOMEPAGE="http://gimmix.berlios.de/"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="cover lyrics"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.6
+ >=media-libs/libmpd-0.12
+ >=media-libs/taglib-1.4
+ cover? ( net-libs/libnxml net-misc/curl )
+ lyrics? ( net-libs/libnxml net-misc/curl )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ dev-util/intltool"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-missing-prototypes.patch
+ echo "src/eggtrayicon.c" >> "${S}"/po/POTFILES.skip
+ echo "src/gimmix-covers.c" >> "${S}"/po/POTFILES.skip
+ echo "src/gimmix-lyrics.c" >> "${S}"/po/POTFILES.skip
+}
+
+src_compile() {
+ econf $(use_enable cover) $(use_enable lyrics)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ elog "gimmix-0.4 introduces a new config file format."
+ elog "If you're upgrading from an older version please"
+ elog "delete your ~/.gimmixrc before running gimmix."
+}