summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-nntp/pan/ChangeLog8
-rw-r--r--net-nntp/pan/Manifest16
-rw-r--r--net-nntp/pan/files/digest-pan-0.14.2.91-r21
-rw-r--r--net-nntp/pan/files/pan-0.14.2.91-gcc4-2.patch23
-rw-r--r--net-nntp/pan/pan-0.14.2.91-r2.ebuild58
5 files changed, 93 insertions, 13 deletions
diff --git a/net-nntp/pan/ChangeLog b/net-nntp/pan/ChangeLog
index fd5ed673b429..1fb72bb6740b 100644
--- a/net-nntp/pan/ChangeLog
+++ b/net-nntp/pan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-nntp/pan
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/ChangeLog,v 1.5 2005/04/29 13:25:49 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/ChangeLog,v 1.6 2005/04/30 16:09:16 azarah Exp $
+
+*pan-0.14.2.91-r2 (30 Apr 2005)
+
+ 30 Apr 2005; Martin Schlemmer <azarah@gentoo.org>
+ +files/pan-0.14.2.91-gcc4-2.patch, +pan-0.14.2.91-r2.ebuild:
+ Fix typo in gcc4 patch, bug #90943.
*pan-0.14.2.91-r1 (29 Apr 2005)
diff --git a/net-nntp/pan/Manifest b/net-nntp/pan/Manifest
index 87609ece6892..debe33331d32 100644
--- a/net-nntp/pan/Manifest
+++ b/net-nntp/pan/Manifest
@@ -1,19 +1,11 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 6c26b444f4123c87123ddd1593340dac ChangeLog 7170
MD5 b379ecb012e58dcb29c4feee0f5219f2 metadata.xml 180
MD5 174713b7a47ec08aa89ba36656948abe pan-0.14.2.91.ebuild 1498
-MD5 6225c7c8a053c3b857b7b6ca504bd4f9 pan-0.14.2.ebuild 1388
MD5 9949abbd77f7cc88660a73188a1730e2 pan-0.14.2.91-r1.ebuild 1501
+MD5 6225c7c8a053c3b857b7b6ca504bd4f9 pan-0.14.2.ebuild 1388
+MD5 0ce760aee37955371b7c9d49b420c5af pan-0.14.2.91-r2.ebuild 1503
MD5 179a6776627498e226a1cc2d6bdc33d2 files/digest-pan-0.14.2 64
MD5 bc715242bd05043ca432fb54b03e2fdf files/digest-pan-0.14.2.91 67
-MD5 daf4b06f3fce576fbf35e97bcffa9305 files/pan-0.14.2.91-gcc4.patch 698
+MD5 bc715242bd05043ca432fb54b03e2fdf files/digest-pan-0.14.2.91-r2 67
MD5 bc715242bd05043ca432fb54b03e2fdf files/digest-pan-0.14.2.91-r1 67
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCcjcN1ZcsMnZjRyIRAtv0AJ4ixcxIT4WPH6sn9nZgkHug0EkTQgCaAoIS
-1SIggJ18Fl70wfZ6xbweWxY=
-=ChUl
------END PGP SIGNATURE-----
+MD5 8ba6afcc31900a8353dc12ef62681f38 files/pan-0.14.2.91-gcc4-2.patch 698
diff --git a/net-nntp/pan/files/digest-pan-0.14.2.91-r2 b/net-nntp/pan/files/digest-pan-0.14.2.91-r2
new file mode 100644
index 000000000000..8d1304772a69
--- /dev/null
+++ b/net-nntp/pan/files/digest-pan-0.14.2.91-r2
@@ -0,0 +1 @@
+MD5 4770d899a1c1ba968ce96bc5aeb07b62 pan-0.14.2.91.tar.bz2 1919099
diff --git a/net-nntp/pan/files/pan-0.14.2.91-gcc4-2.patch b/net-nntp/pan/files/pan-0.14.2.91-gcc4-2.patch
new file mode 100644
index 000000000000..1edb35bfa0fd
--- /dev/null
+++ b/net-nntp/pan/files/pan-0.14.2.91-gcc4-2.patch
@@ -0,0 +1,23 @@
+--- pan-0.14.2.91/pan/base/msort.c.orig 2005-04-25 15:54:31.000000000 +0000
++++ pan-0.14.2.91/pan/base/msort.c 2005-04-25 15:59:21.000000000 +0000
+@@ -65,14 +65,16 @@
+ if ((*cmp) (b1, b2) <= 0)
+ {
+ --n1;
+- *((unsigned long int *) tmp)++ =
+- *((unsigned long int *) b1)++;
++ *((unsigned long int *) tmp) = *((unsigned long int *) b1);
++ tmp += sizeof(unsigned long int);
++ b1 += sizeof(unsigned long int);
+ }
+ else
+ {
+ --n2;
+- *((unsigned long int *) tmp)++ =
+- *((unsigned long int *) b2)++;
++ *((unsigned long int *) tmp) = *((unsigned long int *) b2);
++ tmp += sizeof(unsigned long int);
++ b2 += sizeof(unsigned long int);
+ }
+ }
+ else
diff --git a/net-nntp/pan/pan-0.14.2.91-r2.ebuild b/net-nntp/pan/pan-0.14.2.91-r2.ebuild
new file mode 100644
index 000000000000..84a46374c2d6
--- /dev/null
+++ b/net-nntp/pan/pan-0.14.2.91-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/pan-0.14.2.91-r2.ebuild,v 1.1 2005/04/30 16:09:16 azarah Exp $
+
+inherit eutils libtool
+
+IUSE="nls spell"
+
+DESCRIPTION="A newsreader for the Gnome2 desktop"
+SRC_URI="http://pan.rebelbase.com/download/releases/${PV}/SOURCE/${P}.tar.bz2"
+HOMEPAGE="http://pan.rebelbase.com/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~hppa ~ppc ~sparc ~amd64 ppc64"
+SLOT="0"
+
+RDEPEND=">=dev-libs/glib-2.0.4
+ >=x11-libs/gtk+-2.0.5
+ >=dev-libs/libxml2-2.4.22
+ >=net-libs/gnet-1.1.8
+ >=dev-libs/libpcre-4.0
+ spell? ( >=app-text/gtkspell-2.0.2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.21
+ sys-devel/gettext"
+
+export CONFIG_PROTECT_MASK="/etc/gconf"
+
+pkg_setup() {
+ # Likely that glibc might of been compiled with nls turned off.
+ # Warn people that Pan requires glibc to have nls support.
+ if ! use nls
+ then
+ ewarn "Pan requires glibc to be merged with 'nls' in your USE flags."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix for building with gcc4
+ epatch ${FILESDIR}/${P}-gcc4-2.patch
+
+ elibtoolize || die "elibtoolize failed"
+}
+
+src_compile() {
+ econf $(use_enable spell gtkspell) || die "Configure failure"
+ emake || die "Compilation failure"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "Installation failed"
+ dodoc AUTHORS ChangeLog CREDITS NEWS README TODO || die "dodoc failed"
+ dohtml ANNOUNCE.html docs/{pan-shortcuts,faq}.html || die "dodoc failed"
+}