summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-sports/torcs/ChangeLog11
-rw-r--r--games-sports/torcs/files/digest-torcs-1.2.42
-rw-r--r--games-sports/torcs/files/digest-torcs-1.2.4-r13
-rw-r--r--games-sports/torcs/files/torcs-1.2.4-freealut.patch11
-rw-r--r--games-sports/torcs/torcs-1.2.4-r1.ebuild52
5 files changed, 77 insertions, 2 deletions
diff --git a/games-sports/torcs/ChangeLog b/games-sports/torcs/ChangeLog
index 9fdb86024d92..0ec166b80c33 100644
--- a/games-sports/torcs/ChangeLog
+++ b/games-sports/torcs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-sports/torcs
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/ChangeLog,v 1.11 2005/11/07 16:33:05 mr_bones_ Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/ChangeLog,v 1.12 2006/05/11 14:42:48 wolf31o2 Exp $
+
+*torcs-1.2.4-r1 (11 May 2006)
+
+ 11 May 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/torcs-1.2.4-freealut.patch, +torcs-1.2.4-r1.ebuild:
+ Added patch to fix openal/freealut using upstream released versions and
+ closing bug #132837.
07 Nov 2005; Michael Sterrett <mr_bones_@gentoo.org> torcs-1.2.4.ebuild:
stable for x86
diff --git a/games-sports/torcs/files/digest-torcs-1.2.4 b/games-sports/torcs/files/digest-torcs-1.2.4
index e6ad3948590b..296eb9707e7c 100644
--- a/games-sports/torcs/files/digest-torcs-1.2.4
+++ b/games-sports/torcs/files/digest-torcs-1.2.4
@@ -1 +1,3 @@
MD5 f8727358323bd92537f10167bda4ee5f torcs-1.2.4.tar.bz2 112020278
+RMD160 4337589c8a5d84a84dccbe75c20d7831d876b322 torcs-1.2.4.tar.bz2 112020278
+SHA256 2b836a6f99947fa1a4a32ebd9b85f62ca109cde0e58b2326a3f94ef619f66249 torcs-1.2.4.tar.bz2 112020278
diff --git a/games-sports/torcs/files/digest-torcs-1.2.4-r1 b/games-sports/torcs/files/digest-torcs-1.2.4-r1
new file mode 100644
index 000000000000..296eb9707e7c
--- /dev/null
+++ b/games-sports/torcs/files/digest-torcs-1.2.4-r1
@@ -0,0 +1,3 @@
+MD5 f8727358323bd92537f10167bda4ee5f torcs-1.2.4.tar.bz2 112020278
+RMD160 4337589c8a5d84a84dccbe75c20d7831d876b322 torcs-1.2.4.tar.bz2 112020278
+SHA256 2b836a6f99947fa1a4a32ebd9b85f62ca109cde0e58b2326a3f94ef619f66249 torcs-1.2.4.tar.bz2 112020278
diff --git a/games-sports/torcs/files/torcs-1.2.4-freealut.patch b/games-sports/torcs/files/torcs-1.2.4-freealut.patch
new file mode 100644
index 000000000000..e6cd8b874668
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.2.4-freealut.patch
@@ -0,0 +1,11 @@
+--- src/modules/graphic/ssggraph/Makefile
++++ src/modules/graphic/ssggraph/Makefile
+@@ -24,7 +24,7 @@
+
+ MODULEDIR = modules/graphic
+
+-LIBS = -lplibsl -lplibsm -lplibsg -lplibssg -lplibul -lplibssgaux -lopenal
++LIBS = -lplibsl -lplibsm -lplibsg -lplibssg -lplibul -lplibssgaux -lopenal -lalut
+
+ SHIPDIR = config
+
diff --git a/games-sports/torcs/torcs-1.2.4-r1.ebuild b/games-sports/torcs/torcs-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..eb8a59f24da5
--- /dev/null
+++ b/games-sports/torcs/torcs-1.2.4-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/torcs-1.2.4-r1.ebuild,v 1.1 2006/05/11 14:42:48 wolf31o2 Exp $
+
+inherit games
+
+DESCRIPTION="The Open Racing Car Simulator"
+HOMEPAGE="http://torcs.org/"
+SRC_URI="mirror://sourceforge/torcs/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/plib-1.8.3
+ virtual/opengl
+ virtual/glut
+ ~media-libs/openal-0.0.8
+ media-libs/freealut
+ media-libs/libpng
+ sys-libs/zlib"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-freealut.patch
+ sed -i \
+ -e "s:/games::" \
+ Make-config.in \
+ src/linux/torcs.in \
+ src/tools/trackgen/trackgen.in \
+ src/tools/nfs2ac/nfs2ac.in \
+ src/tools/accc/accc.in \
+ src/tools/texmapper/texmapper.in \
+ src/tools/nfsperf/nfsperf.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --x-libraries=/usr/lib || die
+ emake -j1 || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install datainstall || die "make install failed"
+ dodoc README.linux
+ dohtml *.html *.png
+ prepgamesdirs
+}