summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-strategy/widelands/ChangeLog6
-rw-r--r--games-strategy/widelands/files/widelands-0.15-gcc46.patch10
-rw-r--r--games-strategy/widelands/widelands-0.15.ebuild5
3 files changed, 18 insertions, 3 deletions
diff --git a/games-strategy/widelands/ChangeLog b/games-strategy/widelands/ChangeLog
index 002e8a1c76d6..96f230a8a0fe 100644
--- a/games-strategy/widelands/ChangeLog
+++ b/games-strategy/widelands/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/widelands
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/ChangeLog,v 1.32 2011/02/26 16:44:28 signals Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/ChangeLog,v 1.33 2011/04/26 12:12:49 tupone Exp $
+
+ 26 Apr 2011; Tupone Alfredo <tupone@gentoo.org> widelands-0.15.ebuild,
+ +files/widelands-0.15-gcc46.patch:
+ Build with gcc-4.6 Bug #362379 by Diego Elio Pettenò
26 Feb 2011; Kevin McCarthy <signals@gentoo.org> widelands-0.15.ebuild:
Updated depends from media-libs/jpeg to virtual-jpeg
diff --git a/games-strategy/widelands/files/widelands-0.15-gcc46.patch b/games-strategy/widelands/files/widelands-0.15-gcc46.patch
new file mode 100644
index 000000000000..9f1d06796765
--- /dev/null
+++ b/games-strategy/widelands/files/widelands-0.15-gcc46.patch
@@ -0,0 +1,10 @@
+--- src/economy/supply_list.h.old 2011-04-26 12:25:14.102136343 +0200
++++ src/economy/supply_list.h 2011-04-26 13:32:57.127500881 +0200
+@@ -21,6 +21,7 @@
+ #define SUPPLY_LIST_H
+
+ #include <vector>
++#include <cstddef>
+
+ namespace Widelands {
+
diff --git a/games-strategy/widelands/widelands-0.15.ebuild b/games-strategy/widelands/widelands-0.15.ebuild
index 0de6e8314327..47f8cf772a27 100644
--- a/games-strategy/widelands/widelands-0.15.ebuild
+++ b/games-strategy/widelands/widelands-0.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/widelands-0.15.ebuild,v 1.7 2011/02/26 16:44:28 signals Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/widelands-0.15.ebuild,v 1.8 2011/04/26 12:12:49 tupone Exp $
EAPI=2
inherit eutils versionator cmake-utils games
@@ -36,7 +36,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-build.patch \
"${FILESDIR}"/${P}-locale.patch \
- "${FILESDIR}"/${P}-gcc45.patch
+ "${FILESDIR}"/${P}-gcc45.patch \
+ "${FILESDIR}"/${P}-gcc46.patch
sed -i \
-e 's:__ppc__:__PPC__:' src/s2map.cc \