summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/kiwi/ChangeLog9
-rw-r--r--dev-python/kiwi/kiwi-1.9.36.2.ebuild59
2 files changed, 66 insertions, 2 deletions
diff --git a/dev-python/kiwi/ChangeLog b/dev-python/kiwi/ChangeLog
index 816cf7f80333..857cf53e6da9 100644
--- a/dev-python/kiwi/ChangeLog
+++ b/dev-python/kiwi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/kiwi
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/ChangeLog,v 1.21 2012/12/11 17:06:30 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/ChangeLog,v 1.22 2013/01/22 06:02:43 patrick Exp $
+
+*kiwi-1.9.36.2 (22 Jan 2013)
+
+ 22 Jan 2013; Patrick Lauer <patrick@gentoo.org> +kiwi-1.9.36.2.ebuild:
+ Bump
11 Dec 2012; Agostino Sarubbo <ago@gentoo.org> kiwi-1.9.36.ebuild:
Add ~ppc, wrt bug #416677
diff --git a/dev-python/kiwi/kiwi-1.9.36.2.ebuild b/dev-python/kiwi/kiwi-1.9.36.2.ebuild
new file mode 100644
index 000000000000..cf40d4ca1c5d
--- /dev/null
+++ b/dev-python/kiwi/kiwi-1.9.36.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/kiwi-1.9.36.2.ebuild,v 1.1 2013/01/22 06:02:43 patrick Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython *-pypy-*"
+
+inherit distutils versionator virtualx
+
+DESCRIPTION="Kiwi is a pure Python framework and set of enhanced PyGTK widgets"
+HOMEPAGE="http://www.async.com.br/projects/kiwi/
+ https://launchpad.net/kiwi
+ http://pypi.python.org/pypi/kiwi-gtk"
+MY_PN="${PN}-gtk"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND="dev-python/pygtk"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pep8
+ dev-python/pyflakes
+ dev-python/twisted
+ )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ distutils_src_prepare
+ sed -e "s:share/doc/kiwi:share/doc/${PF}:g" -i setup.py || die "sed failed"
+}
+
+src_test() {
+ # Tarballs are missing files.
+ # https://code.launchpad.net/~floppym/kiwi/testfiles/+merge/106505
+ rm tests/test_ui.py tests/test_Delegate.py
+
+ testing() {
+ "$(PYTHON)" tests/run_all_tests.py
+ }
+ VIRTUALX_COMMAND=python_execute_function virtualmake testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}