summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-irc/rbot/ChangeLog8
-rw-r--r--net-irc/rbot/files/digest-rbot-0.9.10-r13
-rw-r--r--net-irc/rbot/rbot-0.9.10-r1.ebuild25
-rw-r--r--net-irc/rbot/rbot-0.9.10.ebuild5
4 files changed, 37 insertions, 4 deletions
diff --git a/net-irc/rbot/ChangeLog b/net-irc/rbot/ChangeLog
index cfa55794a727..e8ef86cc9ad8 100644
--- a/net-irc/rbot/ChangeLog
+++ b/net-irc/rbot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/rbot
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/ChangeLog,v 1.16 2006/09/15 10:14:17 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/ChangeLog,v 1.17 2006/09/23 01:43:53 flameeyes Exp $
+
+*rbot-0.9.10-r1 (23 Sep 2006)
+
+ 23 Sep 2006; Diego Pettenò <flameeyes@gentoo.org> rbot-0.9.10.ebuild,
+ +rbot-0.9.10-r1.ebuild:
+ Add new revision of rbot using the gem now, hopefully fixing bug #134987.
*rbot-0.9.10 (15 Sep 2006)
diff --git a/net-irc/rbot/files/digest-rbot-0.9.10-r1 b/net-irc/rbot/files/digest-rbot-0.9.10-r1
new file mode 100644
index 000000000000..74cee3fe1832
--- /dev/null
+++ b/net-irc/rbot/files/digest-rbot-0.9.10-r1
@@ -0,0 +1,3 @@
+MD5 92977fbefa4ecccb1eaaac6d2bf783eb rbot-0.9.10.gem 387584
+RMD160 a29dd55aa894fac89b2cc0a05f694df8c7e1489c rbot-0.9.10.gem 387584
+SHA256 3433783e2be481d63072c5ef03dd4f61b09bee0520c306607ad1e0fa46b8a4b5 rbot-0.9.10.gem 387584
diff --git a/net-irc/rbot/rbot-0.9.10-r1.ebuild b/net-irc/rbot/rbot-0.9.10-r1.ebuild
new file mode 100644
index 000000000000..7993440f30f3
--- /dev/null
+++ b/net-irc/rbot/rbot-0.9.10-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-0.9.10-r1.ebuild,v 1.1 2006/09/23 01:43:53 flameeyes Exp $
+
+inherit ruby gems
+
+DESCRIPTION="rbot is a ruby IRC bot"
+HOMEPAGE="http://www.linuxbrit.co.uk/rbot/"
+
+SRC_URI="http://www.linuxbrit.co.uk/downloads/${P}.gem"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="spell"
+
+RDEPEND=">=virtual/ruby-1.8
+ dev-ruby/ruby-bdb"
+DEPEND="${RDEPEND}"
+
+pkg_postinst() {
+ einfo
+ einfo "Default configuration file location has changed from /etc/rbot to ~/.rbot"
+ einfo
+}
diff --git a/net-irc/rbot/rbot-0.9.10.ebuild b/net-irc/rbot/rbot-0.9.10.ebuild
index 1f43b834ee4c..8fb9dcb06e56 100644
--- a/net-irc/rbot/rbot-0.9.10.ebuild
+++ b/net-irc/rbot/rbot-0.9.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-0.9.10.ebuild,v 1.1 2006/09/15 10:14:17 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-0.9.10.ebuild,v 1.2 2006/09/23 01:43:53 flameeyes Exp $
inherit ruby
@@ -20,8 +20,7 @@ KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
IUSE="spell"
RDEPEND=">=virtual/ruby-1.8
- dev-ruby/ruby-bdb
- spell? ( app-text/ispell )"
+ dev-ruby/ruby-bdb"
DEPEND="${RDEPEND}"
src_install() {