summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/xmltodict/ChangeLog6
-rw-r--r--dev-python/xmltodict/xmltodict-0.8.1.ebuild22
-rw-r--r--dev-python/xmltodict/xmltodict-0.8.3.ebuild12
3 files changed, 15 insertions, 25 deletions
diff --git a/dev-python/xmltodict/ChangeLog b/dev-python/xmltodict/ChangeLog
index ae94d9bd0e94..b40d8d296473 100644
--- a/dev-python/xmltodict/ChangeLog
+++ b/dev-python/xmltodict/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/xmltodict
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/xmltodict/ChangeLog,v 1.4 2013/10/28 06:55:35 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xmltodict/ChangeLog,v 1.5 2013/10/29 19:00:07 radhermit Exp $
+
+ 29 Oct 2013; Tim Harder <radhermit@gentoo.org> -xmltodict-0.8.1.ebuild,
+ xmltodict-0.8.3.ebuild:
+ Fix setuptools sandbox issue (bug #489726) and remove old.
*xmltodict-0.8.3 (28 Oct 2013)
diff --git a/dev-python/xmltodict/xmltodict-0.8.1.ebuild b/dev-python/xmltodict/xmltodict-0.8.1.ebuild
deleted file mode 100644
index 7f632fcbb78a..000000000000
--- a/dev-python/xmltodict/xmltodict-0.8.1.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/xmltodict/xmltodict-0.8.1.ebuild,v 1.1 2013/10/21 06:41:13 patrick Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-inherit distutils-r1
-
-DESCRIPTION="Makes working with XML feel like you are working with JSON"
-HOMEPAGE="https://github.com/martinblech/xmltodict/ https://pypi.python.org/pypi/xmltodict/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_test() {
- nosetests || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/xmltodict/xmltodict-0.8.3.ebuild b/dev-python/xmltodict/xmltodict-0.8.3.ebuild
index 111bc06a9a7c..bd09652b99f5 100644
--- a/dev-python/xmltodict/xmltodict-0.8.3.ebuild
+++ b/dev-python/xmltodict/xmltodict-0.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/xmltodict/xmltodict-0.8.3.ebuild,v 1.1 2013/10/28 06:55:35 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xmltodict/xmltodict-0.8.3.ebuild,v 1.2 2013/10/29 19:00:07 radhermit Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
@@ -15,7 +15,15 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
-DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # avoid setuptools sandbox issues, bug #489726
+ sed -i '/setup_requires/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
python_test() {
nosetests || die "Tests fail with ${EPYTHON}"