summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/webtest/ChangeLog6
-rw-r--r--dev-python/webtest/webtest-2.0.15.ebuild15
2 files changed, 8 insertions, 13 deletions
diff --git a/dev-python/webtest/ChangeLog b/dev-python/webtest/ChangeLog
index 17aa6f661cc5..0e5dbb3d46cc 100644
--- a/dev-python/webtest/ChangeLog
+++ b/dev-python/webtest/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/webtest
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.84 2014/10/10 16:11:53 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.85 2014/10/13 09:50:09 idella4 Exp $
+
+ 13 Oct 2014; Ian Delaney <idella4@gentoo.org> webtest-2.0.15.ebuild:
+ add py3.4, update 1 dep, remove superfluous removal of superfluous file @
+ install phase wrt Bug 524724 by wtking (leave 1.4.3-r1 as is for now)
10 Oct 2014; Ian Delaney <idella4@gentoo.org> webtest-2.0.15.ebuild:
add missing invisible rdep (not listed in setup.py) in latest or current
diff --git a/dev-python/webtest/webtest-2.0.15.ebuild b/dev-python/webtest/webtest-2.0.15.ebuild
index 6f9a8d528fed..68a96fb42622 100644
--- a/dev-python/webtest/webtest-2.0.15.ebuild
+++ b/dev-python/webtest/webtest-2.0.15.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-2.0.15.ebuild,v 1.3 2014/10/10 16:11:53 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-2.0.15.ebuild,v 1.4 2014/10/13 09:50:09 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
inherit distutils-r1
@@ -36,7 +36,7 @@ DEPEND="${RDEPEND}
dev-python/pastedeploy[${PYTHON_USEDEP}]
dev-python/wsgiproxy2[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python{2_7,3_2} )
)"
S="${WORKDIR}/${MY_P}"
@@ -66,15 +66,6 @@ python_test() {
nosetests || die "Tests fail with ${EPYTHON}"
}
-python_install() {
- distutils-r1_python_install
-
- # Why is it so?
- if python_is_python3; then
- rm -f "${D}$(python_get_sitedir)"/webtest/lint3.py
- fi
-}
-
python_install_all() {
use doc && local HTML_DOCS=( html/. )
distutils-r1_python_install_all