summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libe/ChangeLog9
-rw-r--r--dev-libs/libe/libe-0.9.0.ebuild27
2 files changed, 34 insertions, 2 deletions
diff --git a/dev-libs/libe/ChangeLog b/dev-libs/libe/ChangeLog
index cef87c8366b5..e6d049235768 100644
--- a/dev-libs/libe/ChangeLog
+++ b/dev-libs/libe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libe
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libe/ChangeLog,v 1.15 2014/11/23 12:53:09 patrick Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libe/ChangeLog,v 1.16 2015/01/13 02:35:00 patrick Exp $
+
+*libe-0.9.0 (13 Jan 2015)
+
+ 13 Jan 2015; Patrick Lauer <patrick@gentoo.org> +libe-0.9.0.ebuild:
+ Bump
*libe-0.8.2 (23 Nov 2014)
diff --git a/dev-libs/libe/libe-0.9.0.ebuild b/dev-libs/libe/libe-0.9.0.ebuild
new file mode 100644
index 000000000000..6a8c54c46509
--- /dev/null
+++ b/dev-libs/libe/libe-0.9.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libe/libe-0.9.0.ebuild,v 1.1 2015/01/13 02:35:00 patrick Exp $
+EAPI=4
+
+inherit eutils
+
+# bit messy at the moment, next release should fix it I hope
+RESTRICT="test"
+
+DESCRIPTION="Hyperdex libe support library"
+
+HOMEPAGE="http://hyperdex.org"
+SRC_URI="http://hyperdex.org/src/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+
+RDEPEND=">=dev-libs/libpo6-0.6.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i -e 's/_strtoui64/strtoul/' e/convert.h || die
+}