summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/activesupport/ChangeLog6
-rw-r--r--dev-ruby/activesupport/activesupport-2.3.15.ebuild45
-rw-r--r--dev-ruby/activesupport/activesupport-3.0.19.ebuild53
-rw-r--r--dev-ruby/activesupport/activesupport-3.1.3.ebuild51
4 files changed, 5 insertions, 150 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 9dc199035ff6..ea019403fb84 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.211 2013/02/10 09:27:53 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.212 2013/02/11 19:16:27 graaff Exp $
+
+ 11 Feb 2013; Hans de Graaff <graaff@gentoo.org> -activesupport-2.3.15.ebuild,
+ -activesupport-3.0.19.ebuild, -activesupport-3.1.3.ebuild:
+ Remove vulnerable versions.
10 Feb 2013; Hans de Graaff <graaff@gentoo.org> activesupport-3.2.11.ebuild:
Add missing tzinfo to the test dependencies, bug 455036.
diff --git a/dev-ruby/activesupport/activesupport-2.3.15.ebuild b/dev-ruby/activesupport/activesupport-2.3.15.ebuild
deleted file mode 100644
index cf8f8b63b0e9..000000000000
--- a/dev-ruby/activesupport/activesupport-2.3.15.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.15.ebuild,v 1.5 2013/01/09 15:12:52 ago Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Utility Classes and Extension to the Standard Library"
-HOMEPAGE="http://rubyforge.org/projects/activesupport/"
-
-LICENSE="MIT"
-SLOT="2.3"
-KEYWORDS="amd64 ~hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/builder-2.1.2:0 >=dev-ruby/tzinfo-0.3.16 >=dev-ruby/i18n-0.4.1:0.4"
-
-all_ruby_prepare() {
- # Remove the bundled packages!
- rm -r lib/active_support/vendor/{tzinfo,builder,i18n}-* \
- || die "failed to remove vendor packages"
-
- # This patch removes the fallback to local vendorized gems, as well
- # as fixing the dependencies for i18n to use the correct slot. It
- # also edits the metadata file so that the dependencies are added to
- # the specification, which is required for bundler to pick them up
- # (which in turn is required by radiant 1.0.0rc3 to
- # work). Furthermore remove the references to the vendorized copies
- # from the specification, to be safe.
- mv ../metadata . || die
- epatch "${FILESDIR}"/${PN}-2.3.15-unvendorize.patch
- mv metadata .. || die
- sed -i -e '/\/vendor\//d' ../metadata
-
- # don't support older mocha versions as the optional codepath
- # breaks JRuby
- epatch "${FILESDIR}"/${PN}-2.3.5-mocha-0.9.5.patch
-}
diff --git a/dev-ruby/activesupport/activesupport-3.0.19.ebuild b/dev-ruby/activesupport/activesupport-3.0.19.ebuild
deleted file mode 100644
index fa1f5185b236..000000000000
--- a/dev-ruby/activesupport/activesupport-3.0.19.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.0.19.ebuild,v 1.1 2013/01/09 09:16:15 graaff Exp $
-
-EAPI=4
-
-# jruby fails tests.
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="Utility Classes and Extension to the Standard Library"
-HOMEPAGE="http://rubyforge.org/projects/activesupport/"
-SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="3.0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_S="rails-rails-*/${PN}"
-
-ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8"
-
-# libxml-ruby and nokogiri are not strictly needed, but there are tests
-# using this code.
-ruby_add_bdepend "test? ( >=dev-ruby/libxml-2.0.0 dev-ruby/nokogiri >=dev-ruby/mocha-0.10.5 )"
-
-all_ruby_prepare() {
- # don't support older mocha versions as the optional codepath
- # breaks JRuby
- epatch "${FILESDIR}"/${PN}-3.0.3-mocha-0.9.5.patch
-
- # Set test environment to our hand.
- rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
-
- # Avoid tests that do not work with newer versions of mocha.
- rm test/whiny_nil_test.rb || die
-
- # Avoid tests failing due to slightly different builder semantics.
- sed -i -e '/test_one_level_with_nils/,/end/ s:^:#:' \
- -e '/test_one_level_with_skipping_types/,/end/ s:^:#:' \
- test/core_ext/hash_ext_test.rb || die
-}
diff --git a/dev-ruby/activesupport/activesupport-3.1.3.ebuild b/dev-ruby/activesupport/activesupport-3.1.3.ebuild
deleted file mode 100644
index 37d03805194b..000000000000
--- a/dev-ruby/activesupport/activesupport-3.1.3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.1.3.ebuild,v 1.8 2013/01/15 07:19:48 zerochaos Exp $
-
-EAPI=4
-
-# jruby fails tests.
-USE_RUBY="ruby18 ree18 ruby19"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Utility Classes and Extension to the Standard Library"
-HOMEPAGE="http://rubyforge.org/projects/activesupport/"
-SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="3.1"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_S="rails-rails-*/${PN}"
-
-ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8
- >=dev-ruby/multi_json-1.0
- dev-ruby/i18n:0.6
- !!<dev-ruby/activesupport-3.0.11-r1:3.0"
-
-# libxml-ruby, nokogiri, and builder are not strictly needed, but there
-# are tests using this code.
-ruby_add_bdepend "test? (
- virtual/ruby-test-unit
- >=dev-ruby/libxml-2.0.0
- dev-ruby/nokogiri
- dev-ruby/builder:0
- )"
-
-all_ruby_prepare() {
- # don't support older mocha versions as the optional codepath
- # breaks JRuby
- epatch "${FILESDIR}"/${PN}-3.0.3-mocha-0.9.5.patch
-
- # Set test environment to our hand.
-# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
-}