summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/wine/ChangeLog6
-rw-r--r--app-emulation/wine/files/20050211-docs.patch18
-rw-r--r--app-emulation/wine/wine-20050111.ebuild7
-rw-r--r--app-emulation/wine/wine-20050211.ebuild10
4 files changed, 37 insertions, 4 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index ada8f0872b94..6762e959e88c 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/wine
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.87 2005/02/12 19:50:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.88 2005/02/20 02:30:35 vapier Exp $
+
+ 19 Feb 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/20050211-docs.patch, wine-20050111.ebuild, wine-20050211.ebuild:
+ Add patch to fix sgml error and pdf/ps misdetection #73458.
*wine-20050211 (12 Feb 2005)
diff --git a/app-emulation/wine/files/20050211-docs.patch b/app-emulation/wine/files/20050211-docs.patch
new file mode 100644
index 000000000000..e47d09602d01
--- /dev/null
+++ b/app-emulation/wine/files/20050211-docs.patch
@@ -0,0 +1,18 @@
+--- documentation/getting.sgml.orig 2005-02-19 21:00:05.000000000 -0500
++++ documentation/getting.sgml 2005-02-19 21:01:20.000000000 -0500
+@@ -30,6 +30,7 @@
+ few clicks. Building your own installable binary package from a
+ source package is also possible, although it is beyond the scope of
+ this guide.
++ </para>
+ </sect2>
+
+ <sect2 id="installation-methods-source">
+@@ -96,6 +97,7 @@
+ installing a Wine package. See the section on <link
+ linkend="uninstalling-wine-source">uninstalling Wine from source
+ </link> for proper instructions.
++ </para>
+ </sect2>
+ <sect2>
+ <title>Different Distributions</title>
diff --git a/app-emulation/wine/wine-20050111.ebuild b/app-emulation/wine/wine-20050111.ebuild
index d4aefdca9def..8b12bf7fc259 100644
--- a/app-emulation/wine/wine-20050111.ebuild
+++ b/app-emulation/wine/wine-20050111.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050111.ebuild,v 1.2 2005/02/12 18:58:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050111.ebuild,v 1.3 2005/02/20 02:30:35 vapier Exp $
inherit eutils flag-o-matic
@@ -69,6 +69,11 @@ src_compile() {
strip-flags
use lcms && append-flags -I${ROOT}/usr/include/lcms
+ if ! built_with_use app-text/docbook-sgml-utils tetex ; then
+ export DB2PDF=true
+ export DB2PS=true
+ fi
+
# $(use_enable amd64 win64)
# USE=debug is broken in this release
econf \
diff --git a/app-emulation/wine/wine-20050211.ebuild b/app-emulation/wine/wine-20050211.ebuild
index 9150e272f5d5..67838f3b5861 100644
--- a/app-emulation/wine/wine-20050211.ebuild
+++ b/app-emulation/wine/wine-20050211.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.1 2005/02/12 19:50:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.2 2005/02/20 02:30:35 vapier Exp $
inherit eutils flag-o-matic
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="-* ~x86"
+KEYWORDS="-* ~amd64 ~x86"
IUSE="X alsa arts cups debug nas opengl gif glut jack jpeg oss ncurses doc lcms"
RESTRICT="maketest" #72375
@@ -39,6 +39,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
+ epatch "${FILESDIR}"/20050211-docs.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
test_flag -fstack-protector && epatch "${FILESDIR}"/20041019-no-stack.patch #66002
@@ -69,6 +70,11 @@ src_compile() {
strip-flags
use lcms && append-flags -I${ROOT}/usr/include/lcms
+ if ! built_with_use app-text/docbook-sgml-utils tetex ; then
+ export DB2PDF=true
+ export DB2PS=true
+ fi
+
# $(use_enable amd64 win64)
# USE=debug is broken in this release
econf \