summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/bluecloth/ChangeLog8
-rw-r--r--dev-ruby/bluecloth/bluecloth-2.0.7.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ruby/bluecloth/ChangeLog b/dev-ruby/bluecloth/ChangeLog
index c5cbca838f33..073f82404eb1 100644
--- a/dev-ruby/bluecloth/ChangeLog
+++ b/dev-ruby/bluecloth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/bluecloth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/ChangeLog,v 1.33 2010/01/18 20:13:27 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/ChangeLog,v 1.34 2010/01/26 19:16:12 flameeyes Exp $
+
+*bluecloth-2.0.7 (26 Jan 2010)
+
+ 26 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +bluecloth-2.0.7.ebuild:
+ Version bump.
18 Jan 2010; Brent Baude <ranger@gentoo.org> bluecloth-2.0.5-r1.ebuild:
Marking bluecloth-2.0.5-r1 ~ppc for bug 297041
diff --git a/dev-ruby/bluecloth/bluecloth-2.0.7.ebuild b/dev-ruby/bluecloth/bluecloth-2.0.7.ebuild
new file mode 100644
index 000000000000..ceda573b7ba3
--- /dev/null
+++ b/dev-ruby/bluecloth/bluecloth-2.0.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/bluecloth-2.0.7.ebuild,v 1.1 2010/01/26 19:16:12 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_VERSION="${PV/_pre/.pre}"
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README"
+RUBY_FAKEGEM_DOCDIR="docs/api"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A Ruby implementation of Markdown"
+HOMEPAGE="http://www.deveiate.org/projects/BlueCloth"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/rdoc-2.4.1 dev-ruby/rake-compiler"
+ruby_add_bdepend test "dev-ruby/rspec
+ dev-ruby/diff-lcs"
+
+all_ruby_prepare() {
+ # The Rakefile uses the rubygems' package_task unconditionally,
+ # but this breaks when we don't install rubygems proper (like for
+ # Ruby 1.9 or JRuby). For this reason, patch it away. It should
+ # really be submitted upstream so that, if missing, only the
+ # packaging tasks will be ignored.
+ sed -i \
+ -e '/^\(Gem\|Rake\)::PackageTask/, /^end/ s:^:#:' \
+ -e '/package_task/s:^:#:' \
+ -e '/task :package/s:^:#:' \
+ rake/packaging.rb || die
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake compile || die "extension build failed"
+}