summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/Imaging/Imaging-1.1.2.ebuild102
-rw-r--r--dev-python/Imaging/files/digest-Imaging-1.1.21
-rw-r--r--dev-python/ReportLab/ReportLab-1.11.ebuild42
-rw-r--r--dev-python/ReportLab/files/digest-ReportLab-1.111
4 files changed, 146 insertions, 0 deletions
diff --git a/dev-python/Imaging/Imaging-1.1.2.ebuild b/dev-python/Imaging/Imaging-1.1.2.ebuild
new file mode 100644
index 000000000000..5c95572672a2
--- /dev/null
+++ b/dev-python/Imaging/Imaging-1.1.2.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Python Imaging Library (PIL)."
+
+SRC_URI="http://www.pythonware.com/downloads/${P}.tar.gz"
+
+HOMEPAGE="http://www.pythonware.com/downloads/#pil"
+
+DEPEND=">=dev-lang/python-2.0
+ >=media-libs/jpeg-6a
+ >=sys-libs/zlib-0.95
+ tcltk? ( dev-lang/tcl-tk )"
+
+#Change tcltk dependency to: tcltk? ( dev-tcltk/tk ),
+#if my separated tcl and tk ebuilds ever make it in portage tree.
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ #This is a goofy build.
+
+ #Build the core imaging library (libImaging.a)
+ cd ${S}/libImaging
+
+ ./configure --prefix=/usr \
+ --host=${CHOST} || die
+ cp Makefile Makefile.orig
+
+ #Not configured by configure
+ sed \
+ -e "s:\(JPEGINCLUDE=[[:blank:]]*/usr/\)local/\(include\).*:\1\2:" \
+ -e "s:\(OPT=[[:blank:]]*\).*:\1${CFLAGS}:" \
+ Makefile.orig > Makefile
+
+ emake || die
+
+ #Build loadable python modules
+ cd ${S}
+
+ local scmd=""
+
+ #First change all the "/usr/local" to "/usr"
+ scmd="$scmd s:/usr/local:/usr:g;"
+
+ # adjust for USE tcltk
+ if use tcltk; then
+ # Find the version of tcl/tk that has headers installed.
+ # This will be the most recently merged, not necessarily the highest
+ # version number.
+ tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
+ tkv=$( grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
+ # adjust Setup to match
+ scmd="$scmd s/-ltcl[0-9.]* -ltk[0-9.]*/-ltcl$tclv -ltk$tkv/;"
+ else
+ scmd="$scmd s:\(^_imagingtk\):#\1:;"
+ fi
+
+ sed "$scmd" Setup.in > Setup
+
+ #No configure (#$%@!%%)
+ scmd=""
+ cp Makefile.pre.in Makefile.pre.in.orig
+ #change all the "/usr/local" to "/usr" (haven't we been here before)
+ scmd="$scmd s:/usr/local:/usr:g;"
+ #fix man paths
+ scmd="$scmd "'s:^\(MANDIR=.*/\)\(man\):\1share/\2:;'
+ #Insert make.conf CFLAGS settings
+ scmd="$scmd "'s:$(OPT)'":${CFLAGS}:;"
+
+ sed "$scmd" Makefile.pre.in.orig > Makefile.pre.in
+
+ #Now generate a top level Makefile
+ make -f Makefile.pre.in boot || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ #grab python verision so ebuild doesn't depend on it
+ local pv
+ pv=$(python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:')
+
+
+ insinto /usr/lib/python$pv/site-packages
+ doins PIL.pth
+
+ insinto /usr/lib/python$pv/site-packages/PIL
+ doins _imaging.so PIL/*
+ use tcltk && doins _imagingtk.so
+
+ dodoc CHANGES CONTENTS FORMATS README
+
+}
+
diff --git a/dev-python/Imaging/files/digest-Imaging-1.1.2 b/dev-python/Imaging/files/digest-Imaging-1.1.2
new file mode 100644
index 000000000000..859dddd5c3e6
--- /dev/null
+++ b/dev-python/Imaging/files/digest-Imaging-1.1.2
@@ -0,0 +1 @@
+MD5 a17e1a769c7cfbd0ca0b358aa96ecd05 Imaging-1.1.2.tar.gz 339968
diff --git a/dev-python/ReportLab/ReportLab-1.11.ebuild b/dev-python/ReportLab/ReportLab-1.11.ebuild
new file mode 100644
index 000000000000..94175664696a
--- /dev/null
+++ b/dev-python/ReportLab/ReportLab-1.11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# /home/cvsroot/gentoo-x86/dev-python/Numeric/Numeric-19.0.0.ebuild,v 1.3 2001/08/31 03:23:38 pm Exp
+
+#goofy tarball versioning
+vmaj=${PV%%.*}
+vmin=${PV##*.}
+
+S=${WORKDIR}/reportlab
+DESCRIPTION="Tools for generating printable PDF documents from any data source."
+SRC_URI="http://www.reportlab.com/ftp/${PN}_${vmaj}_${vmin}.tgz"
+HOMEPAGE="http://www.reportlab.com/"
+
+DEPEND=">=dev-lang/python-2.0
+ >=sys-libs/zlib-0.95
+ dev-python/Imaging"
+
+RDEPEND=${DEPEND}
+
+src_install() {
+
+ #grab python verision so ebuild doesn't depend on it
+ local pv
+ pv=$(python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:')
+
+
+ insinto /usr/lib/python$pv/site-packages
+ echo "reportlab" > reportlab.pth
+ doins reportlab.pth
+ #I'm feeling lazy
+ cd ../
+ cp -a reportlab ${D}/usr/lib/python$pv/site-packages
+
+ cd ${S}
+ dodoc README license.txt
+
+}
+
+
+
+
diff --git a/dev-python/ReportLab/files/digest-ReportLab-1.11 b/dev-python/ReportLab/files/digest-ReportLab-1.11
new file mode 100644
index 000000000000..9c60a3378300
--- /dev/null
+++ b/dev-python/ReportLab/files/digest-ReportLab-1.11
@@ -0,0 +1 @@
+MD5 4f76901de9a5d8f09052df4fc7c1eebd ReportLab_1_11.tgz 2465792