summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/openmotif/Manifest2
-rw-r--r--x11-libs/openmotif/files/digest-openmotif-2.2.3-r21
-rw-r--r--x11-libs/openmotif/openmotif-2.2.3-r2.ebuild141
3 files changed, 144 insertions, 0 deletions
diff --git a/x11-libs/openmotif/Manifest b/x11-libs/openmotif/Manifest
index 64ac44f2fcd9..cd06d863f4a3 100644
--- a/x11-libs/openmotif/Manifest
+++ b/x11-libs/openmotif/Manifest
@@ -1,5 +1,6 @@
MD5 18a738af27482c9abb5153e4227db96d openmotif-2.1.30-r6.ebuild 3861
MD5 6fff264c20ad6310193b795730887894 openmotif-2.2.3.ebuild 3251
+MD5 96687370626dd80e20d246dde193e46d openmotif-2.2.3-r2.ebuild 3626
MD5 b385c61765918c22c7effa1cb7c70076 openmotif-2.1.30-r5.ebuild 3705
MD5 857765a311c1db686b7e2f975facbb0e openmotif-2.1.30-r7.ebuild 4781
MD5 f4704a04776292a53963f2f1ed9761be ChangeLog 11507
@@ -8,6 +9,7 @@ MD5 9b9944f935f1d0a18a551baa873adb53 openmotif-2.2.3-r1.ebuild 3267
MD5 84da30838fedca094e625631fd6dbbaa openmotif-2.1.30-r4.ebuild 3288
MD5 ee3a092a933a6393bf14d5d7e6231934 files/openmotif-2.1.30-xpm2.diff 47085
MD5 744ea82c1ac06c88fb0e8c93418d5a6e files/digest-openmotif-2.2.3-r1 68
+MD5 744ea82c1ac06c88fb0e8c93418d5a6e files/digest-openmotif-2.2.3-r2 68
MD5 61fb956ff4bc34bc503cdb2226fd037b files/openmotif-2.1.30-darwin-netbsd.diff 16799
MD5 339b1b38271b9dfdd8c476429b55787e files/openmotif-2.2.3-pixel_length.patch 450
MD5 744ea82c1ac06c88fb0e8c93418d5a6e files/digest-openmotif-2.2.3 68
diff --git a/x11-libs/openmotif/files/digest-openmotif-2.2.3-r2 b/x11-libs/openmotif/files/digest-openmotif-2.2.3-r2
new file mode 100644
index 000000000000..a6451299c75a
--- /dev/null
+++ b/x11-libs/openmotif/files/digest-openmotif-2.2.3-r2
@@ -0,0 +1 @@
+MD5 94c96a0f94ee0d5e41d3dba2188b263d openMotif-2.2.3.tar.gz 5149785
diff --git a/x11-libs/openmotif/openmotif-2.2.3-r2.ebuild b/x11-libs/openmotif/openmotif-2.2.3-r2.ebuild
new file mode 100644
index 000000000000..9f47d4b7e65b
--- /dev/null
+++ b/x11-libs/openmotif/openmotif-2.2.3-r2.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.2.3-r2.ebuild,v 1.1 2005/02/16 13:44:49 lanius Exp $
+
+inherit eutils libtool flag-o-matic multilib
+
+MY_P=${P/m/M}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Open Motif"
+HOMEPAGE="http://www.motifzone.org/"
+SRC_URI="ftp://ftp.motifzone.net/om${PV}/src/${MY_P}.tar.gz"
+
+LICENSE="MOTIF"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~ppc-macos ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ virtual/x11
+ >=sys-apps/sed-4
+ !ppc-macos? ( =sys-devel/automake-1.4* )
+ =sys-devel/autoconf-2.5*
+ x11-libs/motif-config"
+RDEPEND="virtual/libc
+ virtual/x11
+ x11-libs/motif-config"
+
+PROVIDE="virtual/motif"
+SLOT="2.2"
+
+pkg_setup() {
+ # multilib includes don't work right in this package...
+ [ -n "${ABI}" ] && append-flags "-I/usr/include/gentoo-multilib/${ABI}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # various patches
+ epatch ${FILESDIR}/${P}-mwm-configdir.patch
+ epatch ${FILESDIR}/${P}-CAN-2004-0687-0688.patch.bz2
+ epatch ${FILESDIR}/${P}-CAN-2004-0914.patch.bz2
+ epatch ${FILESDIR}/${P}-CAN-2004-0914_sec8.patch
+ epatch ${FILESDIR}/${P}-char_not_supported.patch
+ epatch ${FILESDIR}/${P}-pixel_length.patch
+ epatch ${FILESDIR}/${P}-popup_timeout.patch
+ epatch ${FILESDIR}/${P}-XmResizeHashTable.patch
+ epatch ${FILESDIR}/${P}-utf8.patch
+ epatch ${FILESDIR}/${P}-no_demos.patch
+ use ppc-macos && epatch ${FILESDIR}/${P}-automake.patch
+
+ # autotool stuff
+ export WANT_AUTOCONF=2.5
+
+ # Patched Makefile.am to work with version 1.6 on ppc-macos.
+ # Untested elsewhere
+ use ppc-macos || export WANT_AUTOMAKE=1.4
+
+ libtoolize --force --copy
+ aclocal || die
+ AUTOMAKE_OPTS="--foreign"
+ # For some reason ppc-macos complains about missing depcomp and compile
+ # files
+ use ppc-macos && AUTOMAKE_OPTS="-a -c -f ${AUTOMAKE_OPTS}"
+ automake ${AUTOMAKE_OPTS} || die
+ autoconf || die
+}
+
+
+src_compile() {
+ # get around some LANG problems in make (#15119)
+ unset LANG
+
+ # fails to copmile with -jx
+ export MAKEOPTS="${MAKEOPTS} -j1"
+
+ # bug #80421
+ filter-flags -ftracer
+
+ econf --with-x || die "configuration failed"
+
+ emake || die "make failed, if you have lesstif installed removed it, compile openmotif and recompile lesstif"
+}
+
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ # cleanups
+ rm -fR ${D}/usr/$(get_libdir)/X11
+ rm -fR ${D}/usr/$(get_libdir)/X11/bindings
+ rm -fR ${D}/usr/include/X11/
+
+ list="/usr/share/man/man1/mwm.1 /usr/share/man/man4/mwmrc.4"
+ for f in $list; do
+ dosed 's:/usr/lib/X11/\(.*system\\&\.mwmrc\):/etc/X11/mwm/\1:g' "$f"
+ dosed 's:/usr/lib/X11/app-defaults:/etc/X11/app-defaults:g' "$f"
+ done
+
+
+ einfo "Fixing binaries"
+ for file in `ls ${D}/usr/bin`
+ do
+ mv ${D}/usr/bin/${file} ${D}/usr/bin/${file}-openmotif-2.2
+ done
+
+ einfo "Fixing libraries"
+ dodir /usr/$(get_libdir)/openmotif-2.2
+ mv ${D}/usr/$(get_libdir)/* ${D}/usr/$(get_libdir)/openmotif-2.2/
+
+ einfo "Fixing includes"
+ dodir /usr/include/openmotif-2.2/
+ mv ${D}/usr/include/* ${D}/usr/include/openmotif-2.2
+
+ einfo "Fixing man pages"
+ mans="1 3 4 5"
+ for man in $mans; do
+ dodir /usr/share/man/man${man}
+ for file in `ls ${D}/usr/share/man/man${man}`
+ do
+ file=${file/.${man}/}
+ mv ${D}/usr/share/man/man$man/${file}.${man} ${D}/usr/share/man/man${man}/${file}-openmotif-2.2.${man}
+ done
+ done
+
+
+ # install docs
+ dodoc COPYRIGHT.MOTIF LICENSE
+ dodoc README RELEASE RELNOTES
+ dodoc BUGREPORT TODO
+}
+
+# Profile stuff
+pkg_postinst() {
+ motif-config --install openmotif-2.2
+}
+
+pkg_prerm() {
+ motif-config --uninstall openmotif-2.2
+}