summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/xdebug-client/ChangeLog8
-rw-r--r--dev-php/xdebug-client/files/digest-xdebug-client-2.0.03
-rw-r--r--dev-php/xdebug-client/xdebug-client-2.0.0.ebuild37
3 files changed, 47 insertions, 1 deletions
diff --git a/dev-php/xdebug-client/ChangeLog b/dev-php/xdebug-client/ChangeLog
index c6e3b12f9c3c..75537745d974 100644
--- a/dev-php/xdebug-client/ChangeLog
+++ b/dev-php/xdebug-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/xdebug-client
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.4 2007/06/30 17:18:36 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.5 2007/08/16 21:34:07 hoffie Exp $
+
+*xdebug-client-2.0.0 (16 Aug 2007)
+
+ 16 Aug 2007; Christian Hoffmann <hoffie@gentoo.org>
+ +xdebug-client-2.0.0.ebuild:
+ version bump wrt bug 186167, thanks to Walter <walter@pratyeka.org>
*xdebug-client-2.0.0_rc4 (30 Jun 2007)
diff --git a/dev-php/xdebug-client/files/digest-xdebug-client-2.0.0 b/dev-php/xdebug-client/files/digest-xdebug-client-2.0.0
new file mode 100644
index 000000000000..f7bdf57c4831
--- /dev/null
+++ b/dev-php/xdebug-client/files/digest-xdebug-client-2.0.0
@@ -0,0 +1,3 @@
+MD5 0f9ecb9c5331d0041b04be9566763171 xdebug-2.0.0.tgz 272342
+RMD160 1902f0b6227d3d8adfa3fc6bbc9cba06a604b2d4 xdebug-2.0.0.tgz 272342
+SHA256 d29f393d4db1aa403200ac242614f86c06c1f111b290c4c8a612f8322e7f5660 xdebug-2.0.0.tgz 272342
diff --git a/dev-php/xdebug-client/xdebug-client-2.0.0.ebuild b/dev-php/xdebug-client/xdebug-client-2.0.0.ebuild
new file mode 100644
index 000000000000..b6012c903d95
--- /dev/null
+++ b/dev-php/xdebug-client/xdebug-client-2.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/xdebug-client-2.0.0.ebuild,v 1.1 2007/08/16 21:34:07 hoffie Exp $
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)."
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE="libedit"
+
+S="${WORKDIR}/xdebug-${MY_PV}/debugclient"
+
+DEPEND="libedit? ( || ( dev-libs/libedit sys-freebsd/freebsd-lib ) )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack "${A}"
+ chmod +x "${S}/configure"
+}
+
+src_compile() {
+ econf \
+ $(use_with libedit) \
+ || die "Configure of debug client failed!"
+
+ emake || die "Build of debug client failed!"
+}
+
+src_install() {
+ newbin debugclient xdebug
+}