summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-benchmarks/bonnie++/bonnie++-1.03.ebuild20
-rw-r--r--app-benchmarks/iozone/iozone-3.218.ebuild31
-rw-r--r--app-benchmarks/lmbench/lmbench-3.0_alpha3.ebuild4
-rw-r--r--app-benchmarks/pipebench/pipebench-0.40.ebuild12
-rw-r--r--app-benchmarks/tiobench/tiobench-0.3.3-r1.ebuild16
-rw-r--r--app-benchmarks/tiobench/tiobench-0.3.3.ebuild16
6 files changed, 42 insertions, 57 deletions
diff --git a/app-benchmarks/bonnie++/bonnie++-1.03.ebuild b/app-benchmarks/bonnie++/bonnie++-1.03.ebuild
index 3f580ca15b3a..93442620cc96 100644
--- a/app-benchmarks/bonnie++/bonnie++-1.03.ebuild
+++ b/app-benchmarks/bonnie++/bonnie++-1.03.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bonnie++/bonnie++-1.03.ebuild,v 1.8 2004/06/24 21:27:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bonnie++/bonnie++-1.03.ebuild,v 1.9 2004/06/27 20:52:15 vapier Exp $
DESCRIPTION="Hard drive bottleneck testing benchmark suite."
HOMEPAGE="http://www.coker.com.au/bonnie++/"
@@ -11,23 +11,21 @@ SLOT="0"
KEYWORDS="x86 ~ppc ~sparc alpha ~amd64"
IUSE="debug"
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_compile() {
- local myconf="`use_with debug`"
- use debug \
- && myconf="${myconf} --disable-stripping" \
- || myconf="${myconf} --enable-stripping"
-
- econf ${myconf} || die
+ econf \
+ `use_with debug` \
+ `use_enable !debug stripping` \
+ || die
emake || die "emake failed"
emake zcav || die "emake zcav failed" # see #9073
}
src_install() {
- dosbin bonnie++ zcav
- dobin bon_csv2html bon_csv2txt
+ dosbin bonnie++ zcav || die
+ dobin bon_csv2html bon_csv2txt || die
doman bon_csv2html.1 bon_csv2txt.1 bonnie++.8 zcav.8
dohtml readme.html
- dodoc changelog.txt copyright.txt credits.txt
+ dodoc changelog.txt credits.txt
}
diff --git a/app-benchmarks/iozone/iozone-3.218.ebuild b/app-benchmarks/iozone/iozone-3.218.ebuild
index ee3ecd783a6c..dcd9f27ddd51 100644
--- a/app-benchmarks/iozone/iozone-3.218.ebuild
+++ b/app-benchmarks/iozone/iozone-3.218.ebuild
@@ -1,16 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/iozone/iozone-3.218.ebuild,v 1.3 2004/06/24 21:28:04 agriffis Exp $
-
-IUSE=""
-
-inherit eutils
-
-DESCRIPTION="Filesystem benchmarking program."
-HOMEPAGE="http://www.iozone.org/"
-SRC_URI="http://www.iozone.org/src/current/${PN}${PV/./_}.tar"
-LICENSE="freedist"
-SLOT="0"
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/iozone/iozone-3.218.ebuild,v 1.4 2004/06/27 20:53:00 vapier Exp $
# TODO
# -> linux-arm (32bit) <-
@@ -25,22 +15,27 @@ SLOT="0"
# -> openbsd (32bit) <-
# -> openbsd-threads (32bit) <-
#
-#
# ~arm ~amd64 ~ia64 ~s390 alpha(?)
-KEYWORDS="~x86 ~ppc ~sparc"
+inherit eutils
+DESCRIPTION="Filesystem benchmarking program"
+HOMEPAGE="http://www.iozone.org/"
+SRC_URI="http://www.iozone.org/src/current/${PN}${PV/./_}.tar"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE=""
DEPEND="sys-devel/gcc
>=sys-apps/sed-4
- virtual/glibc"
-
-RDEPEND="virtual/glibc"
+ virtual/libc"
+RDEPEND="virtual/libc"
S=${WORKDIR}
src_compile() {
-
cd src/current
# Options FIX
@@ -84,8 +79,6 @@ src_install() {
}
src_test() {
-
cd ${T}
${S}/src/current/iozone testfile || die "self test failed"
-
}
diff --git a/app-benchmarks/lmbench/lmbench-3.0_alpha3.ebuild b/app-benchmarks/lmbench/lmbench-3.0_alpha3.ebuild
index 7561ceeade13..02966468d47c 100644
--- a/app-benchmarks/lmbench/lmbench-3.0_alpha3.ebuild
+++ b/app-benchmarks/lmbench/lmbench-3.0_alpha3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/lmbench/lmbench-3.0_alpha3.ebuild,v 1.8 2004/06/24 21:28:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/lmbench/lmbench-3.0_alpha3.ebuild,v 1.9 2004/06/27 20:53:32 vapier Exp $
inherit gcc
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="x86 ppc ~amd64 ~sparc"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
S=${WORKDIR}/${MY_P}
diff --git a/app-benchmarks/pipebench/pipebench-0.40.ebuild b/app-benchmarks/pipebench/pipebench-0.40.ebuild
index cdde0f2e7456..9c705ba6f8e0 100644
--- a/app-benchmarks/pipebench/pipebench-0.40.ebuild
+++ b/app-benchmarks/pipebench/pipebench-0.40.ebuild
@@ -1,24 +1,18 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/pipebench/pipebench-0.40.ebuild,v 1.2 2004/06/24 21:28:49 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/pipebench/pipebench-0.40.ebuild,v 1.3 2004/06/27 20:53:56 vapier Exp $
DESCRIPTION="Measures the speed of stdin/stdout communication"
-
HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=pipebench"
-
SRC_URI="ftp://ftp.habets.pp.se/pub/synscan/${P}.tar.gz"
LICENSE="GPL-2"
-
SLOT="0"
-
KEYWORDS="~x86"
-
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
-#Add make.conf CFLAGS, add the ${D} and fix the install dirs here (no /.configure).
src_unpack() {
unpack ${P}.tar.gz
cd ${S} || die "Manual configure failed"
@@ -37,5 +31,5 @@ src_compile() {
src_install() {
dodir /usr/{bin,share/man/man1}
make install || die
- dodoc README LICENSE
+ dodoc README
}
diff --git a/app-benchmarks/tiobench/tiobench-0.3.3-r1.ebuild b/app-benchmarks/tiobench/tiobench-0.3.3-r1.ebuild
index 02be46f4e057..88106d0d18a6 100644
--- a/app-benchmarks/tiobench/tiobench-0.3.3-r1.ebuild
+++ b/app-benchmarks/tiobench/tiobench-0.3.3-r1.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/tiobench/tiobench-0.3.3-r1.ebuild,v 1.2 2004/06/24 21:29:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/tiobench/tiobench-0.3.3-r1.ebuild,v 1.3 2004/06/27 20:54:39 vapier Exp $
DESCRIPTION="Portable, robust, fully-threaded I/O benchmark program"
HOMEPAGE="http://tiobench.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-KEYWORDS="x86"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86"
IUSE=""
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
dev-lang/perl"
DEPEND=">=sys-apps/sed-4"
@@ -19,12 +19,12 @@ src_unpack() {
unpack ${A}
cd ${S}
sed -i \
- -e 's:/usr/local/bin:/usr/sbin:' tiobench.pl || \
- die "sed tiobench.pl failed"
+ -e 's:/usr/local/bin:/usr/sbin:' tiobench.pl \
+ || die "sed tiobench.pl failed"
sed -i \
-e '/DLARGEFILES/ s/^#//' \
- -e "/^CFLAGS/ s:=.*:= ${CFLAGS}:" Makefile || \
- die "sed Makefile failed"
+ -e "/^CFLAGS/ s:=.*:= ${CFLAGS}:" Makefile \
+ || die "sed Makefile failed"
}
src_compile() {
@@ -33,5 +33,5 @@ src_compile() {
src_install() {
dosbin tiotest tiobench.pl tiosum.pl || die "dosbin failed"
- dodoc BUGS ChangeLog README TODO || die "dodoc failed"
+ dodoc BUGS ChangeLog README TODO
}
diff --git a/app-benchmarks/tiobench/tiobench-0.3.3.ebuild b/app-benchmarks/tiobench/tiobench-0.3.3.ebuild
index 46399407341d..f30b80605665 100644
--- a/app-benchmarks/tiobench/tiobench-0.3.3.ebuild
+++ b/app-benchmarks/tiobench/tiobench-0.3.3.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/tiobench/tiobench-0.3.3.ebuild,v 1.4 2004/06/24 21:29:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/tiobench/tiobench-0.3.3.ebuild,v 1.5 2004/06/27 20:54:39 vapier Exp $
DESCRIPTION="Portable, robust, fully-threaded I/O benchmark program"
HOMEPAGE="http://tiobench.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-KEYWORDS="x86"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86"
IUSE=""
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
dev-lang/perl"
DEPEND=">=sys-apps/sed-4"
@@ -19,12 +19,12 @@ src_unpack() {
unpack ${A}
cd ${S}
sed -i \
- -e 's:/usr/local/bin:/usr/sbin:' tiobench.pl || \
- die "sed tiobench.pl failed"
+ -e 's:/usr/local/bin:/usr/sbin:' tiobench.pl \
+ || die "sed tiobench.pl failed"
sed -i \
-e '/DLARGEFILES/ s/^#//' \
- -e "/^CFLAGS/ s:=.*:= ${CFLAGS}:" Makefile || \
- die "sed Makefile failed"
+ -e "/^CFLAGS/ s:=.*:= ${CFLAGS}:" Makefile \
+ || die "sed Makefile failed"
}
src_compile() {
@@ -33,5 +33,5 @@ src_compile() {
src_install() {
dosbin tiotest tiobench.pl tiosum.pl || die "dosbin failed"
- dodoc BUGS ChangeLog README TODO || die "dodoc failed"
+ dodoc BUGS ChangeLog README TODO
}