summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/qtsvc/qtsvc-0.1-r1.ebuild9
-rw-r--r--app-arch/kfilecoder/files/digest-kfilecoder-0.5.0-r21
-rw-r--r--app-arch/kfilecoder/kfilecoder-0.5.0-r2.ebuild23
-rw-r--r--app-text/docbook-sgml-utils/docbook-sgml-utils-0.6.6.ebuild6
-rw-r--r--dev-db/unixODBC/unixODBC-2.0.6.ebuild5
-rw-r--r--dev-db/unixODBC/unixODBC-2.0.8.ebuild5
-rw-r--r--dev-util/xxdiff/xxdiff-1.9.ebuild6
-rw-r--r--incoming/squelch-1.0.1.ebuild2
-rw-r--r--media-libs/musicbrainz/files/digest-musicbrainz-1.0.11
-rw-r--r--media-libs/musicbrainz/musicbrainz-1.0.1.ebuild22
-rw-r--r--media-sound/freeamp/files/digest-freeamp-2.1.11
-rw-r--r--media-sound/freeamp/freeamp-2.1.0.ebuild3
-rw-r--r--media-sound/freeamp/freeamp-2.1.1.ebuild52
-rw-r--r--media-video/vlc/files/digest-vlc-0.2.911
-rw-r--r--media-video/vlc/vlc-0.2.83-r1.ebuild11
-rw-r--r--media-video/vlc/vlc-0.2.90.ebuild11
-rw-r--r--profiles/package.mask3
-rw-r--r--x11-misc/toolbox/toolbox-0.6.0-r1.ebuild16
-rw-r--r--x11-wm/WindowMaker/WindowMaker-0.70.0-r1.ebuild4
-rw-r--r--x11-wm/fluxbox/fluxbox-0.1.5.ebuild4
20 files changed, 148 insertions, 38 deletions
diff --git a/app-admin/qtsvc/qtsvc-0.1-r1.ebuild b/app-admin/qtsvc/qtsvc-0.1-r1.ebuild
index a66e73234071..ccf0df9fdd56 100644
--- a/app-admin/qtsvc/qtsvc-0.1-r1.ebuild
+++ b/app-admin/qtsvc/qtsvc-0.1-r1.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/app-admin/qtsvc/qtsvc-0.1-r1.ebuild,v 1.2 2001/11/10 02:30:19 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/qtsvc/qtsvc-0.1-r1.ebuild,v 1.3 2001/12/29 21:45:08 danarmak Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A QT frontend for svc"
SRC_URI="http://www.together.net/~plomp/${P}.tar.gz"
HOMEPAGE="http://www.together.net/~plomp/qtsvc.html"
-DEPEND=">=x11-libs/qt-x11-2.2.3"
+DEPEND=">=x11-libs/qt-2.2.3"
RDEPEND="$DEPEND
>=sys-apps/daemontools-0.70"
@@ -21,8 +21,9 @@ src_unpack() {
src_compile() {
- try ./configure --host=${CHOST}
- try make CPPFLAGS=\"${CPPFLAGS} -fkeep-inline-functions\"
+ QTDIR=/usr/qt/2 ./configure --host=${CHOST} || die
+ #make CPPFLAGS=\"${CPPFLAGS} -fkeep-inline-functions\" || die
+ make || die
}
diff --git a/app-arch/kfilecoder/files/digest-kfilecoder-0.5.0-r2 b/app-arch/kfilecoder/files/digest-kfilecoder-0.5.0-r2
new file mode 100644
index 000000000000..a7ce550cc25d
--- /dev/null
+++ b/app-arch/kfilecoder/files/digest-kfilecoder-0.5.0-r2
@@ -0,0 +1 @@
+MD5 95e6ef88df4bb9a3462ca59914fac0b7 kfilecoder-0.5.0.tar.bz2 294912
diff --git a/app-arch/kfilecoder/kfilecoder-0.5.0-r2.ebuild b/app-arch/kfilecoder/kfilecoder-0.5.0-r2.ebuild
new file mode 100644
index 000000000000..dfcf6041e0f5
--- /dev/null
+++ b/app-arch/kfilecoder/kfilecoder-0.5.0-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Philippe Namias <pnamias@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-arch/kfilecoder/kfilecoder-0.5.0-r2.ebuild,v 1.1 2001/12/29 21:45:08 danarmak Exp $
+. /usr/portage/eclass/inherit.eclass
+inherit kde-base || die
+
+DESCRIPTION="Archiver with passwd management "
+SRC_URI="http://download.sourceforge.net/kfilecoder/${P}.tar.bz2"
+HOMEPAGE="http://kfilecoder.sourceforge.net"
+
+need-kde 2.1.1
+
+src_compile() {
+ rm config.cache
+ kde_src_compile
+}
+
+src_install () {
+ make DESTDIR=${D} kde_locale=${D}/usr/share/locale install || die
+ kde_src_install dodoc
+}
+
diff --git a/app-text/docbook-sgml-utils/docbook-sgml-utils-0.6.6.ebuild b/app-text/docbook-sgml-utils/docbook-sgml-utils-0.6.6.ebuild
index e4d9628c1e97..0a68a4ce5716 100644
--- a/app-text/docbook-sgml-utils/docbook-sgml-utils-0.6.6.ebuild
+++ b/app-text/docbook-sgml-utils/docbook-sgml-utils-0.6.6.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/docbook-sgml-utils/docbook-sgml-utils-0.6.6.ebuild,v 1.1 2001/03/20 05:47:31 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/docbook-sgml-utils/docbook-sgml-utils-0.6.6.ebuild,v 1.2 2001/12/29 21:45:08 danarmak Exp $
A=docbook-utils-${PV}.tar.gz
S=${WORKDIR}/docbook-utils-${PV}
@@ -14,8 +14,8 @@ DEPEND=">=sys-devel/perl-5"
src_compile() {
- try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST}
- try make
+ ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} || die
+ make || die
}
diff --git a/dev-db/unixODBC/unixODBC-2.0.6.ebuild b/dev-db/unixODBC/unixODBC-2.0.6.ebuild
index 1592281fbd46..d4371c432e1f 100644
--- a/dev-db/unixODBC/unixODBC-2.0.6.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.0.6.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.6.ebuild,v 1.2 2001/11/10 11:21:56 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.6.ebuild,v 1.3 2001/12/29 21:45:08 danarmak Exp $
S=${WORKDIR}/${P}
DESCRIPTION="ODBC Interface for Linux"
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.unixodbc.org"
DEPEND="virtual/glibc
>=sys-libs/readline-4.1
>=sys-libs/ncurses-5.2
- qt? ( >=x11-libs/qt-x11-2.3.0 )"
+ qt? ( >=x11-libs/qt-2.3.0 )"
src_unpack() {
unpack ${A}
@@ -30,6 +30,7 @@ src_compile() {
myconf="--enable-gui=no"
fi
+ export QTDIR=/usr/qt/2
./configure --host=${CHOST} \
--prefix=/usr \
--sysconfdir=/etc/unixODBC \
diff --git a/dev-db/unixODBC/unixODBC-2.0.8.ebuild b/dev-db/unixODBC/unixODBC-2.0.8.ebuild
index b2d93f4c7e42..f5c0a76955e6 100644
--- a/dev-db/unixODBC/unixODBC-2.0.8.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.0.8.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.8.ebuild,v 1.2 2001/11/10 11:21:56 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.8.ebuild,v 1.3 2001/12/29 21:45:08 danarmak Exp $
S=${WORKDIR}/${P}
DESCRIPTION="ODBC Interface for Linux"
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.unixodbc.org"
DEPEND="virtual/glibc
>=sys-libs/readline-4.1
>=sys-libs/ncurses-5.2
- qt? ( >=x11-libs/qt-x11-2.3.0 )"
+ qt? ( >=x11-libs/qt-2.3.0 )"
src_unpack() {
unpack ${A}
@@ -30,6 +30,7 @@ src_compile() {
myconf="--enable-gui=no"
fi
+ export QTDIR=/usr/qt/2
./configure --host=${CHOST} \
--prefix=/usr \
--sysconfdir=/etc/unixODBC \
diff --git a/dev-util/xxdiff/xxdiff-1.9.ebuild b/dev-util/xxdiff/xxdiff-1.9.ebuild
index a347316a7ff1..8eeb54fbc394 100644
--- a/dev-util/xxdiff/xxdiff-1.9.ebuild
+++ b/dev-util/xxdiff/xxdiff-1.9.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Michael Conrad Tilstra <michael@gentoo.org> <tadpol@tadpol.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-util/xxdiff/xxdiff-1.9.ebuild,v 1.2 2001/11/10 12:45:09 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/xxdiff/xxdiff-1.9.ebuild,v 1.3 2001/12/29 21:45:08 danarmak Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A graphical file comparator and merge tool simular to xdiff."
@@ -9,13 +9,13 @@ SRC_URI="http://prdownloads.sourceforge.net/xxdiff/${P}.src.tar.gz"
HOMEPAGE="http://xxdiff.sourceforge.net/"
DEPEND="virtual/glibc
- >=x11-libs/qt-x11-2.3.0
+ >=x11-libs/qt-2.3.0
>=sys-devel/gcc-2.95.3"
RDEPEND="sys-apps/diffutils"
src_compile() {
- ./configure --prefix=/usr --mandir=/usr/share/man || die
+ QTDIR=/usr/qt/2 ./configure --prefix=/usr --mandir=/usr/share/man || die
make || die
}
diff --git a/incoming/squelch-1.0.1.ebuild b/incoming/squelch-1.0.1.ebuild
index d45014c6d49c..f331221ffc5d 100644
--- a/incoming/squelch-1.0.1.ebuild
+++ b/incoming/squelch-1.0.1.ebuild
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.geoid.clara.net/rik/squelch.html"
DEPEND="virtual/x11 virtual/glibc
>=media-libs/libvorbis-1.0_rc1
>=media-libs/libao-0.8.0
- >=x11-libs/qt-x11-2.3.1
+ >=x11-libs/qt-2.3.1
>=media-libs/libogg-1.0_rc1"
# The runtime depends are a bit different than the compiling ones
diff --git a/media-libs/musicbrainz/files/digest-musicbrainz-1.0.1 b/media-libs/musicbrainz/files/digest-musicbrainz-1.0.1
new file mode 100644
index 000000000000..afede7ac04bf
--- /dev/null
+++ b/media-libs/musicbrainz/files/digest-musicbrainz-1.0.1
@@ -0,0 +1 @@
+MD5 0b39ff44a7b85c949fda16ffa995fc1d musicbrainz-1.0.1.tar.gz 409600
diff --git a/media-libs/musicbrainz/musicbrainz-1.0.1.ebuild b/media-libs/musicbrainz/musicbrainz-1.0.1.ebuild
new file mode 100644
index 000000000000..e050b09fe66d
--- /dev/null
+++ b/media-libs/musicbrainz/musicbrainz-1.0.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/musicbrainz/musicbrainz-1.0.1.ebuild,v 1.1 2001/12/29 21:45:08 danarmak Exp $
+
+DESCRIPTION="Client library to access free metadata about mp3/vorbis/CD media"
+S=${WORKDIR}/${P}
+SRC_URI="ftp://ftp.musicbrainz.org/pub/musicbrainz/${P}.tar.gz"
+HOMEPAGE="http://www.musicbrainz.org/"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ CC="gcc ${CFLAGS}" ./configure --prefix=/usr --mandir=/usr/share/man \
+ --host=${CHOST} ; assert
+ emake ; assert
+}
+
+src_install() {
+ make prefix=${D}/usr install ; assert
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO docs/mb_howto.txt
+}
diff --git a/media-sound/freeamp/files/digest-freeamp-2.1.1 b/media-sound/freeamp/files/digest-freeamp-2.1.1
new file mode 100644
index 000000000000..2f578304d5ad
--- /dev/null
+++ b/media-sound/freeamp/files/digest-freeamp-2.1.1
@@ -0,0 +1 @@
+MD5 56720f823f84c3505aeab474c9a6a836 freeamp-2.1.1.tar.bz2 3125248
diff --git a/media-sound/freeamp/freeamp-2.1.0.ebuild b/media-sound/freeamp/freeamp-2.1.0.ebuild
index d5fb0c770ac7..bf1a4098c098 100644
--- a/media-sound/freeamp/freeamp-2.1.0.ebuild
+++ b/media-sound/freeamp/freeamp-2.1.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Donny Davies <woodchip@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-sound/freeamp/freeamp-2.1.0.ebuild,v 1.1 2001/10/12 18:43:25 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/freeamp/freeamp-2.1.0.ebuild,v 1.2 2001/12/29 21:45:08 danarmak Exp $
# I highly suggest you read the features section of the freeamp website to
# see all the neat stuff this program can do. Pretty spiffy :)
@@ -31,6 +31,7 @@ src_compile() {
local myconf
use alsa || myconf="${myconf} --disable-alsa"
use esd || myconf="${myconf} --disable-esd"
+ use arts && export KDEDIR=/usr/kde/2
./configure --prefix=/usr --host=${CHOST} ${myconf} || die
make ; assert "compile problem :("
diff --git a/media-sound/freeamp/freeamp-2.1.1.ebuild b/media-sound/freeamp/freeamp-2.1.1.ebuild
new file mode 100644
index 000000000000..34ac53e78baf
--- /dev/null
+++ b/media-sound/freeamp/freeamp-2.1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/freeamp/freeamp-2.1.1.ebuild,v 1.1 2001/12/29 21:45:08 danarmak Exp $
+
+# I highly suggest you read the features section of the freeamp website to
+# see all the neat stuff this program can do. Pretty spiffy :)
+
+DESCRIPTION="An extremely full-featured mp3/vorbis/cd player with ALSA support"
+SRC_URI="http://www.freeamp.org/download/src/${P}.tar.bz2"
+HOMEPAGE="http://www.freeamp.org/"
+S=${WORKDIR}/freeamp
+
+RDEPEND="virtual/glibc
+ >=dev-libs/glib-1.2.5 >=x11-libs/gtk+-1.2.5
+ >=sys-libs/zlib-1.1.3 >=sys-libs/ncurses-5.2
+ ~media-libs/freetype-1.3.1 >=media-libs/musicbrainz-1.0.1
+ esd? ( media-sound/esound ) alsa? ( media-libs/alsa-lib )
+ gnome? ( gnome-base/ORBit >=media-libs/gdk-pixbuf-0.8 )
+ X? ( virtual/x11 ) arts? ( kde-base/kdelibs )
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND} dev-lang/nasm sys-devel/perl"
+
+# Unfortunately you can't selectively build a lot of the features. Therefore
+# this whole package is essentially a judgement call. However, I've made the
+# DEPEND in a strategic manner to ensure that your USE variable is respected
+# when the knobs are *set*.
+
+src_compile() {
+
+ local myconf
+ use alsa || myconf="${myconf} --disable-alsa"
+ use esd || myconf="${myconf} --disable-esd"
+ use arts && export KDEDIR=/usr/kde/2
+
+ ./configure --prefix=/usr --host=${CHOST} ${myconf} || die
+ make ; assert "compile problem :("
+}
+
+src_install() {
+
+ into /usr ; dobin freeamp
+ exeinto /usr/lib/freeamp/plugins ; doexe plugins/*
+ insinto /usr/share/freeamp/themes ; doins themes/*
+ dodir /usr/share/freeamp/fonts
+
+ dodoc AUTHORS ChangeLog CHANGES COPYING NEWS README README.linux
+
+ cd ${D}/usr/share/freeamp ; tar zxf ${S}/help/unix/freeamphelp.tar.gz
+ chown -R root.root help ; chmod 644 help/*
+ dosym /usr/share/freeamp/help /usr/share/doc/${PF}/html
+}
diff --git a/media-video/vlc/files/digest-vlc-0.2.91 b/media-video/vlc/files/digest-vlc-0.2.91
new file mode 100644
index 000000000000..ae18fef8828e
--- /dev/null
+++ b/media-video/vlc/files/digest-vlc-0.2.91
@@ -0,0 +1 @@
+MD5 a96a4ef83def70b9ab5a4ec364e43709 vlc-0.2.91.tar.gz 1081344
diff --git a/media-video/vlc/vlc-0.2.83-r1.ebuild b/media-video/vlc/vlc-0.2.83-r1.ebuild
index 8eec4cd64019..22a8ffbf1c72 100644
--- a/media-video/vlc/vlc-0.2.83-r1.ebuild
+++ b/media-video/vlc/vlc-0.2.83-r1.ebuild
@@ -1,6 +1,6 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Nathaniel Hirsch <nh2@njit.edu> Achim Gottinge <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.2.83-r1.ebuild,v 1.2 2001/10/07 11:11:08 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.2.83-r1.ebuild,v 1.3 2001/12/29 21:45:08 danarmak Exp $
S=${WORKDIR}/${P}
DESCRIPTION="DVD / video player"
@@ -11,7 +11,7 @@ DEPEND=">=media-libs/libsdl-1.1.8-r1
gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
esd? ( >=media-sound/esound-0.2.22 )
ggi? ( >=media-libs/libggi-2.0_beta3 )
- qt? ( >=x11-libs/qt-x11-2.3.0 )
+ qt? ( >=x11-libs/qt-2.3.0 )
gtk? ( >=x11-libs/gtk+-1.2.10-r4 )
#alsa? ( >=media-libs/alsa-lib-0.5.10 )
X? ( virtual/x11 )"
@@ -37,6 +37,7 @@ src_compile(){
fi
if [ "`use qt`" ]
then
+ export QTDIr=/usr/qt/2
myconf="$myconf --enable-qt"
fi
#if [ "`use kde`" ]
@@ -65,14 +66,14 @@ src_compile(){
# myconf="$myconf --enable-alsa"
# fi
- try ./configure --prefix=/usr $myconf --with-sdl --disable-alsa
- try make
+ ./configure --prefix=/usr $myconf --with-sdl --disable-alsa || die
+ make || die
}
src_install() {
dodir /usr/{bin,lib}
- try make DESTDIR=${D} install
+ make DESTDIR=${D} install || die
}
diff --git a/media-video/vlc/vlc-0.2.90.ebuild b/media-video/vlc/vlc-0.2.90.ebuild
index 977022727aa5..a011904c3965 100644
--- a/media-video/vlc/vlc-0.2.90.ebuild
+++ b/media-video/vlc/vlc-0.2.90.ebuild
@@ -1,6 +1,6 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Nathaniel Hirsch <nh2@njit.edu> Achim Gottinge <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.2.90.ebuild,v 1.1 2001/10/22 18:13:34 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.2.90.ebuild,v 1.2 2001/12/29 21:45:08 danarmak Exp $
S=${WORKDIR}/${P}
DESCRIPTION="DVD / video player"
@@ -11,7 +11,7 @@ DEPEND=">=media-libs/libsdl-1.1.8-r1
gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
esd? ( >=media-sound/esound-0.2.22 )
ggi? ( >=media-libs/libggi-2.0_beta3 )
- qt? ( >=x11-libs/qt-x11-2.3.0 )
+ qt? ( >=x11-libs/qt-2.3.0 )
gtk? ( >=x11-libs/gtk+-1.2.10-r4 )
#alsa? ( >=media-libs/alsa-lib-0.5.10 )
X? ( virtual/x11 )"
@@ -37,6 +37,7 @@ src_compile(){
fi
if [ "`use qt`" ]
then
+ export QTDIR=/usr/qt/2
myconf="$myconf --enable-qt"
fi
#if [ "`use kde`" ]
@@ -65,14 +66,14 @@ src_compile(){
# myconf="$myconf --enable-alsa"
# fi
- try ./configure --prefix=/usr $myconf --with-sdl --disable-alsa
- try make
+ ./configure --prefix=/usr $myconf --with-sdl --disable-alsa || die
+ make || die
}
src_install() {
dodir /usr/{bin,lib}
- try make DESTDIR=${D} install
+ make DESTDIR=${D} install || die
}
diff --git a/profiles/package.mask b/profiles/package.mask
index f81bf5a2fba1..a12d5b45e5ba 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -1,3 +1,6 @@
+#won't compile here
+=media-sound/freeamp-2.1.1
+
#hasn't built in months
>=net-ftp/kbear-1.2.1
diff --git a/x11-misc/toolbox/toolbox-0.6.0-r1.ebuild b/x11-misc/toolbox/toolbox-0.6.0-r1.ebuild
index d21552b18442..298c81ff87a6 100644
--- a/x11-misc/toolbox/toolbox-0.6.0-r1.ebuild
+++ b/x11-misc/toolbox/toolbox-0.6.0-r1.ebuild
@@ -1,28 +1,26 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Craig Joly <joly@ee.ualberta.ca>
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/toolbox/toolbox-0.6.0-r1.ebuild,v 1.1 2001/10/06 15:30:16 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/toolbox/toolbox-0.6.0-r1.ebuild,v 1.2 2001/12/29 21:45:09 danarmak Exp $
-
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="blackbox style file configuration utility"
-SRC_URI="http://movingparts.windsofstorm.net/bbkeys/${A}"
-HOMEPAGE="http://movingparts.windsofstorm.net/code.shtml#toolbox"
+SRC_URI="http://movingparts.windsofstorm.net/bbkeys/${P}.tar.tz"
+HOMEPAGE="http://movingparts.windsofstorm.net/code.shtml\#toolbox"
DEPEND=">=x11-wm/blackbox-0.61
- >=x11-libs/qt-x11-2.3.0"
+ >=x11-libs/qt-2.3.0"
src_compile() {
- try ./configure --prefix=/usr --host=${CHOST}
- try emake
+ QTDIr=/usr/qt/2 ./configure --prefix=/usr --host=${CHOST} || die
+ emake || die
}
src_install () {
- try make DESTDIR=${D} install
+ make DESTDIR=${D} install || die
dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
}
diff --git a/x11-wm/WindowMaker/WindowMaker-0.70.0-r1.ebuild b/x11-wm/WindowMaker/WindowMaker-0.70.0-r1.ebuild
index ba3d89ca4c98..f3b195ab7769 100644
--- a/x11-wm/WindowMaker/WindowMaker-0.70.0-r1.ebuild
+++ b/x11-wm/WindowMaker/WindowMaker-0.70.0-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/WindowMaker/WindowMaker-0.70.0-r1.ebuild,v 1.4 2001/12/02 03:25:51 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/WindowMaker/WindowMaker-0.70.0-r1.ebuild,v 1.5 2001/12/29 21:45:09 danarmak Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Window Maker"
@@ -29,6 +29,8 @@ src_compile() {
myconf="--enable-gnome"
fi
if [ "`use kde`" ] ; then
+ # hope this helps for linking against kdelibs, I'm not testing other wms right now
+ export KDEDIR=/usr/kde/2
myconf="$myconf --enable-kde"
fi
if [ "`use nls`" ] ; then
diff --git a/x11-wm/fluxbox/fluxbox-0.1.5.ebuild b/x11-wm/fluxbox/fluxbox-0.1.5.ebuild
index 086acbcce548..d4e1272fa630 100644
--- a/x11-wm/fluxbox/fluxbox-0.1.5.ebuild
+++ b/x11-wm/fluxbox/fluxbox-0.1.5.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Karl Trygve Kalleberg
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-0.1.5.ebuild,v 1.1 2001/12/27 08:41:22 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-0.1.5.ebuild,v 1.2 2001/12/29 21:45:09 danarmak Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Window manager based on BlackBox"
@@ -18,7 +18,7 @@ RDEPEND="$DEPEND"
src_compile() {
local myconf
use nls && myconf="$myconf --enable-nls" || myconf="$myconf --disable-nls"
- use kde && myconf="$myconf --enable-kde" || myconf="$myconf --disable-kde"
+ use kde && myconf="$myconf --enable-kde" && export KDEDIR=/usr/kde/2 || myconf="$myconf --disable-kde"
./configure \
--host=${CHOST} \