summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/glib/ChangeLog12
-rw-r--r--dev-libs/glib/files/glib-2.26.1-gatomic-header.patch11
-rw-r--r--dev-libs/glib/files/glib-2.26.1-gdatetime-test.patch21
-rw-r--r--dev-libs/glib/glib-2.26.1-r1.ebuild9
4 files changed, 51 insertions, 2 deletions
diff --git a/dev-libs/glib/ChangeLog b/dev-libs/glib/ChangeLog
index de0a6bab5354..4adff2d97536 100644
--- a/dev-libs/glib/ChangeLog
+++ b/dev-libs/glib/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-libs/glib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.437 2011/01/19 21:20:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.438 2011/01/24 13:55:17 pacho Exp $
+
+ 24 Jan 2011; Pacho Ramos <pacho@gentoo.org> glib-2.26.1-r1.ebuild,
+ +files/glib-2.26.1-gatomic-header.patch,
+ +files/glib-2.26.1-gdatetime-test.patch:
+ Add openbsd patch to fix build on several arches (bug #351387 by Alan
+ Hourihane and Raúl Porcel) once I confirmed it doesn't cause any test
+ failure regression. Remove test that seems to fail depending on time of day
+ as done by upstream (was causing one of the failures in bug #352451) and
+ unset GSETTINGS_BACKEND (bug #352451) until upstream takes care (upstream bug
+ #640412).
19 Jan 2011; Markos Chandras <hwoarang@gentoo.org> glib-2.24.2.ebuild:
Stable on amd64 wrt bug #348987
diff --git a/dev-libs/glib/files/glib-2.26.1-gatomic-header.patch b/dev-libs/glib/files/glib-2.26.1-gatomic-header.patch
new file mode 100644
index 000000000000..f6454d446bbd
--- /dev/null
+++ b/dev-libs/glib/files/glib-2.26.1-gatomic-header.patch
@@ -0,0 +1,11 @@
+$OpenBSD: patch-glib_gatomic_c,v 1.1 2010/10/10 10:52:04 kili Exp $
+--- glib/gatomic.c.orig Thu Sep 23 17:26:45 2010
++++ glib/gatomic.c Sun Oct 10 11:50:01 2010
+@@ -28,6 +28,7 @@
+ #endif
+
+ #include "gatomic.h"
++#include "gthread.h"
+ #include "gthreadprivate.h"
+
+ /**
diff --git a/dev-libs/glib/files/glib-2.26.1-gdatetime-test.patch b/dev-libs/glib/files/glib-2.26.1-gdatetime-test.patch
new file mode 100644
index 000000000000..054f311f7535
--- /dev/null
+++ b/dev-libs/glib/files/glib-2.26.1-gdatetime-test.patch
@@ -0,0 +1,21 @@
+From 3f059a6a123dd62257f224b9af7701078783060e Mon Sep 17 00:00:00 2001
+From: Matthias Clasen <mclasen@redhat.com>
+Date: Sat, 22 Jan 2011 04:41:12 +0000
+Subject: Remove a test that seems to fail depending on time of day
+
+---
+diff --git a/glib/tests/gdatetime.c b/glib/tests/gdatetime.c
+index 01f08de..619bb02 100644
+--- a/glib/tests/gdatetime.c
++++ b/glib/tests/gdatetime.c
+@@ -804,7 +804,7 @@ GDateTime *__dt = g_date_time_new_local (2009, 10, 24, 0, 0, 0);\
+ TEST_PRINTF_TIME (13, 13, 13, "%r", "01:13:13 PM");
+ TEST_PRINTF ("%R", "00:00");
+ TEST_PRINTF_TIME (13, 13, 31, "%R", "13:13");
+- TEST_PRINTF ("%s", t_str);
++ //TEST_PRINTF ("%s", t_str);
+ TEST_PRINTF ("%S", "00");
+ TEST_PRINTF ("%t", " ");
+ TEST_PRINTF ("%W", "42");
+--
+cgit v0.8.3.1
diff --git a/dev-libs/glib/glib-2.26.1-r1.ebuild b/dev-libs/glib/glib-2.26.1-r1.ebuild
index e6c36564a7b4..a155cc0ad8c3 100644
--- a/dev-libs/glib/glib-2.26.1-r1.ebuild
+++ b/dev-libs/glib/glib-2.26.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.26.1-r1.ebuild,v 1.1 2011/01/17 17:58:59 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.26.1-r1.ebuild,v 1.2 2011/01/24 13:55:17 pacho Exp $
EAPI="3"
@@ -45,6 +45,12 @@ src_prepare() {
# gsettings.m4: Fix rules to work when there are no schemas, bug #350020
epatch "${FILESDIR}/${PN}-2.26.1-gsettings-rules.patch"
+ # Fix compilation on several arches, bug #351387
+ epatch "${FILESDIR}/${PN}-2.26.1-gatomic-header.patch"
+
+ # Remove a test that seems to fail depending on time of day
+ epatch "${FILESDIR}/${PN}-2.26.1-gdatetime-test.patch"
+
# Deprecation check in tests/testglib.c, upstream bug #635093
epatch "${FILESDIR}/${P}-deprecation-tests.patch"
@@ -144,6 +150,7 @@ src_test() {
export XDG_CONFIG_DIRS=/etc/xdg
export XDG_DATA_DIRS=/usr/local/share:/usr/share
export XDG_DATA_HOME="${T}"
+ unset GSETTINGS_BACKEND # bug 352451
# Hardened: gdb needs this, bug #338891
if host-is-pax ; then