summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-emulation/gens/ChangeLog5
-rw-r--r--games-emulation/gens/gens-2.12a.ebuild11
2 files changed, 13 insertions, 3 deletions
diff --git a/games-emulation/gens/ChangeLog b/games-emulation/gens/ChangeLog
index 946753f46710..dfdb31c17869 100644
--- a/games-emulation/gens/ChangeLog
+++ b/games-emulation/gens/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/gens
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/ChangeLog,v 1.6 2004/03/24 06:47:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/ChangeLog,v 1.7 2004/05/05 02:08:00 mr_bones_ Exp $
+
+ 04 May 2004; Michael Sterrett <mr_bones_@gentoo.org> gens-2.12a.ebuild:
+ IUSE; dep tidy; shot at fixing bug #49308
23 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> gens-2.12a.ebuild:
don't rdepend on sed, nasm and unzip
diff --git a/games-emulation/gens/gens-2.12a.ebuild b/games-emulation/gens/gens-2.12a.ebuild
index f11a96b31495..e9ba1e089789 100644
--- a/games-emulation/gens/gens-2.12a.ebuild
+++ b/games-emulation/gens/gens-2.12a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/gens-2.12a.ebuild,v 1.4 2004/03/24 06:47:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/gens-2.12a.ebuild,v 1.5 2004/05/05 02:08:00 mr_bones_ Exp $
inherit games
@@ -12,17 +12,24 @@ SRC_URI="mirror://sourceforge/gens/gens-rc2.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
+IUSE=""
RDEPEND="virtual/glibc
>=media-libs/libsdl-1.2
>=x11-libs/gtk+-2.0*"
DEPEND="${RDEPEND}
- app-arch/unzip
>=dev-lang/nasm-0.98
>=sys-apps/sed-4"
S="${WORKDIR}/gens-linux-${PV}"
+src_unpack() {
+ unpack ${A}
+ sed -i \
+ -e "s:-DGTK_DISABLE_DEPRECATED::" ${S}/configure \
+ || die "sed configure failed"
+}
+
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS BUGS README