summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--incoming/feh-1.1.0.ebuild22
-rw-r--r--incoming/giblib-1.2.1.ebuild24
-rw-r--r--incoming/scrot-0.6.ebuild21
3 files changed, 67 insertions, 0 deletions
diff --git a/incoming/feh-1.1.0.ebuild b/incoming/feh-1.1.0.ebuild
new file mode 100644
index 000000000000..59b4385042a8
--- /dev/null
+++ b/incoming/feh-1.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Claes Nästén <pekdon@gmx.net>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Command line picture viewer that uses imlib2"
+SRC_URI="http://www.linuxbrit.co.uk/downloads/${P}.tar.gz"
+HOMEPAGE="http://www.linuxbrit.co.uk/"
+DEPEND="media-libs/imlib2"
+
+src_compile() {
+ ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} || die
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr install || die
+ rm -rf ${D}/usr/doc
+ dodoc TODO README AUTHORS ChangeLog
+}
+
diff --git a/incoming/giblib-1.2.1.ebuild b/incoming/giblib-1.2.1.ebuild
new file mode 100644
index 000000000000..fc44f2399be0
--- /dev/null
+++ b/incoming/giblib-1.2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Claes Nästén <pekdon@gmx.net>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Giblib, graphics library"
+SRC_URI="http://www.linuxbrit.co.uk/downloads/${P}.tar.gz"
+HOMEPAGE="http://www.libuxbrit.co.uk/"
+
+DEPEND="media-libs/imlib2
+ >=media-libs/freetype-2"
+
+src_compile() {
+ ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} || die
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr install || die
+ rm -rf ${D}/usr/doc
+ dodoc TODO README AUTHORS ChangeLog
+}
+
diff --git a/incoming/scrot-0.6.ebuild b/incoming/scrot-0.6.ebuild
new file mode 100644
index 000000000000..71465e54f3fd
--- /dev/null
+++ b/incoming/scrot-0.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Claes Nästén <pekdon@gmx.net>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Screen Shooter"
+SRC_URI="http://www.linuxbrit.co.uk/downloads/${P}.tar.gz"
+HOMEPAGE="http://www.linuxbrit.co.uk/"
+DEPEND="media-libs/giblib-1.2.1"
+
+src_compile() {
+ ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} || die
+ emake || die
+}
+
+src_install () {
+ dobin src/scrot
+ dodoc TODO README AUTHORS ChangeLog
+}
+