summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/tse3/ChangeLog7
-rw-r--r--media-libs/tse3/files/tse3-0.2.7-gcc34.patch107
-rw-r--r--media-libs/tse3/tse3-0.2.7.ebuild5
3 files changed, 117 insertions, 2 deletions
diff --git a/media-libs/tse3/ChangeLog b/media-libs/tse3/ChangeLog
index ae1b4cc8537c..5a0dea414432 100644
--- a/media-libs/tse3/ChangeLog
+++ b/media-libs/tse3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/tse3
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/ChangeLog,v 1.6 2004/07/13 06:10:55 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/ChangeLog,v 1.7 2004/07/14 09:40:23 eradicator Exp $
+
+ 14 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ +files/tse3-0.2.7-gcc34.patch:
+ gcc-3.4 fixes provided by Patrick Dawson <pkdawson@buffalo.edu> to close bug
+ #56867.
12 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> tse3-0.2.7.ebuild:
Moved patching goodness to src_unpack(). Added to ~sparc.
diff --git a/media-libs/tse3/files/tse3-0.2.7-gcc34.patch b/media-libs/tse3/files/tse3-0.2.7-gcc34.patch
new file mode 100644
index 000000000000..69cd08849b6c
--- /dev/null
+++ b/media-libs/tse3/files/tse3-0.2.7-gcc34.patch
@@ -0,0 +1,107 @@
+diff -ur tse3-0.2.7.orig/src/tse3/Midi.h tse3-0.2.7/src/tse3/Midi.h
+--- tse3-0.2.7.orig/src/tse3/Midi.h 2004-07-13 13:42:54.171911848 -0400
++++ tse3-0.2.7/src/tse3/Midi.h 2004-07-13 13:44:05.282101456 -0400
+@@ -819,6 +819,6 @@
+ const MidiEvent &e1;
+ };
+ };
+-};
++}
+
+ #endif
+diff -ur tse3-0.2.7.orig/src/tse3/Mutex.h tse3-0.2.7/src/tse3/Mutex.h
+--- tse3-0.2.7.orig/src/tse3/Mutex.h 2004-07-13 13:42:54.188909264 -0400
++++ tse3-0.2.7/src/tse3/Mutex.h 2004-07-13 13:51:01.925761992 -0400
+@@ -315,7 +315,7 @@
+ #endif
+ }
+ };
+- };
++ }
+ }
+
+ #endif
+diff -ur tse3-0.2.7.orig/src/tse3/Notifier.h tse3-0.2.7/src/tse3/Notifier.h
+--- tse3-0.2.7.orig/src/tse3/Notifier.h 2004-07-13 13:42:54.171911848 -0400
++++ tse3-0.2.7/src/tse3/Notifier.h 2004-07-13 13:46:50.128041064 -0400
+@@ -290,7 +290,7 @@
+ const p4_type &p4; // (*)
+ };
+
+- };
++ }
+
+ /**************************************************************************
+ * Public Notifier framework API
+@@ -367,7 +367,7 @@
+ */
+ typedef Listener<interface_type> listener_type;
+
+- friend class listener_type;
++ friend class Listener<interface_type>;
+
+ protected:
+
+@@ -602,7 +602,7 @@
+ if (notifiers.erase(notifier)) notifier->detach(this);
+ }
+
+- friend class notifier_type;
++ friend class Notifier<interface_type>;
+
+ protected:
+
+diff -ur tse3-0.2.7.orig/src/tse3/app/Application.h tse3-0.2.7/src/tse3/app/Application.h
+--- tse3-0.2.7.orig/src/tse3/app/Application.h 2004-07-13 13:42:54.149915192 -0400
++++ tse3-0.2.7/src/tse3/app/Application.h 2004-07-13 13:50:10.297610664 -0400
+@@ -35,12 +35,12 @@
+ namespace Cmd
+ {
+ class CommandHistory;
+- };
++ }
+
+ namespace Ins
+ {
+ class Destination;
+- };
++ }
+
+ /**
+ * The App namespace contains classes that use the @ref TSE3
+diff -ur tse3-0.2.7.orig/src/tse3/app/Record.h tse3-0.2.7/src/tse3/app/Record.h
+--- tse3-0.2.7.orig/src/tse3/app/Record.h 2004-07-13 13:42:54.152914736 -0400
++++ tse3-0.2.7/src/tse3/app/Record.h 2004-07-13 13:50:33.187130928 -0400
+@@ -36,7 +36,7 @@
+ namespace Cmd
+ {
+ class CommandHistory;
+- };
++ }
+
+ namespace App
+ {
+diff -ur tse3-0.2.7.orig/src/tse3/plt/Arts.cpp tse3-0.2.7/src/tse3/plt/Arts.cpp
+--- tse3-0.2.7.orig/src/tse3/plt/Arts.cpp 2004-07-13 13:42:54.158913824 -0400
++++ tse3-0.2.7/src/tse3/plt/Arts.cpp 2004-07-13 13:49:02.575905928 -0400
+@@ -74,7 +74,7 @@
+
+ ArtsCommon *artsCommon = 0;
+ int artsCommonInit = 0;
+-};
++}
+
+
+ ArtsMidiScheduler::ArtsMidiScheduler()
+diff -ur tse3-0.2.7.orig/src/tse3/util/MulDiv.h tse3-0.2.7/src/tse3/util/MulDiv.h
+--- tse3-0.2.7.orig/src/tse3/util/MulDiv.h 2004-07-13 13:42:54.169912152 -0400
++++ tse3-0.2.7/src/tse3/util/MulDiv.h 2004-07-13 13:48:05.942515512 -0400
+@@ -34,7 +34,7 @@
+ * @return val * num / div (which coped with integer overflows)
+ */
+ extern int muldiv(int val, int num, int div);
+- };
++ }
+ }
+
+ #endif
diff --git a/media-libs/tse3/tse3-0.2.7.ebuild b/media-libs/tse3/tse3-0.2.7.ebuild
index 32111d3aee9c..6466a89036b3 100644
--- a/media-libs/tse3/tse3-0.2.7.ebuild
+++ b/media-libs/tse3/tse3-0.2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/tse3-0.2.7.ebuild,v 1.9 2004/07/13 06:10:55 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/tse3-0.2.7.ebuild,v 1.10 2004/07/14 09:40:23 eradicator Exp $
IUSE="alsa oss arts"
@@ -23,6 +23,9 @@ src_unpack() {
cd ${S}
# size_t patch for 64bit machines
epatch ${FILESDIR}/${P}-size_t-64bit.patch
+
+ # gcc-3.4 patch
+ epatch ${FILESDIR}/${P}-gcc34.patch
}
src_compile() {