summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/xulrunner/ChangeLog7
-rw-r--r--net-libs/xulrunner/files/digest-xulrunner-1.8.0.116
-rw-r--r--net-libs/xulrunner/xulrunner-1.8.0.11.ebuild160
3 files changed, 172 insertions, 1 deletions
diff --git a/net-libs/xulrunner/ChangeLog b/net-libs/xulrunner/ChangeLog
index 1728c603efb3..df9a909d0473 100644
--- a/net-libs/xulrunner/ChangeLog
+++ b/net-libs/xulrunner/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/xulrunner
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner/ChangeLog,v 1.16 2007/03/29 21:06:04 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner/ChangeLog,v 1.17 2007/04/14 16:13:04 armin76 Exp $
+
+*xulrunner-1.8.0.11 (14 Apr 2007)
+
+ 14 Apr 2007; Raúl Porcel <armin76@gentoo.org> +xulrunner-1.8.0.11.ebuild:
+ Version bump, wrt security fixes, and stable to x86
29 Mar 2007; Jeroen Roovers <jer@gentoo.org> :
Marked ~hppa (bug #172559).
diff --git a/net-libs/xulrunner/files/digest-xulrunner-1.8.0.11 b/net-libs/xulrunner/files/digest-xulrunner-1.8.0.11
new file mode 100644
index 000000000000..db064d8697a6
--- /dev/null
+++ b/net-libs/xulrunner/files/digest-xulrunner-1.8.0.11
@@ -0,0 +1,6 @@
+MD5 839d8c91d6efc5b787aa46eef85707ea xulrunner-1.8.0.11-patches-0.1.tar.bz2 93146
+RMD160 11dbe3622021338085660312873a50305879b162 xulrunner-1.8.0.11-patches-0.1.tar.bz2 93146
+SHA256 f71afb193093d0a3d237bf9b3150159c0cb9b7592edf201a1bb3ec4230f2964c xulrunner-1.8.0.11-patches-0.1.tar.bz2 93146
+MD5 e0e4c609c50ae171c65d5c454aa0e94f xulrunner_1.8.0.11.orig.tar.gz 40237017
+RMD160 2651cb315a3465acc32ee770b8386bec39ad5969 xulrunner_1.8.0.11.orig.tar.gz 40237017
+SHA256 cc3cd44bbeb4112112c1ae6ab420177a6b1266d060eab7da1ae926fea57c5f24 xulrunner_1.8.0.11.orig.tar.gz 40237017
diff --git a/net-libs/xulrunner/xulrunner-1.8.0.11.ebuild b/net-libs/xulrunner/xulrunner-1.8.0.11.ebuild
new file mode 100644
index 000000000000..a766e4547b2b
--- /dev/null
+++ b/net-libs/xulrunner/xulrunner-1.8.0.11.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner/xulrunner-1.8.0.11.ebuild,v 1.1 2007/04/14 16:13:04 armin76 Exp $
+
+WANT_AUTOCONF="2.1"
+
+inherit flag-o-matic toolchain-funcs eutils makeedit multilib autotools mozconfig-2 java-pkg-opt-2
+PATCH="${P}-patches-0.1"
+
+DESCRIPTION="Mozilla runtime package that can be used to bootstrap XUL+XPCOM applications"
+HOMEPAGE="http://developer.mozilla.org/en/docs/XULRunner"
+SRC_URI="mirror://debian/pool/main/x/xulrunner/xulrunner_1.8.0.11.orig.tar.gz
+ mirror://gentoo/${PATCH}.tar.bz2"
+
+LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ >=sys-devel/binutils-2.16.1
+ >=dev-libs/nss-3.10
+ >=dev-libs/nspr-4.6.1
+ java? ( >=virtual/jre-1.4 )"
+
+DEPEND="java? ( >=virtual/jdk-1.4 )
+ ${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${P}.orig"
+
+# Needed by src_compile() and src_install().
+# Would do in pkg_setup but that loses the export attribute, they
+# become pure shell variables.
+export MOZ_CO_PROJECT=xulrunner
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+
+src_unpack() {
+ unpack ${P/-/_}.orig.tar.gz ${PATCH}.tar.bz2
+
+ # Apply our patches
+ cd ${S} || die "cd failed"
+
+ # exclude the xpcomglue-shared.patch from debian for now
+ # until we figured out if we need also the versioning patch
+ EPATCH_EXCLUDE="030_pango-cairo-1.patch.bz2"
+
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ epatch "${WORKDIR}"/patch
+
+ # Fix a compilation issue using the 32-bit userland with 64-bit kernel on
+ # PowerPC, because with that configuration, it detects a ppc64 system.
+ # -- hansmi, 2005-11-13
+ if use ppc && [[ "${PROFILE_ARCH}" == ppc64 ]]; then
+ sed -i -e "s#OS_TEST=\`uname -m\`\$#OS_TEST=${ARCH}#" \
+ ${S}/configure
+ sed -i -e "s#OS_TEST :=.*uname -m.*\$#OS_TEST:=${ARCH}#" \
+ ${S}/security/coreconf/arch.mk
+ fi
+
+ eautoreconf || die "failed running eautoreconf"
+}
+
+src_compile() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+
+ ####################################
+ #
+ # mozconfig, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+
+ mozconfig_init
+ mozconfig_config
+
+ mozconfig_annotate '' --enable-extensions="default,cookie,permissions"
+ mozconfig_annotate '' --enable-native-uconv
+ mozconfig_annotate '' --enable-image-encoder=all
+ mozconfig_annotate '' --enable-canvas
+ #mozconfig_annotate '' --enable-js-binary
+ mozconfig_annotate '' --enable-embedding-tests
+ mozconfig_annotate '' --with-system-nspr
+ mozconfig_annotate '' --with-system-nss
+ mozconfig_annotate '' --with-system-bz2
+ mozconfig_annotate '' --enable-jsd
+ mozconfig_annotate '' --enable-xpctools
+ # Bug 60668: Galeon doesn't build without oji enabled, so enable it
+ # regardless of java setting.
+ mozconfig_annotate '' --enable-oji --enable-mathml
+ mozconfig_annotate '' --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME}
+
+ #disable java
+ if ! use java ; then
+ mozconfig_annotate '-java' --disable-javaxpcom
+ fi
+
+ # Finalize and report settings
+ mozconfig_final
+
+ # hardened GCC uses -fstack-protector-all by default, which breaks us
+ gcc-specs-ssp && append-flags -fno-stack-protector-all
+ # remove -fstack-protector because now it borks firefox
+ CFLAGS=${CFLAGS/-fstack-protector-all/}
+ CFLAGS=${CFLAGS/-fstack-protector/}
+ CXXFLAGS=${CXXFLAGS/-fstack-protector-all/}
+ CXXFLAGS=${CXXFLAGS/-fstack-protector/}
+
+ append-flags -freorder-blocks -fno-reorder-functions
+
+ # Export CPU_ARCH_TEST as it is not exported by default.
+ case $(tc-arch) in
+ amd64) [[ ${ABI} == "x86" ]] && CPU_ARCH_TEST="x86" || CPU_ARCH_TEST="x86_64" ;;
+ *) CPU_ARCH_TEST=$(tc-arch) ;;
+ esac
+
+ export CPU_ARCH_TEST
+
+ ####################################
+ #
+ # Configure and build
+ #
+ ####################################
+
+ CPPFLAGS="${CPPFLAGS} -DARON_WAS_HERE" \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
+ econf || die
+
+ # It would be great if we could pass these in via CPPFLAGS or CFLAGS prior
+ # to econf, but the quotes cause configure to fail.
+ sed -i -e \
+ 's|-DARON_WAS_HERE|-DGENTOO_NSPLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsplugins\\\" -DGENTOO_NSBROWSER_PLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsbrowser/plugins\\\"|' \
+ ${S}/config/autoconf.mk \
+ ${S}/xpfe/global/buildconfig.html
+
+ # This removes extraneous CFLAGS from the Makefiles to reduce RAM
+ # requirements while compiling
+ edit_makefiles
+
+ emake -j1 || die
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
+ einstall || die "failed running make install"
+
+ if use java ; then
+ java-pkg_dojar ${D}${MOZILLA_FIVE_HOME}/javaxpcom.jar
+ rm -f ${D}${MOZILLA_FIVE_HOME}/javaxpcom.jar
+ fi
+
+ # xulrunner registration, the gentoo way
+ insinto /etc/gre.d
+ newins ${FILESDIR}/${PN}.conf ${PV}.conf
+ sed -i -e \
+ "s|version|${PV}|
+ s|instpath|${MOZILLA_FIVE_HOME}|" \
+ ${D}/etc/gre.d/${PV}.conf
+}