summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-irc/xchat/ChangeLog10
-rw-r--r--net-irc/xchat/files/digest-xchat-2.4.2-r1 (renamed from net-irc/xchat/files/digest-xchat-2.4.2)0
-rw-r--r--net-irc/xchat/files/xc242-slist-nosel.diff25
-rw-r--r--net-irc/xchat/files/xc242-whois-spec.diff15
-rw-r--r--net-irc/xchat/xchat-2.4.2-r1.ebuild (renamed from net-irc/xchat/xchat-2.4.2.ebuild)5
5 files changed, 53 insertions, 2 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 5fdbc0607fce..4dcd5f68cd7d 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-irc/xchat
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.150 2005/03/19 14:51:05 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.151 2005/03/25 12:08:20 swegener Exp $
+
+*xchat-2.4.2-r1 (25 Mar 2005)
+
+ 25 Mar 2005; Sven Wegener <swegener@gentoo.org>
+ +files/xc242-whois-spec.diff, +files/xc242-slist-nosel.diff,
+ -xchat-2.4.2.ebuild, +xchat-2.4.2-r1.ebuild:
+ Revision bump to include two patches from upstream. Thanks to Martin Wienold
+ <martin.wienold@uni-dortmund.de> in bug #86617.
*xchat-2.4.2 (19 Mar 2005)
diff --git a/net-irc/xchat/files/digest-xchat-2.4.2 b/net-irc/xchat/files/digest-xchat-2.4.2-r1
index 86444e8bd909..86444e8bd909 100644
--- a/net-irc/xchat/files/digest-xchat-2.4.2
+++ b/net-irc/xchat/files/digest-xchat-2.4.2-r1
diff --git a/net-irc/xchat/files/xc242-slist-nosel.diff b/net-irc/xchat/files/xc242-slist-nosel.diff
new file mode 100644
index 000000000000..dc6ea14a6e85
--- /dev/null
+++ b/net-irc/xchat/files/xc242-slist-nosel.diff
@@ -0,0 +1,25 @@
+#
+# Fixes a crash when clicking "Connect" if no network is selected.
+#
+--- xchat-2.4.2/src/fe-gtk/servlistgui.c 2005-02-03 15:42:44.000000000 +1100
++++ xchat-2.4.2p1/src/fe-gtk/servlistgui.c 2005-03-20 18:02:41.000000000 +1100
+@@ -609,6 +609,9 @@
+ static void
+ servlist_connectnew_cb (GtkWidget *button, gpointer userdata)
+ {
++ if (!selected_net)
++ return;
++
+ if (servlist_savegui () != 0)
+ {
+ gtkutil_simpledialog (_("User name and Real name cannot be left blank."));
+@@ -625,6 +628,9 @@
+ static void
+ servlist_connect_cb (GtkWidget *button, gpointer userdata)
+ {
++ if (!selected_net)
++ return;
++
+ if (servlist_savegui () != 0)
+ {
+ gtkutil_simpledialog (_("User name and Real name cannot be left blank."));
diff --git a/net-irc/xchat/files/xc242-whois-spec.diff b/net-irc/xchat/files/xc242-whois-spec.diff
new file mode 100644
index 000000000000..e423f1321b38
--- /dev/null
+++ b/net-irc/xchat/files/xc242-whois-spec.diff
@@ -0,0 +1,15 @@
+#
+# Fix handling of WHOIS SPECIAL events to be more strictly correct.
+#
+--- xchat-2.4.2/src/common/proto-irc.c 2005-03-13 13:38:57.000000000 +1100
++++ xchat-2.4.2p1/src/common/proto-irc.c 2005-03-20 21:33:58.000000000 +1100
+@@ -710,7 +710,8 @@
+ {
+ /* some unknown WHOIS reply, ircd coders make them up weekly */
+ EMIT_SIGNAL (XP_TE_WHOIS_SPECIAL, serv->server_session, word[4],
+- word_eol[5] + 1, word[2], NULL, 0);
++ (word_eol[5][0] == ':') ? word_eol[5] + 1 : word_eol[5],
++ word[2], NULL, 0);
+ return;
+ }
+
diff --git a/net-irc/xchat/xchat-2.4.2.ebuild b/net-irc/xchat/xchat-2.4.2-r1.ebuild
index 2c9400aa9bad..3dfcd938b40f 100644
--- a/net-irc/xchat/xchat-2.4.2.ebuild
+++ b/net-irc/xchat/xchat-2.4.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.4.2.ebuild,v 1.1 2005/03/19 14:51:05 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.4.2-r1.ebuild,v 1.1 2005/03/25 12:08:20 swegener Exp $
inherit flag-o-matic eutils
@@ -36,6 +36,9 @@ src_unpack() {
unpack ${A}
cd ${S}
+ epatch ${FILESDIR}/xc242-whois-spec.diff
+ epatch ${FILESDIR}/xc242-slist-nosel.diff
+
use xchatdccserver && epatch ${DISTDIR}/xchat-dccserver-0.4.patch
}