summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-i18n/jless/ChangeLog11
-rw-r--r--app-i18n/jless/files/jless-382.262-gentoo.patch86
-rw-r--r--app-i18n/jless/jless-382.262.ebuild52
3 files changed, 147 insertions, 2 deletions
diff --git a/app-i18n/jless/ChangeLog b/app-i18n/jless/ChangeLog
index 86f68fcfaab5..a74820d0c196 100644
--- a/app-i18n/jless/ChangeLog
+++ b/app-i18n/jless/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-i18n/jless
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/jless/ChangeLog,v 1.4 2007/04/09 13:54:32 matsuu Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/jless/ChangeLog,v 1.5 2008/11/02 16:26:01 matsuu Exp $
+
+*jless-382.262 (02 Nov 2008)
+
+ 02 Nov 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +files/jless-382.262-gentoo.patch, +jless-382.262.ebuild:
+ Fixed HOMEPAGE, LICENSE and DEPEND. Removed pkg_postinst. Added
+ eautoreconf, bug #240008.
09 Apr 2007; MATSUU Takuto <matsuu@gentoo.org> jless-358.254.ebuild,
jless-382.258.ebuild:
diff --git a/app-i18n/jless/files/jless-382.262-gentoo.patch b/app-i18n/jless/files/jless-382.262-gentoo.patch
new file mode 100644
index 000000000000..265a73932ee4
--- /dev/null
+++ b/app-i18n/jless/files/jless-382.262-gentoo.patch
@@ -0,0 +1,86 @@
+diff -Naur less-382.orig/multi.c less-382/multi.c
+--- less-382.orig/multi.c 2008-11-02 20:17:16.000000000 +0900
++++ less-382/multi.c 2008-11-02 20:20:07.000000000 +0900
+@@ -279,7 +279,6 @@
+ case 0x70: return 4; /* or more bytes */
+ }
+ }
+- assert(0);
+ return (0);
+ }
+
+@@ -1337,8 +1336,6 @@
+ default: goto wrongone;
+ }
+ break;
+- default:
+- assert(0);
+ }
+ if (mp->eseq == NOESC) {
+ fix_status_for_escape_sequence(mp);
+@@ -1857,8 +1854,6 @@
+ strcpy(buf, "96N( )");
+ buf[4] = CS2FT(mp->icharset);
+ break;
+- default:
+- assert(0);
+ }
+ if (CS2IRR(mp->icharset) > 0)
+ {
+@@ -2078,7 +2073,6 @@
+ return (nullcvbuffer);
+ } else
+ {
+- assert(0);
+ cvindex = 0;
+ }
+
+@@ -2171,7 +2165,6 @@
+ cvindex = 0;
+ return (nullcvbuffer);
+ }
+- assert(0);
+ cvindex = 0;
+ return (cvbuffer);
+ }
+@@ -2270,7 +2263,6 @@
+ cvindex = 0;
+ return (nullcvbuffer);
+ }
+- assert(0);
+ cvindex = 0;
+ return (cvbuffer);
+ }
+@@ -2296,7 +2288,6 @@
+
+ cs = CS2CHARSET(cs);
+
+- assert(0);
+ if (cs == ASCII || cs == JISX0201ROMAN)
+ {
+ assert(cvindex == 1);
+@@ -2324,7 +2315,6 @@
+ cvindex = 0;
+ return (nullcvbuffer);
+ }
+- assert(0);
+ cvindex = 0;
+ return (cvbuffer);
+ }
+@@ -2390,7 +2380,6 @@
+ case TYPE_96N_CHARSET:
+ return (2);
+ default:
+- assert(0);
+ return (0);
+ }
+ }
+@@ -2410,7 +2399,7 @@
+ case 4: p = "iso8"; mp->io.inputr = ESISO8; break;
+ case 5: p = "noconv"; mp->io.inputr = ESNOCONV; break;
+ case 6: p = "none"; mp->io.inputr = ESNONE; break;
+- default: assert(0); break;
++ default: break;
+ }
+ init_priority(mp);
+ return (p);
diff --git a/app-i18n/jless/jless-382.262.ebuild b/app-i18n/jless/jless-382.262.ebuild
new file mode 100644
index 000000000000..f750bb0bce5b
--- /dev/null
+++ b/app-i18n/jless/jless-382.262.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/jless/jless-382.262.ebuild,v 1.1 2008/11/02 16:26:01 matsuu Exp $
+
+inherit autotools eutils
+
+LESS_P="less-${PV%%.*}"
+
+DESCRIPTION="Jam less is an enhancement of less which supports multibyte character"
+HOMEPAGE="http://www25.big.jp/~jam/less/"
+JAM_URI="http://www25.big.jp/~jam/less"
+SRC_URI="mirror://gnu/less/${LESS_P}.tar.gz
+ ${JAM_URI}/${LESS_P}-iso258.patch.gz
+ ${JAM_URI}/${LESS_P}-iso258-259.patch.gz
+ ${JAM_URI}/${LESS_P}-iso259-260.patch.gz
+ ${JAM_URI}/${LESS_P}-iso260-261.patch.gz
+ ${JAM_URI}/${LESS_P}-iso261-262.patch.gz"
+
+LICENSE="|| ( GPL-2 less )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.2"
+
+S="${WORKDIR}/${LESS_P}"
+
+src_unpack() {
+ unpack ${LESS_P}.tar.gz
+ cd "${S}"
+ epatch "${DISTDIR}/${LESS_P}-iso258.patch.gz"
+ epatch "${DISTDIR}/${LESS_P}-iso258-259.patch.gz"
+ epatch "${DISTDIR}/${LESS_P}-iso259-260.patch.gz"
+ epatch "${DISTDIR}/${LESS_P}-iso260-261.patch.gz"
+ epatch "${DISTDIR}/${LESS_P}-iso261-262.patch.gz"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ eautoreconf
+}
+
+src_compile() {
+ econf --without-cs-regex --with-editor="${EDITOR}" || die
+ emake || die
+}
+
+src_install() {
+ einstall binprefix=j manprefix=j || die
+
+ newbin "${FILESDIR}/lesspipe.sh-r1" jlesspipe.sh || die
+ doenvd "${FILESDIR}/70jless" || die
+
+ dodoc NEWS README*
+}