summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/greenbone-security-assistant/ChangeLog10
-rwxr-xr-xnet-analyzer/greenbone-security-assistant/files/gsad23
-rw-r--r--net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild36
-rw-r--r--net-analyzer/greenbone-security-assistant/metadata.xml5
4 files changed, 74 insertions, 0 deletions
diff --git a/net-analyzer/greenbone-security-assistant/ChangeLog b/net-analyzer/greenbone-security-assistant/ChangeLog
new file mode 100644
index 000000000000..57b78abb9793
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-analyzer/greenbone-security-assistant
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/ChangeLog,v 1.1 2011/10/09 17:29:41 hanno Exp $
+
+*greenbone-security-assistant-2.0.1 (09 Oct 2011)
+
+ 09 Oct 2011; Hanno Boeck <hanno@gentoo.org>
+ +greenbone-security-assistant-2.0.1.ebuild, +files/gsad, +metadata.xml:
+ Initial commit of Greenbone Security Assistant, part of openvas.
+
diff --git a/net-analyzer/greenbone-security-assistant/files/gsad b/net-analyzer/greenbone-security-assistant/files/gsad
new file mode 100755
index 000000000000..58c0030b22d1
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/files/gsad
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting Greenbone Security Assistant Daemon"
+ start-stop-daemon --start --name gsad \
+ --exec /usr/sbin/gsad \
+ --pidfile /var/run/gsad.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stop openvassd"
+ start-stop-daemon --stop --name gsad \
+ --pidfile /var/run/gsad.pid
+ eend $?
+}
diff --git a/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild
new file mode 100644
index 000000000000..65d2fd748de6
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild,v 1.1 2011/10/09 17:29:41 hanno Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="Greenbone Security Assistant for openvas"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/857/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=net-analyzer/openvas-libraries-4
+ dev-libs/libxslt
+ net-libs/libmicrohttpd"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/cmake"
+
+# Workaround for upstream bug, it doesn't like out-of-tree builds.
+CMAKE_BUILD_DIR="${S}"
+
+src_configure() {
+ local mycmakeargs="-DLOCALSTATEDIR=/var -DSYSCONFDIR=/etc"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc ChangeLog CHANGES README || die "dodoc failed"
+ doinitd "${FILESDIR}"/gsad || die
+}
diff --git a/net-analyzer/greenbone-security-assistant/metadata.xml b/net-analyzer/greenbone-security-assistant/metadata.xml
new file mode 100644
index 000000000000..8cb548491f4e
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>hanno@gentoo.org</email></maintainer>
+</pkgmetadata>