summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/dmenu/ChangeLog7
-rw-r--r--x11-misc/dmenu/dmenu-2.5.ebuild58
-rw-r--r--x11-misc/dmenu/files/digest-dmenu-2.53
3 files changed, 67 insertions, 1 deletions
diff --git a/x11-misc/dmenu/ChangeLog b/x11-misc/dmenu/ChangeLog
index cc722ce9820e..f2738a076555 100644
--- a/x11-misc/dmenu/ChangeLog
+++ b/x11-misc/dmenu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/dmenu
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/ChangeLog,v 1.14 2007/02/24 17:59:47 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/ChangeLog,v 1.15 2007/02/24 19:52:26 cedk Exp $
+
+*dmenu-2.5 (24 Feb 2007)
+
+ 24 Feb 2007; Cedric Krier <cedk@gentoo.org> +dmenu-2.5.ebuild:
+ Version bump
24 Feb 2007; Cedric Krier <cedk@gentoo.org> -dmenu-2.1.ebuild:
Remove old version for bug #168044
diff --git a/x11-misc/dmenu/dmenu-2.5.ebuild b/x11-misc/dmenu/dmenu-2.5.ebuild
new file mode 100644
index 000000000000..b2ec05d6525c
--- /dev/null
+++ b/x11-misc/dmenu/dmenu-2.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/dmenu-2.5.ebuild,v 1.1 2007/02/24 19:52:26 cedk Exp $
+
+inherit toolchain-funcs savedconfig
+
+DESCRIPTION="a generic, highly customizable, and efficient menu for the X Window System"
+HOMEPAGE="http://tools.suckless.org/view.sh/x+tools"
+SRC_URI="http://suckless.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/.*strip.*//" \
+ Makefile || die "sed failed"
+
+ sed -i \
+ -e "s/CFLAGS = -Os/CFLAGS +=/" \
+ -e "s/LDFLAGS =/LDFLAGS +=/" \
+ config.mk || die "sed failed"
+
+ if use savedconfig; then
+ restore_config ${PN}.h
+ fi
+}
+
+src_compile() {
+ local msg
+ use savedconfig && msg=", please check the configfile"
+ emake CC=$(tc-getCC) || die "emake failed${msg}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ newins ${PN}.h ${PF}.config.h
+
+ dodoc README
+
+ save_config ${PN}.h
+}
+
+pkg_postinst() {
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+}
diff --git a/x11-misc/dmenu/files/digest-dmenu-2.5 b/x11-misc/dmenu/files/digest-dmenu-2.5
new file mode 100644
index 000000000000..f672986bb35f
--- /dev/null
+++ b/x11-misc/dmenu/files/digest-dmenu-2.5
@@ -0,0 +1,3 @@
+MD5 1598c5de06eeaa7698d8adbc45b4e909 dmenu-2.5.tar.gz 7878
+RMD160 d1842757fcdc4494bcae307363a773eac544cd2d dmenu-2.5.tar.gz 7878
+SHA256 8b5ffa1aaf8b0a5d1c016a423465c4d90ac268946253f07e81eaf362c85a6508 dmenu-2.5.tar.gz 7878