summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pysqlite/ChangeLog8
-rw-r--r--dev-python/pysqlite/pysqlite-2.6.0.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-python/pysqlite/ChangeLog b/dev-python/pysqlite/ChangeLog
index 69379b5923f6..f16e392ab0ad 100644
--- a/dev-python/pysqlite/ChangeLog
+++ b/dev-python/pysqlite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pysqlite
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/ChangeLog,v 1.115 2010/01/16 15:03:54 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/ChangeLog,v 1.116 2010/03/05 18:28:46 arfrever Exp $
+
+*pysqlite-2.6.0 (05 Mar 2010)
+
+ 05 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -pysqlite-2.5.5-r1.ebuild, +pysqlite-2.6.0.ebuild:
+ Version bump.
16 Jan 2010; Raúl Porcel <armin76@gentoo.org> pysqlite-2.5.6.ebuild:
ia64/sparc stable wrt #296674
diff --git a/dev-python/pysqlite/pysqlite-2.6.0.ebuild b/dev-python/pysqlite/pysqlite-2.6.0.ebuild
new file mode 100644
index 000000000000..11cc9c17f617
--- /dev/null
+++ b/dev-python/pysqlite/pysqlite-2.6.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/pysqlite-2.6.0.ebuild,v 1.1 2010/03/05 18:28:46 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Python wrapper for the local database Sqlite"
+HOMEPAGE="http://code.google.com/p/pysqlite/ http://pypi.python.org/pypi/pysqlite"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="pysqlite"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="examples"
+
+DEPEND=">=dev-db/sqlite-3.1"
+RDEPEND=${DEPEND}
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_MODNAME="pysqlite2"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Don't install pysqlite2.test.
+ sed -i -e 's/, "pysqlite2.test"//' setup.py || die "sed setup.py failed"
+
+ # Fix encoding.
+ sed -i -e "s/\(coding: \)ISO-8859-1/\1utf-8/" lib/{__init__.py,dbapi2.py} || die "sed lib/{__init__.py,dbapi2.py} failed"
+
+ # Workaround to make tests work without installing them.
+ sed -i -e "s/pysqlite2.test/test/" lib/test/__init__.py || die "sed lib/test/__init__.py failed"
+}
+
+src_test() {
+ cd lib
+ testing() {
+ PYTHONPATH="$(ls -d ../build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" -c "from test import test;import sys;sys.exit(test())"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ rm -rf "${ED}usr/pysqlite2-doc"
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/includes/sqlite3
+ fi
+}