summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/codetools/ChangeLog7
-rw-r--r--dev-python/codetools/codetools-4.0.0.ebuild32
2 files changed, 16 insertions, 23 deletions
diff --git a/dev-python/codetools/ChangeLog b/dev-python/codetools/ChangeLog
index daceef8dc814..52cf3eb91fb3 100644
--- a/dev-python/codetools/ChangeLog
+++ b/dev-python/codetools/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/codetools
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/codetools/ChangeLog,v 1.9 2011/08/03 23:51:50 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/codetools/ChangeLog,v 1.10 2012/01/17 06:19:00 bicatali Exp $
+
+ 17 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> codetools-4.0.0.ebuild:
+ EAPI bump
*codetools-4.0.0 (03 Aug 2011)
diff --git a/dev-python/codetools/codetools-4.0.0.ebuild b/dev-python/codetools/codetools-4.0.0.ebuild
index 021cd3607941..1761dfd4cd48 100644
--- a/dev-python/codetools/codetools-4.0.0.ebuild
+++ b/dev-python/codetools/codetools-4.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/codetools/codetools-4.0.0.ebuild,v 1.2 2011/08/04 19:30:30 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/codetools/codetools-4.0.0.ebuild,v 1.3 2012/01/17 06:19:00 bicatali Exp $
+
+EAPI=4
-EAPI="3"
-PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.* *-jython"
DISTUTILS_SRC_TEST="nosetests"
@@ -20,8 +20,9 @@ KEYWORDS="~amd64 ~x86"
LICENSE="BSD"
RDEPEND="dev-python/numpy
- >=dev-python/scimath-4.0
- >=dev-python/traits-4.0"
+ >=dev-python/scimath-4
+ >=dev-python/traits-4"
+
DEPEND="${RDEPEND}
dev-python/setuptools
doc? ( dev-python/sphinx )
@@ -33,13 +34,7 @@ DEPEND="${RDEPEND}
src_compile() {
distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
- popd > /dev/null
- fi
+ use doc && emake -C docs html
}
src_test() {
@@ -50,15 +45,10 @@ src_install() {
find -name "*LICENSE*.txt" -delete
distutils_src_install
- if use doc; then
- pushd docs/build/html > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _images _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
+ use doc && dohtml -r docs/build/html/*
if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/* || die "Installation of examples failed"
+ insinto /usr/share/doc/${PF}
+ doins -r examples
fi
}