summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/bitkeeper/bitkeeper-3.0-r1.ebuild29
-rw-r--r--sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild10
-rw-r--r--sys-apps/fakeroot/fakeroot-0.4.4.ebuild10
3 files changed, 20 insertions, 29 deletions
diff --git a/dev-util/bitkeeper/bitkeeper-3.0-r1.ebuild b/dev-util/bitkeeper/bitkeeper-3.0-r1.ebuild
index 379d2feaf1e6..5ec089a843ef 100644
--- a/dev-util/bitkeeper/bitkeeper-3.0-r1.ebuild
+++ b/dev-util/bitkeeper/bitkeeper-3.0-r1.ebuild
@@ -1,34 +1,29 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/bitkeeper-3.0-r1.ebuild,v 1.6 2003/07/18 20:19:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/bitkeeper-3.0-r1.ebuild,v 1.7 2003/07/18 20:20:45 vapier Exp $
DESCRIPTION="BitKeeper is a scalable configuration management system."
-SRC_URI=""
+SRC_URI="x86? ( bk-${PV}-x86-glibc22-linux.bin )
+ ppc? ( bk-${PV}-powerpc-glibc21-linux.bin )
+ sparc? ( bk-${PV}-sparc-glibc21-linux.bin )
+ alpha? ( bk-${PV}-alpha-glibc21-linux.bin )"
HOMEPAGE="http://www.bitkeeper.com"
SLOT="0"
LICENSE="BKL"
KEYWORDS="x86 ppc sparc alpha"
+RESTRICT="fetch"
DEPEND="virtual/glibc
>=dev-lang/tcl-8.3.3
X? ( >=dev-lang/tk-8.3.3 )"
-# I'm not sure what the official way to do this is...
-use 'x86' >/dev/null && A="bk-3.0-x86-glibc22-linux.bin"
-use 'ppc' >/dev/null && A="bk-3.0-powerpc-glibc21-linux.bin"
-use 'sparc' >/dev/null && A="bk-3.0-sparc-glibc21-linux.bin"
-use 'alpha' >/dev/null && A="bk-3.0-alpha-glibc21-linux.bin"
-
-pkg_setup() {
- if [ ! -f ${DISTDIR}/${A} ] ; then
- eerror "You need to perform the following steps to install this package:"
- eerror "- Sign up at ${HOMEPAGE}"
- eerror "- Check your mail and visit the download location"
- eerror "- Download ${A} and place it in ${DISTDIR}"
- eerror "- emerge this package again"
- die "package must be downloaded"
- fi
+pkg_nofetch() {
+ einfo "You need to perform the following steps to install this package:"
+ einfo "- Sign up at ${HOMEPAGE}"
+ einfo "- Check your mail and visit the download location"
+ einfo "- Download ${A} and place it in ${DISTDIR}"
+ einfo "- emerge this package again"
}
src_unpack() {
diff --git a/sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild b/sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild
index 89c2f37dd6e2..052bf8008543 100644
--- a/sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild
+++ b/sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild
@@ -1,20 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild,v 1.5 2003/06/21 21:19:39 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild,v 1.6 2003/07/18 20:21:56 vapier Exp $
MY_P="${PN}_${PV}-4.1"
DESCRIPTION="Run commands in an environment faking root privileges"
HOMEPAGE="http://joostje.op.het.net/fakeroot/index.html"
SRC_URI="http://ftp.debian.org/debian/dists/potato/main/source/utils/${MY_P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 amd64 ~sparc ~ppc"
-RDEPEND=">=virtual/glibc-2.2.2"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${P}"
+RDEPEND="virtual/glibc"
src_unpack() {
unpack ${A}
@@ -26,6 +24,6 @@ src_compile() {
emake || die "compile problem"
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die "install problem"
}
diff --git a/sys-apps/fakeroot/fakeroot-0.4.4.ebuild b/sys-apps/fakeroot/fakeroot-0.4.4.ebuild
index 2a774200d69b..cb1f779899f1 100644
--- a/sys-apps/fakeroot/fakeroot-0.4.4.ebuild
+++ b/sys-apps/fakeroot/fakeroot-0.4.4.ebuild
@@ -1,26 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fakeroot/fakeroot-0.4.4.ebuild,v 1.3 2003/06/21 21:19:39 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fakeroot/fakeroot-0.4.4.ebuild,v 1.4 2003/07/18 20:21:56 vapier Exp $
MY_P="${PN}_${PV}-4.1"
DESCRIPTION="Run commands in an environment faking root privileges"
HOMEPAGE="http://joostje.op.het.net/fakeroot/index.html"
SRC_URI="http://ftp.debian.org/debian/dists/potato/main/source/utils/${MY_P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 amd64"
-RDEPEND=">=virtual/glibc-2.2.2"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${P}"
+RDEPEND="virtual/glibc"
src_compile() {
econf || die "configure problem"
emake || die "compile problem"
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die "install problem"
}