summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-www/mozilla-firefox-bin/ChangeLog9
-rw-r--r--net-www/mozilla-firefox-bin/files/digest-mozilla-firefox-bin-1.0.11
-rw-r--r--net-www/mozilla-firefox-bin/mozilla-firefox-bin-1.0.1.ebuild83
-rw-r--r--net-www/mozilla-firefox-bin/mozilla-firefox-bin-1.0.ebuild4
4 files changed, 93 insertions, 4 deletions
diff --git a/net-www/mozilla-firefox-bin/ChangeLog b/net-www/mozilla-firefox-bin/ChangeLog
index 8018c3f77e44..3bab592b8680 100644
--- a/net-www/mozilla-firefox-bin/ChangeLog
+++ b/net-www/mozilla-firefox-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mozilla-firefox-bin
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox-bin/ChangeLog,v 1.27 2004/11/18 21:53:15 agriffis Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox-bin/ChangeLog,v 1.28 2005/02/26 08:38:53 brad Exp $
+
+*mozilla-firefox-bin-1.0.1 (26 Feb 2005)
+
+ 26 Feb 2005; Brad Laue <brad@gentoo.org> +mozilla-firefox-bin-1.0.1.ebuild:
+ Bump to version 1.0.1 - stability and security fixes.
*mozilla-firefox-bin-1.0_rc1 (18 Nov 2004)
diff --git a/net-www/mozilla-firefox-bin/files/digest-mozilla-firefox-bin-1.0.1 b/net-www/mozilla-firefox-bin/files/digest-mozilla-firefox-bin-1.0.1
new file mode 100644
index 000000000000..59720900dc4d
--- /dev/null
+++ b/net-www/mozilla-firefox-bin/files/digest-mozilla-firefox-bin-1.0.1
@@ -0,0 +1 @@
+MD5 f1781acbba45db0f4074478c4800289e firefox-1.0.1.tar.gz 8232400
diff --git a/net-www/mozilla-firefox-bin/mozilla-firefox-bin-1.0.1.ebuild b/net-www/mozilla-firefox-bin/mozilla-firefox-bin-1.0.1.ebuild
new file mode 100644
index 000000000000..9dfc20073b2a
--- /dev/null
+++ b/net-www/mozilla-firefox-bin/mozilla-firefox-bin-1.0.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox-bin/mozilla-firefox-bin-1.0.1.ebuild,v 1.1 2005/02/26 08:38:53 brad Exp $
+
+inherit nsplugins eutils mozilla-launcher
+
+IUSE="gnome"
+
+DESCRIPTION="The Mozilla Firefox Web Browser"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/linux-i686/en-US/firefox-${PV}.tar.gz"
+HOMEPAGE="http://www.mozilla.org/projects/firefox"
+RESTRICT="nostrip"
+
+KEYWORDS="-* ~x86 ~amd64"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+
+DEPEND="virtual/libc"
+RDEPEND="virtual/x11
+ x86? (
+ >=sys-libs/lib-compat-1.0-r2
+ >=x11-libs/gtk+-2.2
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ )
+ >=net-www/mozilla-launcher-1.22"
+
+S=${WORKDIR}/firefox
+
+src_install() {
+ # Install firefox in /opt
+ dodir /opt
+ mv ${S} ${D}/opt/firefox
+
+ # Plugin path setup (rescuing the existing plugins)
+ src_mv_plugins /opt/firefox/plugins
+
+ # Fixing permissions
+ chown -R root:root ${D}/opt/firefox
+
+ # mozilla-launcher-1.8 supports -bin versions
+ dodir /usr/bin
+ dosym /usr/libexec/mozilla-launcher /usr/bin/firefox-bin
+
+ # Install icon and .desktop for menu entry
+ if use gnome; then
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/icon/mozillafirefox-bin-icon.png
+ # Fix bug 54179: Install .desktop file into /usr/share/applications
+ # instead of /usr/share/gnome/apps/Internet (18 Jun 2004 agriffis)
+ insinto /usr/share/applications
+ doins ${FILESDIR}/icon/mozillafirefox-bin.desktop
+ fi
+
+ # Normally firefox-bin-0.9 must be run as root once before it can
+ # be run as a normal user. Drop in some initialized files to
+ # avoid this.
+ einfo "Extracting firefox-bin-${PV} initialization files"
+ tar xjpf ${FILESDIR}/firefox-bin-0.9-init.tar.bz2 -C ${D}/opt/firefox
+}
+
+pkg_preinst() {
+ export MOZILLA_FIVE_HOME=${ROOT}/opt/firefox
+
+ # Remove the old plugins dir
+ pkg_mv_plugins /opt/firefox/plugins
+
+ # Remove entire installed instance to prevent all kinds of
+ # problems... see bug 44772 for example
+ rm -rf "${MOZILLA_FIVE_HOME}"
+}
+
+pkg_postinst() {
+ export MOZILLA_FIVE_HOME=${ROOT}/opt/firefox
+
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}
diff --git a/net-www/mozilla-firefox-bin/mozilla-firefox-bin-1.0.ebuild b/net-www/mozilla-firefox-bin/mozilla-firefox-bin-1.0.ebuild
index ddd5414cdc6d..e0e65011f2ad 100644
--- a/net-www/mozilla-firefox-bin/mozilla-firefox-bin-1.0.ebuild
+++ b/net-www/mozilla-firefox-bin/mozilla-firefox-bin-1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox-bin/mozilla-firefox-bin-1.0.ebuild,v 1.2 2004/11/18 21:53:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox-bin/mozilla-firefox-bin-1.0.ebuild,v 1.3 2005/02/26 08:38:53 brad Exp $
inherit nsplugins eutils mozilla-launcher