summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-base/gnome-menus/ChangeLog8
-rw-r--r--gnome-base/gnome-menus/gnome-menus-2.26.2.ebuild76
-rw-r--r--gnome-base/gnome-menus/gnome-menus-2.28.0.1.ebuild78
-rw-r--r--gnome-base/gnome-menus/gnome-menus-2.30.4.ebuild30
4 files changed, 27 insertions, 165 deletions
diff --git a/gnome-base/gnome-menus/ChangeLog b/gnome-base/gnome-menus/ChangeLog
index 92d40d258e55..33df36aa483d 100644
--- a/gnome-base/gnome-menus/ChangeLog
+++ b/gnome-base/gnome-menus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/gnome-menus
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-menus/ChangeLog,v 1.158 2010/10/17 15:16:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-menus/ChangeLog,v 1.159 2010/11/08 22:08:18 eva Exp $
+
+ 08 Nov 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ -gnome-menus-2.26.2.ebuild, -gnome-menus-2.28.0.1.ebuild,
+ gnome-menus-2.30.4.ebuild:
+ Support mulitple-python installations, bug #313447. Clean up old
+ revisions.
17 Oct 2010; Raúl Porcel <armin76@gentoo.org>
gnome-menus-2.30.2-r1.ebuild:
diff --git a/gnome-base/gnome-menus/gnome-menus-2.26.2.ebuild b/gnome-base/gnome-menus/gnome-menus-2.26.2.ebuild
deleted file mode 100644
index 0754723ad415..000000000000
--- a/gnome-base/gnome-menus/gnome-menus-2.26.2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-menus/gnome-menus-2.26.2.ebuild,v 1.13 2010/07/20 01:51:05 jer Exp $
-
-inherit eutils gnome2 python
-
-DESCRIPTION="The GNOME menu system, implementing the F.D.O cross-desktop spec"
-HOMEPAGE="http://www.gnome.org"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE="debug python"
-
-RDEPEND=">=dev-libs/glib-2.18.0
- python? (
- >=dev-lang/python-2.4.4-r5
- dev-python/pygtk )"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- >=dev-util/pkgconfig-0.9
- >=dev-util/intltool-0.40"
-
-DOCS="AUTHORS ChangeLog HACKING NEWS README"
-
-pkg_setup() {
- # Do NOT compile with --disable-debug/--enable-debug=no
- # FIXME: fix autofoo and report upstream
- if use debug ; then
- G2CONF="${G2CONF} --enable-debug=yes"
- fi
-
- G2CONF="${G2CONF} $(use_enable python) --disable-static"
-}
-
-src_unpack() {
- gnome2_src_unpack
-
- # Don't show KDE standalone settings desktop files in GNOME others menu
- epatch "${FILESDIR}/${PN}-2.18.3-ignore_kde_standalone.patch"
-
- # disable pyc compiling
- mv py-compile py-compile-disabled
- ln -s $(type -P true) py-compile
-}
-
-src_install() {
- gnome2_src_install
-
- # Prefix menu, bug #256614
- mv "${D}"/etc/xdg/menus/applications.menu \
- "${D}"/etc/xdg/menus/gnome-applications.menu || die "menu move failed"
-
- exeinto /etc/X11/xinit/xinitrc.d/
- doexe "${FILESDIR}/10-xdg-menu-gnome" || die "doexe failed"
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- if use python; then
- python_need_rebuild
- python_mod_optimize $(python_get_sitedir)/GMenuSimpleEditor
- fi
-
- ewarn "Due to bug #256614, you might lose icons in applications menus."
- ewarn "If you use a login manager, please re-select your session."
- ewarn "If you use startx and have no .xinitrc, just export XSESSION=Gnome."
- ewarn "If you use startx and have .xinitrc, export XDG_MENU_PREFIX=gnome-."
-}
-
-pkg_postrm() {
- gnome2_pkg_postrm
- if use python; then
- python_mod_cleanup $(python_get_sitedir)/GMenuSimpleEditor
- fi
-}
diff --git a/gnome-base/gnome-menus/gnome-menus-2.28.0.1.ebuild b/gnome-base/gnome-menus/gnome-menus-2.28.0.1.ebuild
deleted file mode 100644
index ef8f695f61c0..000000000000
--- a/gnome-base/gnome-menus/gnome-menus-2.28.0.1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-menus/gnome-menus-2.28.0.1.ebuild,v 1.9 2010/08/18 22:00:09 maekke Exp $
-
-inherit eutils gnome2 python
-
-DESCRIPTION="The GNOME menu system, implementing the F.D.O cross-desktop spec"
-HOMEPAGE="http://www.gnome.org"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ia64 ~ppc ~ppc64 sh sparc x86 ~x86-fbsd"
-IUSE="debug python"
-
-RDEPEND=">=dev-libs/glib-2.18.0
- python? (
- >=dev-lang/python-2.4.4-r5
- dev-python/pygtk )"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- >=dev-util/pkgconfig-0.9
- >=dev-util/intltool-0.40"
-
-DOCS="AUTHORS ChangeLog HACKING NEWS README"
-
-pkg_setup() {
- # Do NOT compile with --disable-debug/--enable-debug=no
- # It disables api usage checks
- if ! use debug ; then
- G2CONF="${G2CONF} --enable-debug=minimum"
- fi
-
- G2CONF="${G2CONF} $(use_enable python) --disable-static"
-}
-
-src_unpack() {
- gnome2_src_unpack
-
- # Don't show KDE standalone settings desktop files in GNOME others menu
- epatch "${FILESDIR}/${PN}-2.18.3-ignore_kde_standalone.patch"
-
- # disable pyc compiling
- mv py-compile py-compile-disabled
- ln -s $(type -P true) py-compile
-}
-
-src_install() {
- gnome2_src_install
-
- find "${D}" -name "*.la" -delete || die "remove of la files failed"
-
- # Prefix menu, bug #256614
- mv "${D}"/etc/xdg/menus/applications.menu \
- "${D}"/etc/xdg/menus/gnome-applications.menu || die "menu move failed"
-
- exeinto /etc/X11/xinit/xinitrc.d/
- doexe "${FILESDIR}/10-xdg-menu-gnome" || die "doexe failed"
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- if use python; then
- python_need_rebuild
- python_mod_optimize $(python_get_sitedir)/GMenuSimpleEditor
- fi
-
- ewarn "Due to bug #256614, you might lose icons in applications menus."
- ewarn "If you use a login manager, please re-select your session."
- ewarn "If you use startx and have no .xinitrc, just export XSESSION=Gnome."
- ewarn "If you use startx and have .xinitrc, export XDG_MENU_PREFIX=gnome-."
-}
-
-pkg_postrm() {
- gnome2_pkg_postrm
- if use python; then
- python_mod_cleanup $(python_get_sitedir)/GMenuSimpleEditor
- fi
-}
diff --git a/gnome-base/gnome-menus/gnome-menus-2.30.4.ebuild b/gnome-base/gnome-menus/gnome-menus-2.30.4.ebuild
index bc35a787980f..e359097572c6 100644
--- a/gnome-base/gnome-menus/gnome-menus-2.30.4.ebuild
+++ b/gnome-base/gnome-menus/gnome-menus-2.30.4.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-menus/gnome-menus-2.30.4.ebuild,v 1.1 2010/09/27 21:37:00 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-menus/gnome-menus-2.30.4.ebuild,v 1.2 2010/11/08 22:08:18 eva Exp $
EAPI="2"
PYTHON_DEPEND="python? 2:2.4"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit eutils gnome2 python
@@ -23,9 +25,9 @@ DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.9
>=dev-util/intltool-0.40"
-DOCS="AUTHORS ChangeLog HACKING NEWS README"
-
pkg_setup() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
# Do NOT compile with --disable-debug/--enable-debug=no
# It disables api usage checks
if ! use debug ; then
@@ -47,16 +49,25 @@ src_prepare() {
# disable pyc compiling
mv py-compile py-compile-disabled
ln -s $(type -P true) py-compile
+
+ python_copy_sources
}
src_configure() {
- gnome2_src_configure
+ python_execute_function -s gnome2_src_configure
}
-src_install() {
- gnome2_src_install
+src_compile() {
+ python_execute_function -s gnome2_src_compile
+}
+
+src_test() {
+ python_execute_function -s -d
+}
- find "${D}" -name "*.la" -delete || die "remove of la files failed"
+src_install() {
+ python_execute_function -s gnome2_src_install
+ python_clean_installation_image
# Prefix menu, bug #256614
mv "${D}"/etc/xdg/menus/applications.menu \
@@ -69,8 +80,7 @@ src_install() {
pkg_postinst() {
gnome2_pkg_postinst
if use python; then
- python_need_rebuild
- python_mod_optimize $(python_get_sitedir)/GMenuSimpleEditor
+ python_mod_optimize GMenuSimpleEditor
fi
ewarn "Due to bug #256614, you might lose icons in applications menus."
@@ -82,6 +92,6 @@ pkg_postinst() {
pkg_postrm() {
gnome2_pkg_postrm
if use python; then
- python_mod_cleanup $(python_get_sitedir)/GMenuSimpleEditor
+ python_mod_cleanup GMenuSimpleEditor
fi
}