summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/PEAR-PEAR/ChangeLog5
-rw-r--r--dev-php/PEAR-PEAR/PEAR-PEAR-1.6.2.ebuild136
-rw-r--r--dev-php/PEAR-PEAR/files/digest-PEAR-PEAR-1.6.215
3 files changed, 4 insertions, 152 deletions
diff --git a/dev-php/PEAR-PEAR/ChangeLog b/dev-php/PEAR-PEAR/ChangeLog
index 6b5d79ea1820..49cbfaf1647d 100644
--- a/dev-php/PEAR-PEAR/ChangeLog
+++ b/dev-php/PEAR-PEAR/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-php/PEAR-PEAR
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/ChangeLog,v 1.97 2007/11/29 23:31:23 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/ChangeLog,v 1.98 2007/11/29 23:33:32 jokey Exp $
+
+ 29 Nov 2007; Markus Ullmann <jokey@gentoo.org> -PEAR-PEAR-1.6.2.ebuild:
+ drop old
*PEAR-PEAR-1.6.2-r1 (29 Nov 2007)
diff --git a/dev-php/PEAR-PEAR/PEAR-PEAR-1.6.2.ebuild b/dev-php/PEAR-PEAR/PEAR-PEAR-1.6.2.ebuild
deleted file mode 100644
index 6d9e12317d6a..000000000000
--- a/dev-php/PEAR-PEAR/PEAR-PEAR-1.6.2.ebuild
+++ /dev/null
@@ -1,136 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/PEAR-PEAR-1.6.2.ebuild,v 1.1 2007/10/22 22:33:47 jokey Exp $
-
-inherit depend.php
-
-ARCHIVE_TAR="1.3.2"
-CONSOLE_GETOPT="1.2.3"
-STRUCTURES_GRAPH="1.0.2"
-XML_RPC="1.5.1"
-PEAR="${PV}"
-
-[[ -z "${PEAR_CACHEDIR}" ]] && PEAR_CACHEDIR="/var/cache/pear"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-
-DESCRIPTION="PEAR Base System (PEAR, Archive_Tar, Console_Getopt, Structures_Graph, XML_RPC)."
-HOMEPAGE="http://pear.php.net/"
-SRC_URI="http://pear.php.net/get/Archive_Tar-${ARCHIVE_TAR}.tgz
- http://pear.php.net/get/Console_Getopt-${CONSOLE_GETOPT}.tgz
- http://pear.php.net/get/Structures_Graph-${STRUCTURES_GRAPH}.tgz
- http://pear.php.net/get/XML_RPC-${XML_RPC}.tgz
- http://pear.php.net/get/PEAR-${PEAR}.tgz"
-LICENSE="LGPL-2.1 PHP"
-SLOT="0"
-IUSE=""
-
-# we depend on a recent sandbox version to mitigate problems users
-# have been experiencing
-DEPEND="dev-lang/php
- >=sys-apps/sandbox-1.2.17"
-RDEPEND="dev-lang/php"
-
-S=${WORKDIR}
-
-pkg_setup() {
- has_php
-
- # we check that PHP was compiled with the correct USE flags
- if [[ ${PHP_VERSION} == "4" ]] ; then
- require_php_with_use cli pcre expat zlib
- else
- require_php_with_use cli pcre xml zlib
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${WORKDIR}"/PEAR-${PV}
- epatch "${FILESDIR}"/${PV}-accept-encoding-bug_12116.patch # PEAR bug #12116
-}
-
-src_install() {
- require_php_cli
-
- # Prevent SNMP related sandbox violoation.
- addpredict /usr/share/snmp/mibs/.index
- addpredict /var/lib/net-snmp/
-
- mkdir -p PEAR/XML/RPC
-
- # Install PEAR Package.
- cp -r PEAR-${PEAR}/OS PEAR/
- cp -r PEAR-${PEAR}/PEAR PEAR/
- cp PEAR-${PEAR}/PEAR.php PEAR/PEAR.php
- cp PEAR-${PEAR}/System.php PEAR/System.php
-
- # Prepare /usr/bin/pear script.
- cp PEAR-${PEAR}/scripts/pearcmd.php PEAR/pearcmd.php
- sed -i "s:@pear_version@:${PEAR}:g" PEAR/pearcmd.php || die "sed failed"
- cp PEAR-${PEAR}/scripts/pear.sh PEAR/pear
- sed -i -e "s:@php_bin@:${PHPCLI}:g" \
- -e "s:@bin_dir@:/usr/bin:g" \
- -e "s:@php_dir@:/usr/share/php:g" \
- -e "s:-d output_buffering=1:-d output_buffering=1 -d memory_limit=32M:g" PEAR/pear || die "sed failed"
-
- # Prepare /usr/bin/peardev script.
- cp PEAR-${PEAR}/scripts/peardev.sh PEAR/peardev
- sed -i -e "s:@php_bin@:${PHPCLI}:g" \
- -e "s:@bin_dir@:/usr/bin:g" \
- -e "s:@php_dir@:/usr/share/php:g" PEAR/peardev || die "sed failed"
-
- # Prepare /usr/bin/pecl script.
- cp PEAR-${PEAR}/scripts/peclcmd.php PEAR/peclcmd.php
- sed -i "s:@pear_version@:${PEAR}:g" PEAR/peclcmd.php || die "sed failed"
- cp PEAR-${PEAR}/scripts/pecl.sh PEAR/pecl
- sed -i -e "s:@php_bin@:${PHPCLI}:g" \
- -e "s:@bin_dir@:/usr/bin:g" \
- -e "s:@php_dir@:/usr/share/php:g" PEAR/pecl || die "sed failed"
-
- # Prepare PEAR/Dependency2.php.
- sed -i "s:@PEAR-VER@:${PEAR}:g" PEAR/PEAR/Dependency2.php || die "sed failed"
-
- # Install Archive_Tar Package.
- cp -r Archive_Tar-${ARCHIVE_TAR}/Archive PEAR/
-
- # Install Console_Getopt Package.
- cp -r Console_Getopt-${CONSOLE_GETOPT}/Console PEAR/
-
- # Install Structures_Graph Package.
- cp -r Structures_Graph-${STRUCTURES_GRAPH}/Structures PEAR/
-
- # Install XML_RPC Package.
- cp XML_RPC-${XML_RPC}/RPC.php PEAR/XML/RPC.php
- cp XML_RPC-${XML_RPC}/Server.php PEAR/XML/RPC/Server.php
-
- # Finalize installation.
- cd PEAR
- insinto /usr/share/php
- doins -r Archive Console OS PEAR Structures XML *.php
- dobin pear peardev pecl
-
- insinto /etc
- doins "${FILESDIR}/pear.conf"
- sed -i -e "s|s:PHPCLILEN:\"PHPCLI\"|s:${#PHPCLI}:\"${PHPCLI}\"|g" \
- -e "s|s:CACHEDIRLEN:\"CACHEDIR\"|s:${#PEAR_CACHEDIR}:\"${PEAR_CACHEDIR}\"|g" "${D}/etc/pear.conf" || die "sed failed"
-
- keepdir "${PEAR_CACHEDIR}"
- fperms 755 "${PEAR_CACHEDIR}"
-}
-
-pkg_preinst() {
- rm -f "${ROOT}/etc/pear.conf"
-}
-
-pkg_postinst() {
- pear clear-cache
-
- # Update PEAR/PECL channels as needed, add new ones to the list if needed
- pearchans="pear.php.net pecl.php.net components.ez.no pear.phpdb.org pear.phing.info pear.symfony-project.com pear.phpunit.de pear.php-baustelle.de pear.zeronotice.org pear.phpontrax.com"
-
- for chan in ${pearchans} ; do
- pear channel-discover ${chan}
- pear channel-update ${chan}
- done
-}
diff --git a/dev-php/PEAR-PEAR/files/digest-PEAR-PEAR-1.6.2 b/dev-php/PEAR-PEAR/files/digest-PEAR-PEAR-1.6.2
deleted file mode 100644
index af07559e1588..000000000000
--- a/dev-php/PEAR-PEAR/files/digest-PEAR-PEAR-1.6.2
+++ /dev/null
@@ -1,15 +0,0 @@
-MD5 17d49e837b64df4e8f9124f829b22cd1 Archive_Tar-1.3.2.tgz 17150
-RMD160 cec105d1cdefd502f209c24c217645cec723d7a2 Archive_Tar-1.3.2.tgz 17150
-SHA256 952820c055a770a6d1ecdff487b3de0ff0617a1baca084dac443a6d5f7cde53c Archive_Tar-1.3.2.tgz 17150
-MD5 d7618327f9302a7191893768982de823 Console_Getopt-1.2.3.tgz 4011
-RMD160 d1624dbcb223395ded9e46285f896d6f5bb5ca74 Console_Getopt-1.2.3.tgz 4011
-SHA256 1985b1434c13d5e619643c3712e4144d39f66f6fed61994765e6a0f1623680d8 Console_Getopt-1.2.3.tgz 4011
-MD5 8658f584d0ba2648b795fe8b1d8998c2 PEAR-1.6.2.tgz 297794
-RMD160 db3c37446c8e06149d7197ebdd3e9d720dd162ce PEAR-1.6.2.tgz 297794
-SHA256 5f502e44314f4ba28467e21b28c51207265a3d282b33dbc664edbcddf41dcc8e PEAR-1.6.2.tgz 297794
-MD5 2664e2d024048f982e12fad4d1bfbb87 Structures_Graph-1.0.2.tgz 30947
-RMD160 8eb53f6da109b90bab5d8101e99183a1ae116404 Structures_Graph-1.0.2.tgz 30947
-SHA256 d30e72fcb888d17d01d211dd0cdc8bdde8c87554fc4d7de438a4cf0b490a8697 Structures_Graph-1.0.2.tgz 30947
-MD5 1b516162ad65971b5fd04a7c279627ec XML_RPC-1.5.1.tgz 32215
-RMD160 6e8b9f4698285609d9c9d4450c59c16083607ee8 XML_RPC-1.5.1.tgz 32215
-SHA256 a5b517eef799df148d6c85ab19e188715a22c069f4507dcb792e5efb7d0f117e XML_RPC-1.5.1.tgz 32215