summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-forensics/zzuf/ChangeLog9
-rw-r--r--app-forensics/zzuf/zzuf-0.12.ebuild (renamed from app-forensics/zzuf/zzuf-0.10.ebuild)27
2 files changed, 31 insertions, 5 deletions
diff --git a/app-forensics/zzuf/ChangeLog b/app-forensics/zzuf/ChangeLog
index 6f7bd704b8c0..826e39d6a0fc 100644
--- a/app-forensics/zzuf/ChangeLog
+++ b/app-forensics/zzuf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-forensics/zzuf
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/zzuf/ChangeLog,v 1.2 2008/05/19 00:25:47 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/zzuf/ChangeLog,v 1.3 2008/06/13 18:04:52 flameeyes Exp $
+
+*zzuf-0.12 (13 Jun 2008)
+
+ 13 Jun 2008; Diego Pettenò <flameeyes@gentoo.org> -zzuf-0.10.ebuild,
+ +zzuf-0.12.ebuild:
+ Version bump, fix tests being built unconditionally (bug #226355), add
+ src_test for the testsuite, which doesn't work with sandbox.
19 May 2008; Carsten Lohrke <carlo@gentoo.org> zzuf-0.10.ebuild:
Keyword ~x86.
diff --git a/app-forensics/zzuf/zzuf-0.10.ebuild b/app-forensics/zzuf/zzuf-0.12.ebuild
index 224d6228be38..5065968a45da 100644
--- a/app-forensics/zzuf/zzuf-0.10.ebuild
+++ b/app-forensics/zzuf/zzuf-0.12.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/zzuf/zzuf-0.10.ebuild,v 1.2 2008/05/19 00:25:47 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/zzuf/zzuf-0.12.ebuild,v 1.1 2008/06/13 18:04:52 flameeyes Exp $
inherit autotools
DESCRIPTION="Transparent application input fuzzer"
-HOMEPAGE="http://sam.zoy.org/zzuf/"
-SRC_URI="http://sam.zoy.org/zzuf/${P}.tar.gz"
+HOMEPAGE="http://libcaca.zoy.org/wiki/zzuf/"
+SRC_URI="mirro://gentoo/${P}.tar.gz"
LICENSE="WTFPL-2"
SLOT="0"
@@ -19,8 +19,11 @@ src_unpack() {
unpack ${A}
cd "${S}"
- sed -i -e '/CFLAGS/d' "${S}/configure.ac" \
+ sed -i -e '/CFLAGS/d' "${S}"/configure.ac \
|| die "unable to fix the configure.ac"
+ sed -i -e 's:noinst_:check_:' "${S}"/test/Makefile.am \
+ || die "unable to fix unconditional test building"
+
eautoreconf
}
@@ -36,6 +39,22 @@ src_compile() {
emake || die "emake failed"
}
+# This could be removed in next versions if my patches will be applied
+# by Sam. -- Diego 'Flameeyes'
+src_test() {
+ if hasq sandbox ${FEATURES}; then
+ ewarn "zzuf tests don't work correctly when sandbox is enabled,"
+ ewarn "skipping tests. If you want to run the testsuite, please"
+ ewarn "disable sandbox for this build."
+ return
+ fi
+
+ cd "${S}"/test
+ emake check || die "Unable to build tools needed for testsuite"
+
+ ./testsuite.sh || die "testsuite failed"
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README TODO