summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/otrs/ChangeLog6
-rw-r--r--www-apps/otrs/otrs-2.0.4.ebuild23
-rw-r--r--www-apps/otrs/otrs-2.1.5.ebuild23
3 files changed, 19 insertions, 33 deletions
diff --git a/www-apps/otrs/ChangeLog b/www-apps/otrs/ChangeLog
index d5a7d9455e6b..b2836e90c6bb 100644
--- a/www-apps/otrs/ChangeLog
+++ b/www-apps/otrs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apps/otrs
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/otrs/ChangeLog,v 1.31 2007/05/01 11:53:15 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/otrs/ChangeLog,v 1.32 2007/05/12 04:50:56 chtekk Exp $
+
+ 12 May 2007; Luca Longinotti <chtekk@gentoo.org> otrs-2.0.4.ebuild,
+ otrs-2.1.5.ebuild:
+ Apache 1.X masking (fix ebuilds to not require apache-1*).
01 May 2007; Markus Rothe <corsair@gentoo.org> otrs-2.1.5.ebuild:
Added ~ppc64; bug #175869
diff --git a/www-apps/otrs/otrs-2.0.4.ebuild b/www-apps/otrs/otrs-2.0.4.ebuild
index bbf0910f5573..37eae30e5583 100644
--- a/www-apps/otrs/otrs-2.0.4.ebuild
+++ b/www-apps/otrs/otrs-2.0.4.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/otrs/otrs-2.0.4.ebuild,v 1.10 2007/01/20 15:14:00 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/otrs/otrs-2.0.4.ebuild,v 1.11 2007/05/12 04:50:56 chtekk Exp $
inherit webapp eutils
S=${WORKDIR}/${PN}
-IUSE="mysql postgres fastcgi apache2 ldap gd"
+IUSE="mysql postgres fastcgi ldap gd"
DESCRIPTION="OTRS is an Open source Ticket Request System"
HOMEPAGE="http://otrs.org/"
@@ -38,12 +38,9 @@ RDEPEND="
ldap? ( dev-perl/perl-ldap net-nds/openldap )
mysql? ( dev-perl/DBD-mysql )
postgres? ( dev-perl/DBD-Pg )
- apache2? ( >=net-www/apache-2
- fastcgi? ( dev-perl/FCGI )
- !fastcgi? ( =www-misc/libapreq2-2* ) )
- !apache2? ( =net-www/apache-1*
- fastcgi? ( dev-perl/FCGI )
- !fastcgi? ( =www-misc/libapreq-1* ) )
+ >=net-www/apache-2
+ fastcgi? ( dev-perl/FCGI )
+ !fastcgi? ( =www-misc/libapreq2-2* )
gd? ( dev-perl/GD dev-perl/GDTextUtil dev-perl/GDGraph )
"
@@ -64,14 +61,8 @@ src_unpack() {
rm -rf auto_* redhat* suse*
if use fastcgi; then
- if ! use apache2; then
- epatch ${FILESDIR}/apache1.patch
- sed -e "s|cgi-bin|fcgi-bin|" -i ${S}/scripts/apache-httpd.include.conf
- fi
- if use apache2; then
- epatch ${FILESDIR}/apache2.patch
- sed -e "s|cgi-bin|fcgi-bin|" -i ${S}/scripts/apache2-httpd.include.conf
- fi
+ epatch ${FILESDIR}/apache2.patch
+ sed -e "s|cgi-bin|fcgi-bin|" -i ${S}/scripts/apache2-httpd.include.conf
sed -e "s|index.pl|index.fpl|" -i ${S}/var/httpd/htdocs/index.html
fi
}
diff --git a/www-apps/otrs/otrs-2.1.5.ebuild b/www-apps/otrs/otrs-2.1.5.ebuild
index 5725cc27b58b..477e3dc8e004 100644
--- a/www-apps/otrs/otrs-2.1.5.ebuild
+++ b/www-apps/otrs/otrs-2.1.5.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/otrs/otrs-2.1.5.ebuild,v 1.2 2007/05/01 11:53:15 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/otrs/otrs-2.1.5.ebuild,v 1.3 2007/05/12 04:50:56 chtekk Exp $
inherit webapp eutils
-IUSE="mysql postgres fastcgi apache2 ldap gd pdf"
+IUSE="mysql postgres fastcgi ldap gd pdf"
DESCRIPTION="OTRS is an Open source Ticket Request System"
HOMEPAGE="http://otrs.org/"
@@ -35,12 +35,9 @@ RDEPEND="
ldap? ( dev-perl/perl-ldap net-nds/openldap )
mysql? ( dev-perl/DBD-mysql )
postgres? ( dev-perl/DBD-Pg )
- apache2? ( >=net-www/apache-2
- fastcgi? ( dev-perl/FCGI )
- !fastcgi? ( =www-misc/libapreq2-2* ) )
- !apache2? ( =net-www/apache-1*
- fastcgi? ( dev-perl/FCGI )
- !fastcgi? ( =www-misc/libapreq-1* ) )
+ >=net-www/apache-2
+ fastcgi? ( dev-perl/FCGI )
+ !fastcgi? ( =www-misc/libapreq2-2* )
gd? ( dev-perl/GD dev-perl/GDTextUtil dev-perl/GDGraph )
"
@@ -66,14 +63,8 @@ src_unpack() {
rm -rf auto_* redhat* suse*
if use fastcgi; then
- if ! use apache2; then
- epatch ${FILESDIR}/apache1.patch
- sed -e "s|cgi-bin|fcgi-bin|" -i ${S}/scripts/apache-httpd.include.conf
- fi
- if use apache2; then
- epatch ${FILESDIR}/apache2.patch
- sed -e "s|cgi-bin|fcgi-bin|" -i ${S}/scripts/apache2-httpd.include.conf
- fi
+ epatch ${FILESDIR}/apache2.patch
+ sed -e "s|cgi-bin|fcgi-bin|" -i ${S}/scripts/apache2-httpd.include.conf
sed -e "s|index.pl|index.fpl|" -i ${S}/var/httpd/htdocs/index.html
fi
}