summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/beagle/ChangeLog8
-rw-r--r--sci-libs/beagle/beagle-3.0.3.ebuild40
-rw-r--r--sci-libs/beagle/metadata.xml6
3 files changed, 32 insertions, 22 deletions
diff --git a/sci-libs/beagle/ChangeLog b/sci-libs/beagle/ChangeLog
index b9869f8fa30a..964baedf03f7 100644
--- a/sci-libs/beagle/ChangeLog
+++ b/sci-libs/beagle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/beagle
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/beagle/ChangeLog,v 1.12 2010/06/23 11:24:39 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/beagle/ChangeLog,v 1.13 2012/04/26 15:40:11 jlec Exp $
+
+ 26 Apr 2012; Justin Lecher <jlec@gentoo.org> beagle-3.0.3.ebuild,
+ metadata.xml:
+ Move to EAPI=4, handle static-libs, use autotools-utils.eclass
23 Jun 2010; Justin Lecher <jlec@gentoo.org> -beagle-2.2.0.ebuild:
Cleaned old version
diff --git a/sci-libs/beagle/beagle-3.0.3.ebuild b/sci-libs/beagle/beagle-3.0.3.ebuild
index cae92ac99034..3ef6944b9b9d 100644
--- a/sci-libs/beagle/beagle-3.0.3.ebuild
+++ b/sci-libs/beagle/beagle-3.0.3.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/beagle/beagle-3.0.3.ebuild,v 1.3 2010/06/23 11:23:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/beagle/beagle-3.0.3.ebuild,v 1.4 2012/04/26 15:40:11 jlec Exp $
-inherit eutils
+EAPI=4
+
+inherit autotools-utils
DESCRIPTION="Open BEAGLE, a versatile EC/GA/GP framework"
SRC_URI="mirror://sourceforge/beagle/${P}.tar.gz"
@@ -11,39 +13,43 @@ HOMEPAGE="http://beagle.gel.ulaval.ca/"
SLOT="0"
LICENSE="LGPL-2.1"
KEYWORDS="x86"
-IUSE="doc"
+IUSE="doc static-libs"
-RDEPEND="sys-libs/zlib
+RDEPEND="
+ sys-libs/zlib
!app-misc/beagle
!dev-libs/libbeagle"
DEPEND="${DEPEND}
doc? ( app-doc/doxygen )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-3.0.3-gcc43.patch
+PATCHES=( "${FILESDIR}"/${PN}-3.0.3-gcc43.patch )
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ autotools-utils_src_prepare
sed -e "s:@LIBS@:@LIBS@ -lpthread:" \
-i PACC/Threading/Makefile.in || \
die "Failed to fix threading libs makefile."
}
+src_configure() {
+ local myeconfargs=( --enable-optimization )
+ autotools-utils_src_configure
+}
+
src_compile() {
- econf --enable-optimization || die "Configure failed."
- emake || die "Make failed."
+ autotools-utils_src_compile
- if use doc; then
- make doc || die "Failed to generate docs."
- fi
+ use doc && autotools-utils_src_compile doc
}
src_install () {
- emake install DESTDIR="${D}" || die
- dodoc AUTHORS ChangeLog NEWS README TODO
+ autotools-utils_src_install
if use doc; then
cp -pPR examples "${D}"/usr/share/doc/${PF} || \
die "Failed to install examples."
- dohtml -r refman/* || die "Failed to install manual."
+ dohtml -r refman/*
fi
}
diff --git a/sci-libs/beagle/metadata.xml b/sci-libs/beagle/metadata.xml
index dce86978cdfb..47d9e0fe5467 100644
--- a/sci-libs/beagle/metadata.xml
+++ b/sci-libs/beagle/metadata.xml
@@ -1,8 +1,8 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription>
+ <herd>sci</herd>
+ <longdescription>
Open BEAGLE is a C++ Evolutionary Computation (EC) framework. It provides an high-level software environment to do any kind of EC, with support for tree-based genetic programming, bit string and real-valued genetic algorithms, and evolution strategy.
</longdescription>
</pkgmetadata>