summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/speech-dispatcher/ChangeLog9
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.8-r2.ebuild5
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.8.1-r1.ebuild109
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.8.1.ebuild5
4 files changed, 14 insertions, 114 deletions
diff --git a/app-accessibility/speech-dispatcher/ChangeLog b/app-accessibility/speech-dispatcher/ChangeLog
index bf0b05fa0b50..8b917c098782 100644
--- a/app-accessibility/speech-dispatcher/ChangeLog
+++ b/app-accessibility/speech-dispatcher/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-accessibility/speech-dispatcher
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.113 2014/12/05 19:35:26 teiresias Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.114 2014/12/05 20:46:00 teiresias Exp $
+
+ 05 Dec 2014; Christopher Brannon <teiresias@gentoo.org>
+ speech-dispatcher-0.8-r2.ebuild, speech-dispatcher-0.8.1.ebuild,
+ -speech-dispatcher-0.8.1-r1.ebuild:
+ Add pyxdg to speech-dispatcher-0.8-r2 and speech-dispatcher-0.8.1.
+
+ Turns out that a revbump was not needed. 0.8.1-r1 is not needed.
*speech-dispatcher-0.8.1-r1 (05 Dec 2014)
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.8-r2.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.8-r2.ebuild
index e228227c6a21..71a14495587a 100644
--- a/app-accessibility/speech-dispatcher/speech-dispatcher-0.8-r2.ebuild
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.8-r2.ebuild,v 1.15 2014/11/23 17:23:43 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.8-r2.ebuild,v 1.16 2014/12/05 20:46:00 teiresias Exp $
EAPI=5
@@ -32,7 +32,8 @@ COMMON_DEPEND="python? ( ${PYTHON_DEPS} )
DEPEND="${COMMON_DEPEND}
>=dev-util/intltool-0.40.0
virtual/pkgconfig"
- RDEPEND="${COMMON_DEPEND}"
+ RDEPEND="${COMMON_DEPEND}
+ dev-python/pyxdg"
src_configure() {
local myeconfargs=(
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.8.1-r1.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.8.1-r1.ebuild
deleted file mode 100644
index 52cc081c9c3d..000000000000
--- a/app-accessibility/speech-dispatcher/speech-dispatcher-0.8.1-r1.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.8.1-r1.ebuild,v 1.1 2014/12/05 19:35:26 teiresias Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_2 python3_3 python3_4 )
-
-inherit eutils python-r1
-
-DESCRIPTION="Speech synthesis interface"
-HOMEPAGE="http://www.freebsoft.org/speechd"
-SRC_URI="http://www.freebsoft.org/pub/projects/speechd/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="alsa ao +espeak flite nas pulseaudio python static-libs"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-COMMON_DEPEND="python? ( ${PYTHON_DEPS} )
- >=dev-libs/dotconf-1.3
- >=dev-libs/glib-2.28:2
- >=media-libs/libsndfile-1.0.2
- alsa? ( media-libs/alsa-lib )
- ao? ( media-libs/libao )
- espeak? ( app-accessibility/espeak )
- flite? ( app-accessibility/flite )
- nas? ( media-libs/nas )
- pulseaudio? ( media-sound/pulseaudio )"
-DEPEND="${COMMON_DEPEND}
- >=dev-util/intltool-0.40.0
- virtual/pkgconfig"
- RDEPEND="${COMMON_DEPEND}
- dev-python/pyxdg"
-
-src_configure() {
- local myeconfargs=(
- --disable-python
- $(use_enable static-libs static)
- $(use_with alsa)
- $(use_with ao libao)
- $(use_with espeak)
- $(use_with flite)
- $(use_with pulseaudio pulse)
- $(use_with nas)
- )
- econf ${myeconfargs[@]}
-}
-
-src_compile() {
- use python && python_copy_sources
-
- emake
-
- if use python; then
- building() {
- cd src/api/python || die
- emake \
- pyexecdir="$(python_get_sitedir)" \
- pythondir="$(python_get_sitedir)"
- }
- python_foreach_impl run_in_build_dir building
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc ANNOUNCE AUTHORS BUGS ChangeLog FAQ NEWS README*
-
- prune_libtool_files --all
-
- if use python; then
- installation() {
- cd src/api/python || die
- emake \
- DESTDIR="${D}" \
- pyexecdir="$(python_get_sitedir)" \
- pythondir="$(python_get_sitedir)" \
- install
- }
- python_foreach_impl run_in_build_dir installation
- python_replicate_script "${ED}"/usr/bin/spd-conf
- fi
-}
-
-pkg_postinst() {
- local editconfig="n"
- if ! use espeak; then
- ewarn "You have disabled espeak, which is speech-dispatcher's"
- ewarn "default speech synthesizer."
- ewarn
- editconfig="y"
- fi
- if ! use pulseaudio; then
- ewarn "You have disabled pulseaudio support."
- ewarn "pulseaudio is speech-dispatcher's default audio subsystem."
- ewarn
- editconfig="y"
- fi
- if [[ "${editconfig}" == "y" ]]; then
- ewarn "You must edit ${EROOT}etc/speech-dispatcher/speechd.conf"
- ewarn "and make sure the settings there match your system."
- ewarn
- fi
- elog "For festival support, you need to"
- elog "install app-accessibility/festival-freebsoft-utils."
-}
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.8.1.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.8.1.ebuild
index ade729b58966..3ffd0dd5791f 100644
--- a/app-accessibility/speech-dispatcher/speech-dispatcher-0.8.1.ebuild
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.8.1.ebuild,v 1.8 2014/12/05 10:16:45 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.8.1.ebuild,v 1.9 2014/12/05 20:46:00 teiresias Exp $
EAPI=5
@@ -32,7 +32,8 @@ COMMON_DEPEND="python? ( ${PYTHON_DEPS} )
DEPEND="${COMMON_DEPEND}
>=dev-util/intltool-0.40.0
virtual/pkgconfig"
- RDEPEND="${COMMON_DEPEND}"
+ RDEPEND="${COMMON_DEPEND}
+ dev-python/pyxdg"
src_configure() {
local myeconfargs=(