summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/system-config-printer-gnome/files/system-config-printer-gnome-1.4.1-split.patch')
-rw-r--r--app-admin/system-config-printer-gnome/files/system-config-printer-gnome-1.4.1-split.patch177
1 files changed, 177 insertions, 0 deletions
diff --git a/app-admin/system-config-printer-gnome/files/system-config-printer-gnome-1.4.1-split.patch b/app-admin/system-config-printer-gnome/files/system-config-printer-gnome-1.4.1-split.patch
new file mode 100644
index 000000000000..84a93bf298f2
--- /dev/null
+++ b/app-admin/system-config-printer-gnome/files/system-config-printer-gnome-1.4.1-split.patch
@@ -0,0 +1,177 @@
+--- a/Makefile.am 2013-08-11 23:49:07.085505820 +0200
++++ b/Makefile.am 2013-08-11 23:51:57.027522515 +0200
+@@ -1,90 +1,8 @@
+-CFLAGS=-g -O2 -Wall
++AM_CFLAGS=-Wall
+
+ SUBDIRS=po
+
+-EXPORT_MODULES= \
+- cupshelpers/__init__.py \
+- cupshelpers/cupshelpers.py \
+- cupshelpers/installdriver.py \
+- cupshelpers/ppds.py \
+- cupshelpers/openprinting.py \
+- cupshelpers/xmldriverprefs.py
+-
+-EXPORT_MODULES_GEN= \
+- cupshelpers/config.py
+-
+-### Automake hooks for Distutils.
+-# The distutils module doesn't understand srcdir != builddir,
+-# so we copy in, along with the cupshelpers modules, into
+-# the builddir for 'all', 'install-exec', and 'clean' hooks.
+-.stamp-distutils-in-builddir: setup.py $(EXPORT_MODULES)
+- if [ "$(top_srcdir)" != "$(top_builddir)" ]; then \
+- cp $(top_srcdir)/setup.py .; \
+- $(mkdir_p) cupshelpers; \
+- for file in $(EXPORT_MODULES); do \
+- cp $(top_srcdir)/$$file $$file; \
+- done; \
+- fi
+- touch .stamp-distutils-in-builddir
+-
+-dist-hook: mk-ChangeLog
+-.PHONE: mk-ChangeLog
+-mk-ChangeLog:
+- if test -d .git; then \
+- $(top_srcdir)/gitlog-to-changelog \
+- --since=2009-05-01 -- --no-merges \
+- > $(distdir)/cl ; \
+- mv -f $(distdir)/cl $(distdir)/ChangeLog ; \
+- fi
+-
+-config.py: config.py.in Makefile
+- sed \
+- -e "s|\@prefix\@|$(prefix)|" \
+- -e "s|\@datadir\@|$(datadir)|" \
+- -e "s|\@localedir\@|$(localedir)|" \
+- -e "s|\@VERSION\@|$(VERSION)|" \
+- -e "s|\@PACKAGE\@|$(PACKAGE)|" \
+- $< > $@
+-
+-cupshelpers/config.py: cupshelpers/config.py.in Makefile
+- $(mkdir_p) cupshelpers
+- sed \
+- -e "s|\@prefix\@|$(prefix)|" \
+- -e "s|\@sysconfdir\@|$(sysconfdir)|" \
+- -e "s|\@cupsserverbindir\@|$(cupsserverbindir)|" \
+- $< > $@
+-
+-# Use distutils to build the module.
+-all-local: .stamp-distutils-in-builddir config.py cupshelpers/config.py
+- $(PYTHON) setup.py build
+-
+-# Use distutils to install the module.
+-install-exec-local: .stamp-distutils-in-builddir
+- $(PYTHON) setup.py install --prefix=$(DESTDIR)$(prefix)
+-
+-# Uninstall the module, crossing our fingers that we know enough
+-# about how distutils works to do this. Unfortunately, distutils
+-# doesn't provide a way to do this itself.
+-uninstall-local:
+- rm -f $(DESTDIR)/$(pythondir)/cupshelpers*.egg-info
+- for file in $(EXPORT_MODULES) $(EXPORT_MODULES_GEN); do \
+- rm -f $(DESTDIR)/$(pythondir)/$$file*; \
+- done
+-
+-# Tell distutils to clean up.
+-clean-local:
+- -$(PYTHON) setup.py clean --all
+- if [ "$(top_srcdir)" != "$(top_builddir)" ]; then \
+- rm -f setup.py; \
+- for file in $(EXPORT_MODULES) \
+- $(EXPORT_MODULES_GEN); do \
+- rm -f $$file*; \
+- done; \
+- fi
+- rm -f .stamp-distutils-in-builddir
+-
+ nobase_pkgdata_SCRIPTS= \
+- check-device-ids.py \
+ pysmb.py \
+ scp-dbus-service.py \
+ system-config-printer.py \
+@@ -97,31 +15,19 @@
+ asyncipp.py \
+ asyncpk1.py \
+ authconn.py \
+- config.py \
+ cupspk.py \
+- debug.py \
+- dnssdresolve.py \
+ errordialogs.py \
+ HIG.py \
+- firewallsettings.py \
+ gui.py \
+ gtkinklevel.py \
+- installpackage.py \
+ jobviewer.py \
+- monitor.py \
+ newprinter.py \
+ options.py \
+ optionwidgets.py \
+- PhysicalDevice.py \
+ ppdcache.py \
+- ppdippstr.py \
+ ppdsloader.py \
+ printerproperties.py \
+- probe_printer.py \
+- SearchCriterion.py \
+ serversettings.py \
+- smburi.py \
+- statereason.py \
+ timedops.py \
+ ToolbarSearchEntry.py \
+ userdefault.py \
+@@ -164,9 +70,7 @@
+ troubleshoot/ServerFirewalled.py \
+ troubleshoot/Shrug.py \
+ troubleshoot/VerifyPackages.py \
+- troubleshoot/Welcome.py \
+- xml/preferreddrivers.rng \
+- xml/validate.py
++ troubleshoot/Welcome.py
+
+ cupshelpersdir=$(sysconfdir)/cupshelpers
+ cupshelpers_DATA=\
+@@ -178,39 +82,10 @@
+ system-config-printer-applet \
+ dbus/scp-dbus-service
+
+-if UDEV_RULES
+-udevrulesdir=$(sysconfdir)/udev/rules.d
+-udevrules_DATA=udev/70-printers.rules
+-udev_udev_configure_printer_SOURCES=\
+- udev/udev-configure-printer.c
+-udev_udev_configure_printer_LDADD= -lcups -ludev $(libusb_LIBS) $(GLIB_LIBS)
+-udev_udev_configure_printer_CFLAGS= $(AM_CFLAGS) $(libusb_CFLAGS) $(GLIB_CFLAGS)
+-udevhelperdir=$(sysconfdir)/udev
+-udevhelper_PROGRAMS=\
+- udev/udev-configure-printer
+-udevhelper_SCRIPTS=\
+- udev/udev-add-printer
+-
+-if HAVE_SYSTEMD
+-%.service: %.service.in
+- $(AM_V_GEN)sed -e 's,@udevhelperdir\@,$(udevhelperdir),g' $< > $@
+-systemdsystemunit_DATA = \
+- udev/configure-printer@.service
+-CLEANFILES = \
+- $(systemdsystemunit_DATA)
+-endif
+-
+-endif
+-
+ man_MANS= \
+ man/system-config-printer.1 \
+ man/system-config-printer-applet.1
+
+-dbus_DATA = \
+- dbus/com.redhat.NewPrinterNotification.conf \
+- dbus/com.redhat.PrinterDriversInstaller.conf
+-dbusdir = $(sysconfdir)/dbus-1/system.d/
+-
+ dbusinterfaces_DATA = \
+ dbus/org.fedoraproject.Config.Printing.xml
+ dbusinterfacesdir = $(datadir)/dbus-1/interfaces/