summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/file-roller/file-roller-2.8.3.ebuild')
-rw-r--r--app-arch/file-roller/file-roller-2.8.3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-arch/file-roller/file-roller-2.8.3.ebuild b/app-arch/file-roller/file-roller-2.8.3.ebuild
new file mode 100644
index 000000000000..97c01af50060
--- /dev/null
+++ b/app-arch/file-roller/file-roller-2.8.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/file-roller-2.8.3.ebuild,v 1.1 2004/11/24 17:20:10 obz Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="archive manager for GNOME"
+HOMEPAGE="http://fileroller.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa ~amd64 ~ia64 ~mips ~ppc64"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2
+ >=x11-libs/gtk+-2.4*
+ >=gnome-base/libgnome-2.1
+ >=gnome-base/libgnomeui-2.1
+ >=gnome-base/gnome-vfs-2.2
+ >=gnome-base/libglade-2
+ >=gnome-base/libbonobo-2
+ >=gnome-base/libbonoboui-2"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.29
+ >=app-text/scrollkeeper-0.3.11"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README TODO"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ # Use absolute path to GNU tar since star doesn't have the same
+ # options. On Gentoo, star is /usr/bin/tar, GNU tar is /bin/tar
+ epatch ${FILESDIR}/${PN}-2.8.0-use_bin_tar.patch
+ # use a local rpm2cpio script to avoid the dep
+ epatch ${FILESDIR}/${PN}-2.6-use_fr_rpm2cpio.patch
+
+}
+
+src_install() {
+
+ gnome2_src_install
+ dobin ${FILESDIR}/rpm2cpio-file-roller
+
+}