summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/p7zip/p7zip-4.42.ebuild')
-rw-r--r--app-arch/p7zip/p7zip-4.42.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/app-arch/p7zip/p7zip-4.42.ebuild b/app-arch/p7zip/p7zip-4.42.ebuild
new file mode 100644
index 000000000000..ca55ead38fa7
--- /dev/null
+++ b/app-arch/p7zip/p7zip-4.42.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-4.42.ebuild,v 1.1 2006/05/28 17:14:32 radek Exp $
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="Port of 7-Zip archiver for Unix"
+HOMEPAGE="http://p7zip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}_src_all.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~hppa ~ppc ~x86"
+IUSE="static doc"
+
+S=${WORKDIR}/${PN}_${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ use static && epatch "${FILESDIR}"/p7zip-4.16_x86_static.patch
+ # be aware that CXX is now gcc in pattern due to upstream (radek@20060318)
+ sed -i \
+ -e "/^CXX=/s:gcc:$(tc-getCXX):" \
+ -e "/^CC=/s:gcc:$(tc-getCC):" \
+ -e "s:OPTFLAGS=-O:OPTFLAGS=${CXXFLAGS}:" \
+ makefile* || die "changing makefiles"
+
+ if use amd64; then
+ ewarn "Using suboptimal -fPIC upstream makefile due to amd64 being detected. See #126722"
+ cp -f makefile.linux_amd64 makefile.machine
+ fi
+}
+
+src_compile() {
+ emake all3 || die "compilation error"
+}
+
+src_install() {
+ # this wrappers can not be symlinks, p7zip should be called with full path
+ make_wrapper 7zr "/usr/lib/${PN}/7zr"
+ make_wrapper 7za "/usr/lib/${PN}/7za"
+ make_wrapper 7z "/usr/lib/${PN}/7z"
+
+ dobin ${FILESDIR}/p7zip
+
+ # gzip introduced in 4.42 but i havent' got enough time to check it carefully
+ # so for now just leaving it commented
+ # mv needed just as rename, because dobin installs using old name
+ #mv contrib/gzip-like_CLI_wrapper_for_7z/p7zip contrib/gzip-like_CLI_wrapper_for_7z/7zg
+ #dobin contrib/gzip-like_CLI_wrapper_for_7z/7zg
+
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe bin/7z bin/7za bin/7zr bin/7zCon.sfx || die "doexe bins"
+ exeinto /usr/$(get_libdir)/${PN}/Codecs
+ doexe bin/Codecs/* || die "doexe Codecs"
+ exeinto /usr/$(get_libdir)/${PN}/Formats
+ doexe bin/Formats/* || die "doexe Formats"
+
+ doman man1/7z.1 man1/7za.1 man1/7zr.1
+ dodoc ChangeLog README TODO
+
+ if use doc ; then
+ dodoc DOCS/*.txt
+ dohtml -r DOCS/MANUAL/*
+ fi
+}