summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/xcdroast/xcdroast-0.98_alpha14.ebuild')
-rw-r--r--app-cdr/xcdroast/xcdroast-0.98_alpha14.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-cdr/xcdroast/xcdroast-0.98_alpha14.ebuild b/app-cdr/xcdroast/xcdroast-0.98_alpha14.ebuild
new file mode 100644
index 000000000000..6ae303b319da
--- /dev/null
+++ b/app-cdr/xcdroast/xcdroast-0.98_alpha14.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/xcdroast-0.98_alpha14.ebuild,v 1.1 2003/06/14 00:04:21 pylon Exp $
+
+S=${WORKDIR}/${P/_/}
+DESCRIPTION="Menu based front-end to mkisofs and cdrecord"
+HOMEPAGE="http://www.xcdroast.org/"
+SRC_URI="mirror://sourceforge/xcdroast/${P/_/}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+IUSE="nls"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2*
+ >=media-libs/gdk-pixbuf-0.16.0
+ >=media-libs/giflib-3.0
+ >=app-cdr/cdrtools-2.0"
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die
+ make PREFIX=/usr || die
+}
+
+src_install() {
+ make PREFIX=/usr DESTDIR=${D} install || die
+ #chown root.wheel ${D}/usr/bin/xcdrgtk
+ cd doc
+ dodoc DOCUMENTATION FAQ README* TRANSLATION.HOWTO
+ cd ..
+
+ # move man pages to /usr/share/man to be LFH compliant
+ mv ${D}/usr/man ${D}/usr/share
+
+ #remove extraneous directory
+ rm ${D}/usr/etc -rf
+}