summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnupg/ChangeLog8
-rw-r--r--app-crypt/gnupg/files/digest-gnupg-2.0.4-r13
-rw-r--r--app-crypt/gnupg/files/gnupg-2.0.4-idea.patch25
-rw-r--r--app-crypt/gnupg/gnupg-2.0.4-r1.ebuild84
4 files changed, 119 insertions, 1 deletions
diff --git a/app-crypt/gnupg/ChangeLog b/app-crypt/gnupg/ChangeLog
index bb5b4c7dfbc2..cbf51db44f62 100644
--- a/app-crypt/gnupg/ChangeLog
+++ b/app-crypt/gnupg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/gnupg
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.293 2007/06/13 08:05:52 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.294 2007/06/22 16:47:52 alonbl Exp $
+
+*gnupg-2.0.4-r1 (22 Jun 2007)
+
+ 22 Jun 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/gnupg-2.0.4-idea.patch, +gnupg-2.0.4-r1.ebuild:
+ Add IDEA workaround, bug#159870, thanks to so many people.
13 Jun 2007; Alon Bar-Lev <alonbl@gentoo.org> gnupg-1.9.21.ebuild,
gnupg-1.9.21-r1.ebuild, gnupg-1.9.22.ebuild, gnupg-1.9.94.ebuild,
diff --git a/app-crypt/gnupg/files/digest-gnupg-2.0.4-r1 b/app-crypt/gnupg/files/digest-gnupg-2.0.4-r1
new file mode 100644
index 000000000000..8a145e05228d
--- /dev/null
+++ b/app-crypt/gnupg/files/digest-gnupg-2.0.4-r1
@@ -0,0 +1,3 @@
+MD5 e16efce067ba132f933792a3ec7f180e gnupg-2.0.4.tar.bz2 3575021
+RMD160 7d31526012e32c2fe39fea62c01b5c17d16118ad gnupg-2.0.4.tar.bz2 3575021
+SHA256 3872d7280e5a12a947509c73b70c3024521c29ff4427c8fb4caa17dde2f4248c gnupg-2.0.4.tar.bz2 3575021
diff --git a/app-crypt/gnupg/files/gnupg-2.0.4-idea.patch b/app-crypt/gnupg/files/gnupg-2.0.4-idea.patch
new file mode 100644
index 000000000000..aa65cc9f7ac5
--- /dev/null
+++ b/app-crypt/gnupg/files/gnupg-2.0.4-idea.patch
@@ -0,0 +1,25 @@
+
+This is required in order to support IDEA encrypted keys
+using gnupg-1.4.X. The raw key has two bytes which are part
+of the checksum but not part of the key.
+
+This will not get into upstream as upstream does not wish to support
+IDEA at all even for backward compatibility.
+
+Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org>
+
+diff -urNp gnupg-2.0.4.org/g10/seckey-cert.c gnupg-2.0.4/g10/seckey-cert.c
+--- gnupg-2.0.4.org/g10/seckey-cert.c 2006-11-21 10:26:13.000000000 +0200
++++ gnupg-2.0.4/g10/seckey-cert.c 2007-06-22 18:08:48.000000000 +0300
+@@ -211,6 +211,11 @@ do_check( PKT_secret_key *sk, const char
+ csum += checksum (buffer, ndata);
+ gcry_mpi_release (sk->skey[i]);
+
++ if (sk->protect.algo==CIPHER_ALGO_IDEA) {
++ buffer[0] = 0;
++ buffer[1] = 0;
++ }
++
+ err = gcry_mpi_scan( &sk->skey[i], GCRYMPI_FMT_USG,
+ buffer, ndata, &ndata );
+ xfree (buffer);
diff --git a/app-crypt/gnupg/gnupg-2.0.4-r1.ebuild b/app-crypt/gnupg/gnupg-2.0.4-r1.ebuild
new file mode 100644
index 000000000000..ca68f65a224b
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-2.0.4-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-2.0.4-r1.ebuild,v 1.1 2007/06/22 16:47:52 alonbl Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="mirror://gnupg/gnupg/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="bzip2 doc ldap nls openct pcsc-lite smartcard selinux"
+
+COMMON_DEPEND="
+ virtual/libc
+ >=dev-libs/pth-1.3.7
+ >=dev-libs/libgcrypt-1.2.0
+ >=dev-libs/libksba-1.0.0
+ >=dev-libs/libgpg-error-1.4
+ >=net-misc/curl-7.7.2
+ bzip2? ( app-arch/bzip2 )
+ pcsc-lite? ( >=sys-apps/pcsc-lite-1.3.0 )
+ openct? ( >=dev-libs/openct-0.5.0 )
+ ldap? ( net-nds/openldap )
+ app-crypt/pinentry"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/libassuan-1.0.1
+ nls? ( sys-devel/gettext )
+ doc? ( sys-apps/texinfo )"
+
+RDEPEND="${COMMON_DEPEND}
+ !app-crypt/gpg-agent
+ !<=app-crypt/gnupg-2.0.1
+ virtual/mta
+ selinux? ( sec-policy/selinux-gnupg )
+ nls? ( virtual/libintl )"
+
+src_compile() {
+ append-ldflags $(bindnow-flags)
+
+ econf \
+ --enable-symcryptrun \
+ --enable-gpg \
+ --enable-gpgsm \
+ --enable-agent \
+ $(use_enable bzip2) \
+ $(use_enable smartcard scdaemon) \
+ $(use_enable nls) \
+ $(use_enable ldap) \
+ --disable-capabilities \
+ || die
+ emake || die
+ if use doc; then
+ cd doc
+ emake html || die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-idea.patch"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc ChangeLog NEWS README THANKS TODO VERSION
+
+ dosym gpg2 /usr/bin/gpg
+ dosym gpgv2 /usr/bin/gpgv
+ echo ".so man1/gpg2.1" > "${D}/usr/share/man/man1/gpg.1"
+ echo ".so man1/gpgv2.1" > "${D}/usr/share/man/man1/gpgv.1"
+
+ use doc && dohtml doc/gnupg.html/* doc/*jpg doc/*png
+}
+
+pkg_postinst() {
+ elog "If you wish to view images emerge:"
+ elog "media-gfx/xloadimage, media-gfx/xli or any other viewer"
+ elog "Remember to use photo-viewer option in configuration file to activate the right viewer"
+}