summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/emacs/emacs-22.1-r3.ebuild')
-rw-r--r--app-editors/emacs/emacs-22.1-r3.ebuild30
1 files changed, 18 insertions, 12 deletions
diff --git a/app-editors/emacs/emacs-22.1-r3.ebuild b/app-editors/emacs/emacs-22.1-r3.ebuild
index 4484f2718b2f..8a820ce35cbe 100644
--- a/app-editors/emacs/emacs-22.1-r3.ebuild
+++ b/app-editors/emacs/emacs-22.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-22.1-r3.ebuild,v 1.16 2008/01/22 07:56:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-22.1-r3.ebuild,v 1.17 2008/01/30 20:36:59 ulm Exp $
WANT_AUTOCONF="2.5"
WANT_AUTOMAKE="latest"
@@ -44,6 +44,8 @@ RDEPEND="!<app-editors/emacs-cvs-22.1
)"
DEPEND="${RDEPEND}
+ alsa? ( dev-util/pkgconfig )
+ gtk? ( dev-util/pkgconfig )
gzip-el? ( app-arch/gzip )"
# FULL_VERSION keeps the full version number, which is needed in order to
@@ -54,9 +56,24 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}/${P}-Xaw3d-headers.patch"
+ epatch "${FILESDIR}/${P}-freebsd-sparc.patch"
+ epatch "${FILESDIR}/${P}-oldxmenu-qa.patch"
+ epatch "${FILESDIR}/${P}-backup-buffer.patch"
+ epatch "${FILESDIR}/${P}-hack-local-variables.patch"
+ epatch "${FILESDIR}/${P}-format-int.patch"
+ epatch "${FILESDIR}/${P}-s390x-non-multilib.patch"
+
sed -i -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
-e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
"${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
+
+ if ! use alsa; then
+ # ALSA is detected even if not requested by its USE flag.
+ # Suppress it by supplying pkg-config with a wrong library name.
+ sed -i -e "/ALSA_MODULES=/s/alsa/DiSaBlEaLsA/" configure.in \
+ || die "unable to sed configure.in"
+ fi
if ! use gzip-el; then
# Emacs' build system automatically detects the gzip binary and
# compresses el files. We don't want that so confuse it with a
@@ -65,17 +82,6 @@ src_unpack() {
|| die "unable to sed configure.in"
fi
- epatch "${FILESDIR}/${P}-Xaw3d-headers.patch"
- epatch "${FILESDIR}/${P}-freebsd-sparc.patch"
- epatch "${FILESDIR}/${P}-oldxmenu-qa.patch"
- epatch "${FILESDIR}/${P}-backup-buffer.patch"
- epatch "${FILESDIR}/${P}-hack-local-variables.patch"
- epatch "${FILESDIR}/${P}-format-int.patch"
- epatch "${FILESDIR}/${P}-s390x-non-multilib.patch"
- # ALSA is detected and used even if not requested by the USE=alsa flag.
- # So remove the automagic check
- use alsa || epatch "${FILESDIR}/${P}-disable_alsa_detection.patch"
-
eautoreconf
}