summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/ted')
-rw-r--r--app-editors/ted/ChangeLog9
-rw-r--r--app-editors/ted/ted-2.22.ebuild58
2 files changed, 65 insertions, 2 deletions
diff --git a/app-editors/ted/ChangeLog b/app-editors/ted/ChangeLog
index bfe60b681c5e..f6876c3a1d67 100644
--- a/app-editors/ted/ChangeLog
+++ b/app-editors/ted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/ted
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ChangeLog,v 1.48 2012/05/03 18:33:03 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ChangeLog,v 1.49 2013/01/30 05:26:06 patrick Exp $
+
+*ted-2.22 (30 Jan 2013)
+
+ 30 Jan 2013; Patrick Lauer <patrick@gentoo.org> +ted-2.22.ebuild:
+ Bump
03 May 2012; Jeff Horelick <jdhore@gentoo.org> ted-2.21.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/app-editors/ted/ted-2.22.ebuild b/app-editors/ted/ted-2.22.ebuild
new file mode 100644
index 000000000000..db3e8b0eabe2
--- /dev/null
+++ b/app-editors/ted/ted-2.22.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.22.ebuild,v 1.1 2013/01/30 05:26:05 patrick Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="X-based rich text editor"
+HOMEPAGE="http://www.nllgg.nl/Ted"
+SRC_URI="ftp://ftp.nluug.nl/pub/editors/ted/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ media-libs/tiff
+ virtual/jpeg
+ media-libs/libpng
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/Ted-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.21-make.patch
+
+ sed -i -e 's|/Ted/|/share/Ted/|' \
+ "${S}"/appFrame/appFrameConfig.h.in \
+ "${S}"/Ted/tedConfig.h.in || die
+
+ mkdir lib || die
+}
+
+src_configure() {
+ tc-export CC
+
+ local dir
+ for dir in appFrame appUtil bitmap docBuf ind Ted tedPackage; do
+ cd "${S}"/${dir}
+ econf --cache-file=../config.cache || die "configure in ${dir} failed"
+ done
+}
+
+src_compile() {
+ emake package.shared
+}
+
+src_install() {
+ cd tedPackage
+ RPM_BUILD_ROOT=${D} ./installTed.sh COMMON || die
+
+ dodir /usr/share
+ mv "${ED}"usr/Ted "${ED}"usr/share/Ted
+ dosym /usr/share/Ted/rtf2pdf.sh /usr/bin/rtf2pdf.sh
+}