summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/eieio/eieio-0.17.ebuild')
-rw-r--r--app-emacs/eieio/eieio-0.17.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/eieio/eieio-0.17.ebuild b/app-emacs/eieio/eieio-0.17.ebuild
new file mode 100644
index 000000000000..a739f3f12b9c
--- /dev/null
+++ b/app-emacs/eieio/eieio-0.17.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/eieio/eieio-0.17.ebuild,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Enhanced Integration of Emacs Interpreted Objects"
+HOMEPAGE="http://cedet.sourceforge.net/eieio.shtml"
+SRC_URI="mirror://sourceforge/cedet/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs
+ app-emacs/speedbar"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=60eieio-gentoo.el
+
+src_compile() {
+ make LOADPATH=${SITELISP}/speedbar || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+
+ dodoc ChangeLog INSTALL
+ doinfo eieio.info
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}